StoreVirtual Storage
Showing results for 
Search instead for 
Did you mean: 

Upgrade of CMC from 12.0 to 12.5 fails

Occasional Contributor

Upgrade of CMC from 12.0 to 12.5 fails

I am trying to updgrade my 12.0 CMC to 12.5. I have an offline installation so I followed the instructions in the Upgrade Guide. I installed the CMC on a machine which had Internet access and downloaded all of the updates. I then copied those to the Program Files (x86)/HP/StoreVirtual/UI/Download directory on my offline CMC. I started my CMC and it automatically recognized that there were Updates Available. Pretty straightforward and everything was looking good at this point.


I click on "Updates Available" and it shows that my Centralized Management Console has an available upgrade to 12.5.00. I click on "Continue" and get a popup that says I am "About to install CMC Version" and I click Install. I get the InstallAnwhere screen with the progress bar and after a few seconds, it gives me a popup which says "Please select another location to extract the files to" I pick the Temp Directory and it extracts the files and comes back to the same place. I can do this forever but it never gets to the next step in the install (Each time it creates a new temporary directory with a bunch of files). My only choices are to either Extract or Cancel. I tried Cancel and went to the Extracted directories and tried running the installer but it gives me a Java error.


Anyone have any ideas? What am I doing wrong? Thanks



Honored Contributor

Re: Upgrade of CMC from 12.0 to 12.5 fails


you can download the installation file directly frpm HP ftp


and run it not through CMC update it looks like you have a windows problem

not a CMC problem . try extarcting the file first and running CMC_Installer.exe 

from created windows directory



If this helped give a Kudo


Occasional Visitor

Re: Upgrade of CMC from 12.0 to 12.5 fails

I ran into this same issue and found that the installer was corrupt. Downloaded directly from the HP site and ran it manually (not through CMC) and it worked. It will find a previous version of CMC on the box and perform the upgrade, no need to do it through CMC.