Switches, Hubs, and Modems
Showing results for 
Search instead for 
Did you mean: 

Problem with configuring Procurve 1800-24g with Ruckus Wireless LAN with VLAN settings

Occasional Contributor

Problem with configuring Procurve 1800-24g with Ruckus Wireless LAN with VLAN settings

Hi Everyone, this is bugging me for a while now and i realized no one in the web encountered this problem.

If you can solve this, i'll call you a guru and probably even make you my mentor. Ha! You should also probably work for a HP as a consultant!



1) we have 2x 1800-24g switches. linked up together on port 24 via CAT-6 cabling. the one in Level-1, i call it Switch A, the one in Level-4, i call it Switch B.

2) i have a DHCP server connected to Switch A, port 18

3) i have Zone Director WIFI controller connected to Switch A, port 20

4) i have a ZoneFlex 7343 Access Point to Switch A, port 24

5) SwitchA and SwitchB connection is at port 23.

6) I have a router for internet connection at Switch A, port 17

7) I have another Zoneflex 7343 Access Point to Switch B on port 24 too!

8) I have 3 VLANs

   VLAN-1 = Management VLAN for zone director, and the switches. All servers are on VLAN1, PVID1

   VLAN-2 = Guest VLAN

   VLAN-3 = Office Users VLAN

9) For port 17, 18, 20 - they are all on VLAN 1, but tagged with VLAN 2 and 3. PVID set to 1

10) Goal is that office connected users will not see the guest users, vice-versa. But they are all able to share a single DHCP server and access the same server, gateway and Zone-director.

11) both VLAN 2 and 3 are in the same subnet.

12) Everything is working great...except for WIFI - if the signal is VLAN tagged.



1) i set-up Zone Director with 2 set of SSIDs (Guest and Internal)

2) if i don't VLAN Tag the signal, all works fine... but once i tag the Guest network to VLAN-2, no DHCP signal will be given.

3) i have ticked the 'vlan aware' option, but it does not help.

4) i have ensured that I can get DHCP on port 24 where the AP is, therefore if I don't tag this to any VLAN, it'll work.

5) in my other Zonedirector implementation with Netgear and Dell switches, I was able to simply configure the port mode to General instead of Access, and it'll work. As for the communication between Switches, I just need to set it as Trunk Mode. Seems like HP doesn't have all of these config.

6) I can't enable the passed VLAN tagged only packets mode on the port, otherwise, i will lose connection from my Zone Director to the Zone-Flex AP.


[2nd Problem.. solve later]

7) I also need to configure Switch A and Switch B to transfer VLAN tags too! this is to allow transfer of the 802.1q information to the Switch-B; then I could transfer the VLAN tags to my AP that's connected to Switch-B.

8) If i can transfer the VLAN packets over from switch-A to switch-B, i can then set the same port config on switch-B port 24 to allow my level-4 AP to have the same settings.


Some Notes:

1) I can't enter the console mode to specify directly on which port should give tagged or untagged VLANs

2) based on http://www.hp.com/rnd/support/faqs/1800.htm there's no console mode for the 1800 series. :(


I am currently running wifi on VLAN-1 and all wifi connected guests can connect to any of the signals. But that's not good as it means the guest conneted users can access the main office network and the PCs and printers.


I am open to adding new devices, my initial thought is that since there's no dedicated DHCP server or gateway on VLAN-2, it might be due to that reason which is causing users to 'not-receive' IP address dynamically when connected to the guest network when VLAN-2 is enabled on the controller for the SSID.



What do you all think?