Switching and Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

Re: Aruba 2530 48G PoE+

 
Highlighted
Occasional Visitor

Aruba 2530 48G PoE+

Hi, i got at home Aruba 2530-48G and i got router Mikrotik RB4011iGS RM and i order cable Mikrotik S AO0005 SFP and my Aruba doesn't detect the cable when i connect to the port 49, please can you let me know if is any option i need to active in Aruba to be able to discover the cable or SFP is the Aruba lock-in which would prevent using 3rd party modules?

 

Pls see the picture

6 REPLIES 6
Highlighted
Honored Contributor

Re: Aruba 2530 48G PoE+

Hi! give the allow-unsupported-transceivers CLI command a try...even if I doubt allowing unsupported transceivers/DACs is going to solve your deployment issue: IMHO the issue is the MikroTik S+AO0005 Active DAC Cable not being supported on the Aruba 2530 switch.

A solution would be to switch to use SFP (or SFP+, if the Aruba 2530 you have really supports 10Gbps) Transceivers on both ends with an LC/LC Multi-Mode fiber optic patch interconnecting them: original&supported by Aruba on Switch side AND original&supported by MikroTik on Router side.

It's not clear at all what you did with that "Trk1,2"...please post sanitized running configuration of your Aruba 2530 to clarify how exactly (physically and logically) it is connected to the Router.


I'm not an HPE Employee
Kudos and Accepted Solution banner
Highlighted
Occasional Visitor

Re: Aruba 2530 48G PoE+

Pls see conf below:

hostname "HP-2530-48G-PoEP"
trunk 49 trk1 trunk
trunk 48 trk2 trunk
ip default-gateway 192.168.101.1
interface 49
speed-duplex auto-1000
exit
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
no untagged 1-30,39-46
untagged 31-38,47,50-52,Trk1-Trk2
ip address dhcp-bootp
exit
vlan 100
name "vlan PCs"
untagged 1-12
tagged Trk1-Trk2
ip address 192.168.101.2 255.255.255.0
ipv6 enable
ipv6 address autoconfig
exit
vlan 200
name "vlanTVs"
untagged 13-18,39-46
tagged Trk1-Trk2
no ip address
ipv6 enable
ipv6 address autoconfig
exit
vlan 300
name "vlanAPs"
untagged 19-20
tagged Trk1-Trk2
no ip address
ipv6 enable
ipv6 address autoconfig
exit
vlan 400
name "vlanDMZ"
untagged 21-24
tagged Trk1-Trk2
no ip address
ipv6 enable
ipv6 address autoconfig
exit
vlan 500
name "vlanCCTV"
untagged 25-30
tagged Trk1-Trk2
no ip address
ipv6 enable
ipv6 address autoconfig
exit
primary-vlan 100
management-vlan 100
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
no tftp server
no dhcp config-file-update
no dhcp image-file-update
trunk-load-balance L2-based

Honored Contributor

Re: Aruba 2530 48G PoE+

OK, I was afraid of (seeing) that...

First of all: how exactly is the uplink made to your MikroTik router from your Aruba 2530 switch?

I ask that because I see:

 

trunk 49 trk1 trunk
trunk 48 trk2 trunk

 

and that is a non sense looking at network schema you posted.

You've configured two aggregated interfaces (logical interface "trk1" and logical interface "trk2" made, respectively, by only one port each one: trk1=49, trk2=48).

An aggregated interface (called "Port Trunk" in HP/Aruba jargon) means you pick up two defaulted and identical ports (say port 12 and port 13) and then you aggregate them together in a new logical interface called "TrkX" where X is the port trunk id.

This new interface can be: static (trunk type = using no aggregation control protocol = known as non protocol) OR dynamic (lacp type = using IEEE 802.3ad LACP as aggregatione control protocol). The verys same must be done on the peer side...if you do on one side you must do exactly the same on the other side because each aggregated interface "speaks" with other aggregate interface only negotiating (or not) the new logical link over the physical members' links between the peers.

That's to say if you have 1 (one) physical link between your switch (Aruba) and your router (MikroTik) then you shouldn't use an aggregated interface because there is nothing to aggregated, on both side. 1 physical link = 1 port = NO aggregation...just a single uplink/downlink connectivity between two peers.

I suspect you were Cisco biased...where "Trunk" refers to the ability to carry multiple VLANs over an (physical/logical) interface...that could be easily done on Aruba simply by tagging/untagging that particular (physical/logical) interface...but...at first...you must clarify what is your exact topology/connectivity.


I'm not an HPE Employee
Kudos and Accepted Solution banner
Highlighted
Occasional Visitor

Re: Aruba 2530 48G PoE+

When i run the command allow-unsupported-transceiver is showing that below:

 

Highlighted
Occasional Visitor

Re: Aruba 2530 48G PoE+

Hi at the moment i did the trunk with Rj45 as i was not able to enable the trunk with optics cable

trunk 48 trk2 trunk

 

Highlighted
Honored Contributor

Re: Aruba 2530 48G PoE+

You're not clear: please explain if you're trying to aggregate two ports together or not.

IF your answer is "No, I don't want/need to aggregate ports together...I just want to work with a single link uplink from my Aruba to my MikroTik Router" THEN get rid of the port trunks defined in your Aruba 2530 ELSE you will not be able to enable communication between your Aruba Switch and your MikroTik Router.

IF indeed your Aruba switch and your MikroTik router are (or are going to be) interconnected using JUST ONE physical link (say either via Copper cable or via DAC) THEN please tag/untag that single specific port accordingly and get rid of any other "aggregated" port trk<trunk-id> which will be unused.

IF instead you WANT to work with aggregated ports (2 ports Aruba side, 2 ports MikroTik side) THEN you MUST use identical ports (identical in Speed, Duplex and - possibily - Media type)...what does that mean operatively? It means that if your DAC works, it will supposedly work at 10Gbps and copper port 48 (RJ45) will work at 1Gbps then you can't form any aggregation using these two member ports because those ports have speeds not identical (10Gbps versus 1Gbps).


I'm not an HPE Employee
Kudos and Accepted Solution banner