System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

continous '^' characters on hp 700/96 serial console with liebert multilink software installed

 
SOLVED
Go to solution
Highlighted

continous '^' characters on hp 700/96 serial console with liebert multilink software installed

hello all,
I have couple of N/4000 systems with serial consoles 700/96 and with liebert ups software MultiLink installed. As soon as the this liebert 'MultiLink' install is done, the 700/96
begins printing non-stop '^' characters. Ths os is hp-ux 11.23. regardles what setting i set the sonsole to, hp or EM100 i cannot stop the garbage characters of '^'. This ups monitoring software is certified for 11.23. I am running other N/4000 with 11.0 and 11.11 with same software without the problem. uninstalling the 'multinLink' stops the crazy characters. Any ideas?
regards
jim
Few men know where they are going
22 REPLIES 22
Highlighted
Honored Contributor

Re: continous '^' characters on hp 700/96 serial console with liebert multilink software installed

I know nothing, but ...

> [...] liebert ups software MultiLink [...]

There's only one version?

Which serial port has the MultiLink software
been told to use? I'd guess that it
shouldn't be told to use the same port as the
one which you're using for the serial
console. (I assume that an "N/4000" has more
than one serial port.)

> [...] uninstalling the 'multinLink' stops
> the crazy characters.

Before getting all drastic on it, did you try
simply using the start-stop script to stop
it? Perhaps:

/sbin/init.d/LiebertM stop

A little Google searching led to a User
Manual. (For version 1.5, which may or may
not agree with your (secret) version.)

http://shared.liebert.com/SharedDocuments/Manuals/sl_53620.pdf

Among other things (like, say, the
"Pre-Installation Checklist" and "Serial Port
Selection" for HP-UX), it also offers answers
to questions like: "HOW DO YOU CONTACT
LIEBERT FOR TECHNICAL SUPPORT?".

Who made your cable? I also see "APPENDIX B
- MAKING YOUR OWN MULTILINK UPS CABLE".
Looks to be using a couple of the
modem-control signals, with an unusual
pin-out at the UPS end.
Highlighted
Acclaimed Contributor

Re: continous '^' characters on hp 700/96 serial console with liebert multilink software installed

>> As soon as the this liebert 'MultiLink' install is done, the 700/96
begins printing non-stop '^' characters.



I assume you selected the console port instead of the UPS port. Please check!

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Highlighted

Re: continous '^' characters on hp 700/96 serial console with liebert multilink software installed

thanks for the input all
the console is cabled into the 'local console' of the N/4000.

the ups cable is a cable shiped from the vendor along with the ups unit and i know it is good because i use in in couple of other sstems

'/sbin/init.d/LiebrtM stop' stops the crazy characters but it also stops the service which also stops the ups config and the monitoring tool. defeats the purposr of having the ups.

as to the software version, i am using MultiLink 3.6 revision 4. The latest and greatest download.

Jim Synodinos
Few men know where they are going
Highlighted
Acclaimed Contributor

Re: continous '^' characters on hp 700/96 serial console with liebert multilink software installed

I assume the software asked you for the port where the UPS is connected?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Highlighted

Re: continous '^' characters on hp 700/96 serial console with liebert multilink software installed

only one choice.

jim
Few men know where they are going
Highlighted

Re: continous '^' characters on hp 700/96 serial console with liebert multilink software installed

Liebert tech support has been on this for a week with no answer.

jim
Few men know where they are going
Highlighted
Acclaimed Contributor

Re: continous '^' characters on hp 700/96 serial console with liebert multilink software installed

What was the choice?


The UPS path depends on GSP model and firmware level.


3 different paths are possible.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Highlighted
Honored Contributor

Re: continous '^' characters on hp 700/96 serial console with liebert multilink software installed

> the console is cabled into the 'local
> console' of the N/4000.

Are there other serial ports on this system?

> the ups cable [...]

Fine.

> '/sbin/init.d/LiebrtM stop' stops the crazy
> characters but it also stops the service
> [...]

I didn't expect that to fix the problem, just
to be easier and faster than uninstall and
reinstall of the whole thing.

> only one choice.

Did it have a name?
Highlighted
Honored Contributor

Re: continous '^' characters on hp 700/96 serial console with liebert multilink software installed

The n4000 has 3 serial ports, one is labeled console and should never be used for a UPS connection. All console messages are sent to this port and will be unexpected by the UPS software. The second port is the remote support modem -- just like the console, it should never be used for the UPS. It is a link to the console port. The 3rd port is called the UPS port. It should be apparent that this is the correct port.

When you said that the console is showing the ^ characters, it really sounds as if you spliced the UPS into the console cable or some other strange connection.

Put the cable into the UPS port and uninstall the UPS software. Several UPS manufacturers have very bad installers and something simple like changing the UPS port (devicefile) requires a complete removal and re-installation. NOTE: If you tried the UPS port already and it didn't work, then you have the wrong cable. The vast majority of won't-work problems are related to the 2 incompatible cables for serial connections, straight-through or cross-over.

The continuous ^ characters are probably UPS attention characters that causes the UPS to reply and start the communication protocol. You will never see these characters on the console unless you have spliced the two cables together.


Bill Hassell, sysadmin