System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Could not add a linux client to Data protector Cell manager client pool

 
SOLVED
Go to solution
Highlighted
Super Advisor

Could not add a linux client to Data protector Cell manager client pool

Hi

I have a Data Protector (v5.5) Cell Manager server, HP-UX rp4440 OS: 11i v1. I have already added lots of Linux servers and HP-UX servers into Cellmgr client pool for backup.

Yesterday, I installed two new Linux servers OS: RHES v4u6, one is Physcical server (DL380 G3) another is Vmware virtual server.

I met a problem, I could not add them into D/P Cell manger, system still let me input root passwd, I know, it's not this kind of issue.

As we know, Cellmgr and Client communciate with port 5555, so I did below checking:

1. From Cellmgr server A (HP-UX)
# telnet ClientB 5555
Trying...
telnet: Unable to connect to remote host: Connection refused

2. From Client server B (RH Linux)
# tail /etc/services
omni 5555/tcp # DATA-PROTECTOR

# iptables -L
...
ACCEPT tcp -- anywhere anywhere state NEW tcp dpt:omni
...
port 5555 already open. I did it from RH GUI desktop "Security level" add port

# netstat -an | grep 5555
nothing

what's the reason and How to fix this problem?
Whether the port 5555 did NOT real open on client server? or I lost some important steps?
Some doc said I should insert HP DP for HP-UX PA-RISC - installation server CD into client server and do "./omnisetup -install da" first, I did, but it doesn't work, install failed, it could detect omni in Clientserver.

Thank you very much, any answers will be very appreciate.
5 REPLIES 5
Highlighted
Honored Contributor
Solution

Re: Could not add a linux client to Data protector Cell manager client pool

Looks like nothing is listening on port 5555:

# netstat -an | grep 5555
nothing

As the port is not in LISTEN state, any connection has no chance of succeeding. Even without a firewall, the OS will reject all connections to any ports that are not associated with a process that's willing to accept a connection to that port.

I'm not very familiar with Data Protector, so I don't know how the DP client is supposed to start.

If it's started through (x)inetd, then maybe xinetd has not been signaled after modifying its configuration ("sh /etc/init.d/xinetd reload" should fix that). After that, netstat should display the port 5555 in state LISTEN.

If the client process should be running continuously, then the installation of the DP client has probably added a startup script in /etc/init.d. You should run it with argument "start".

MK
MK
Highlighted
Super Advisor

Re: Could not add a linux client to Data protector Cell manager client pool

Hi MK

Thank you very much for your kindly help and suggestions.

Data protector and backup client server communicate through port 5555 (by default,or you could change the port # to free one). The key issue is the port 5555 of client could not be LISTENed.
Would you please tell me how to let the system LISTEN port 5555.

reload the configuration of xinetd via "sh /etc/init.d/xinetd reload" doesn't work. After done it, # netstat -an | grep 5555, still nothing.
Highlighted
Super Advisor

Re: Could not add a linux client to Data protector Cell manager client pool

Hi All

Thank you very much for your all kindly help.
I have fixed the problem.

I made a mistake, port 5555 already be opened, only D/P Cellmgr done the installation of Disk agent to Client server, the port 5555 could be LISTENed, below are the fixing steps for the people who will meet the same issue of D/P adding client in the future:

1. open port 5555
vi /etc/sysconfig/iptables or
iptables -A INPUT -p tcp -m tcp --dport 5555 -j ACCEPT or
via Linux GUI desktop "System Settings" - "Security Level"
checking via # iptables -L

2. Install or re-install "rsh"
#rpm -ivh rsh-server-0.17-25.4.i386.rpm

3. vi /etc/xinetd.d/rsh and /etc/xinetd.d/rexec and change the entry "disable = no" from "yes"

4. vi /etc/securetty and add the entries
rexec
rsh

5. restart the
# service xinetd restart

6. From Data Protector Cell Manager "Client" - "Add Client" choose Disk agent ... Add the backup client server(s) to Cell Manager.

7. From Backup clienet server
# netstat -an | grep 5555
tcp 0 0 0.0.0.0:5555 .0.0.0:* LISTEN
port 5555 be LISTENed, it the same like port 5801 and 5901. When you start "vncserver" the port 5801 and 5901 will be LISTENed.

8. Go ahead to schedule your backup tasks.

Anyone could correct my above steps.

Question:
Who can tell me why install the "rsh", let the disable = no and add those entry in securetty could fix the D/P Cellmgr adding client issue?

Highlighted
Frequent Advisor

Re: Could not add a linux client to Data protector Cell manager client pool

Well you can install DA (disk agent) for Data-Protector in 2 ways: locally on the DP client, as you tried at first, and from various reasons it didn't work; remote from installation server, which is you cell-manager. For the remote installation you need to install rsh (allows you to issue remote commands from the installation server to client). After installation of rsh, you had to enable it in firewall software, and then start it from xinetd.

Any of the above methods are very well explained in the docs: "HP OpenView Storage Data Protector Vx.x Installation and Licensing Guide".

HTH
Highlighted
Super Advisor

Re: Could not add a linux client to Data protector Cell manager client pool

Hi Liviu

Thank you very much for your explanations above.

Now, remote installation works from Cellmgr to Client. Would you please explain why my local install failed. except "./omnisetup -install da", anything else missed?

Have a great day

-Gary