System Administration
Showing results for 
Search instead for 
Did you mean: 

Fedora 13 serial console no login prompt problem

Go to solution
Regular Advisor

Fedora 13 serial console no login prompt problem

I have recently upgraded to Fedora 13.

The following worked perfectly for Fedora 12. But it does no longer work for Fedora 13.

I do not get a login prompt when connecting a terminal emulator via a serial cable.

You need to reboot after making the following modifications:

vi /etc/securetty

vi /etc/event.d/ttyS0
# ttyS0 - mgetty
# This service maintains a getty on ttyS0 from the point the system is
# started until it is shut down again.

start on stopped rc1
start on stopped rc2
start on stopped rc3
start on stopped rc4
start on stopped rc5

stop on shutdown

#exec /sbin/agetty -L ttyS0 57600 vt100
exec /sbin/mgetty -r -s 57600 ttyS0 vt100
Honored Contributor

Re: Fedora 13 serial console no login prompt problem

Regular Advisor

Re: Fedora 13 serial console no login prompt problem

I implemented the advice of Michael -- thanks!

vi /etc/init/serial-console-ttyS0.conf

start on stopped rc RUNLEVEL=[2345]
stop on starting runlevel [016]

exec /sbin/agetty -L ttyS0 57600 vt100
#exec /sbin/mgetty -r -s 57600 /dev/ttyS0 vt100

(need to reboot)

But I still got errors and the serial port did not work:

tail -f /var/log/messages
... kernel: ttyS0: LSR safety check engaged!

The following articles suggested me to use the boot option acpi=off (I tried pnpacpi=off but this did not work):

The boot option acpi=off workaround seems to work. But perhaps other hardware features will now be inaccessible?

Seems to be an old unresolved Fedora bug resulting in a hardware IRQ conflict with an (unexisting) IR port for the Compaq nc6000 laptop? (I found references since Fedora core 6).

Question: Why does the Fedora team change the serial console behaviour at each release? Until and including Fedora 11 /etc/inittab itself could launch the ttyS0 console. The problems started with Fedora 12, and Fedora 13 which both required a different setup (see above) because /etc/inittab since release 12 only contains the default run level.

FYI, the pre-Fedora 12 setup:

vi /etc/inittab
C0:12345:respawn:/sbin/agetty -L ttyS0 57600 vt100

telinit q