System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

help with updating SAS- driver needed

 
Highlighted
New Member

help with updating SAS- driver needed

Hi Folks,

 

I want to update the driver of my SC08Ge card, which is based on LSI1068e chip.

The Linux is a REDHAT box: Red Hat Enterprise Linux Server release 6.3; 2.6.32-279.5.2.el6.x86_64 #1 SMP

 

When i try to install a newer driver (from HP...) for my SAS card some ugly errors apper:

 

# rpm -i kmod-mptbase-4.00.13.09-3.el6.x86_64.rpm
error: Failed dependencies:
        kernel(sas_attach_transport) = 0x53a87501 is needed by kmod-mptbase-4.00.13.09-3.el6.x86_64
        kernel(sas_end_device_alloc) = 0xad9a61d9 is needed by kmod-mptbase-4.00.13.09-3.el6.x86_64
        kernel(sas_expander_alloc) = 0x46481b29 is needed by kmod-mptbase-4.00.13.09-3.el6.x86_64
        kernel(sas_phy_add) = 0xb82d29b4 is needed by kmod-mptbase-4.00.13.09-3.el6.x86_64
        kernel(sas_phy_alloc) = 0x50a3b4bd is needed by kmod-mptbase-4.00.13.09-3.el6.x86_64
        kernel(sas_phy_free) = 0x6a12439e is needed by kmod-mptbase-4.00.13.09-3.el6.x86_64
        kernel(sas_port_add) = 0xc2f2373e is needed by kmod-mptbase-4.00.13.09-3.el6.x86_64
        kernel(sas_port_add_phy) = 0xae70dff6 is needed by kmod-mptbase-4.00.13.09-3.el6.x86_64
        kernel(sas_port_alloc_num) = 0x828b8f2c is needed by kmod-mptbase-4.00.13.09-3.el6.x86_64
        kernel(sas_port_delete) = 0x3b1d3285 is needed by kmod-mptbase-4.00.13.09-3.el6.x86_64
        kernel(sas_port_delete_phy) = 0x61d81cea is needed by kmod-mptbase-4.00.13.09-3.el6.x86_64
        kernel(sas_port_mark_backlink) = 0xea6deff4 is needed by kmod-mptbase-4.00.13.09-3.el6.x86_64
        kernel(sas_rphy_add) = 0x1ae3ab14 is needed by kmod-mptbase-4.00.13.09-3.el6.x86_64
        kernel(sas_rphy_free) = 0x728b663c is needed by kmod-mptbase-4.00.13.09-3.el6.x86_64

 

 

I tried some other drivers from LSI, DELL, IBM different 4.xx versions: the same result.

Any idea?

 

Thanks in advance

 

Mathias

1 REPLY 1
Highlighted
Honored Contributor

Re: help with updating SAS- driver needed

The kmod-mptbase-4.00.13.09-3.el6.x86_64.rpm package is intended for RHEL 6.0 and was released in December 2010.

 

The driver that is built in to the standard RHEL 6.3 kernel is probably newer than that, so installing that RPM would probably be a downgrade, not an upgrade.

MK