System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

how to install and update the packages from command line in suse 9 and sues 10

 
SOLVED
Go to solution
Highlighted
Super Advisor

how to install and update the packages from command line in suse 9 and sues 10

Hi All,

I have registered my suse 9 and 10 linux.

I am using GUI to update the patches.

Start --> yast --> Softwares --> Online Update

Now I want to list , update and install the packages from CUI mode.

Like we are doing using yum in RHEL5.

Example:

#yum update

#yum install

#yum list all

and other options used by yum command
4 REPLIES 4
Highlighted
Honored Contributor
Solution

Re: how to install and update the packages from command line in suse 9 and sues 10

You can run a character mode version of yast.

# yast

or

# yast online_update

Highlighted
Honored Contributor

Re: how to install and update the packages from command line in suse 9 and sues 10

yast -i

zypper

rug

rpm
Highlighted
Super Advisor

Re: how to install and update the packages from command line in suse 9 and sues 10

Hi All,

I have some questions about using rug.


1)I have executed the command "# rug patches SLES10-SP2-Online" It is showing all the patches available in the catalogue "SLES10-SP2-Online".

Ex:

# rug patches SLES10-SP2-Online

Catalog | Name | Version | Category | Status
------------------ +-------------------------------- +--------- +------------- +---------------
SLES10-SP2-Online | product-sles10-sp2 | 0-20 | recommended | Needed
SLES10-SP2-Online | slesp1-apache2-mod_python | 4449-0 | security | Not needed
SLES10-SP2-Online | slesp1-boost | 4978-0 | security | Not needed
SLES10-SP2-Online | slesp1-cairo | 5006-0 | security | Not needed
SLES10-SP2-Online | slesp1-compat-openssl097g | 5055-0 | security | Not needed
SLES10-SP2-Online | slesp1-cups | 5115-0 | security | Not needed
SLES10-SP2-Online | slesp1-emacs | 4733-0 | security | Not needed
SLES10-SP2-Online | slesp1-ethereal | 5058-0 | security | Not Applicable
SLES10-SP2-Online | slesp1-evolution | 4820-0 | recommended | Not needed
SLES10-SP2-Online | slesp1-festival 4378-0 | security | Not Applicable
SLES10-SP2-Online | slesp1-fetchmail | 4462-0 | security | Not Applicable


My question:

1.1)what do 4th column (category) and 5th column (status) mean?

1.2)What is the meaning for "Needed" , "Not neeeded" and "Not Applicable"?


2)I would like to update one package "sudo" , I have done following steps.

a)First checking already installed version:

# rpm -qa | grep -i sudo
sudo-1.6.8p12-18.14

b)Searched whether any lateste version of sudo available for update:

# rug list-updates | grep -i sudo
v | SLES10-SP2-Updates | | sudo | 1.6.8p12-18.16.2 | x86_64


c)Now I have entered following command to update the package "sudo":

# rug update sudo
ERROR: 'sudo' is not a valid catalog.


My question:

2.1)Why it is giving error, how to update a sinle package?


Highlighted
Super Advisor

Re: how to install and update the packages from command line in suse 9 and sues 10

Could any one of you please answer to my question?