System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

how to stop bradcast message

 
SOLVED
Go to solution
Highlighted
Occasional Contributor

how to stop bradcast message

Hi

I am using proxy server in RHEL AS3.My external IP is 192.168.0.10 in eth0. A broadcast message like " IN= eth0 out =MAC=src=192.168.0.10 DST 192.168.0.255 LN=96 Tos=0X00 PREC =0X00 TTL=0...." apear 150/200 times in a minute.
I can do nothing cusing to brastcast.

How can i stop this types of bradcast?
Please help me

Your regards
amzad
3 REPLIES 3
Highlighted
Exalted Contributor

Re: how to stop bradcast message

Shalom,

I would suggest you change kernel logging level in /etc/syslog.conf

Also, iptables configuration can trigger this behavior.

iptables -L

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Highlighted
Honored Contributor

Re: how to stop bradcast message

Hello,

this message is generated by the kernel, and kernel messages with a specific priority will be printed on the console. You can fix this if you configure you syslog server in the right way. Please post the complete broadcast message and the output of the command "iptables -L -v -n".

Kind regards,
Patrick
Best regards,
Patrick
Highlighted
Honored Contributor
Solution

Re: how to stop bradcast message

This is a kernel message, created by the iptables firewall code. There is a firewall rule that is configured to LOG packets like this for some reason. You can either remove the logging rule from the firewall rules, or you could change the way the kernel messages are delivered.

There are two ways for kernel messages like this to appear.

If they are visible only on the console, they might be generated by the kernel directly. This can be stopped by using the "-c " option of the klogd daemon. This option can be added to the KLOGD_OPTIONS variable in the /etc/sysconfig/syslog file.
If you set "-c 0", kernel will print no messages directly on the console: all messages will be sent to klogd, which forwards them to syslogd, which then does whatever it is configured to do to kernel messages.

If the messages appear in all sessions, not only on the console, the problem is in the syslog configuration. Read /etc/syslog.conf and check the lines that are applicable to kernel messages. Read "man syslog.conf" to understand the syntax.

MK
MK