System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

lpstat: printer "cowlas01" non-existent

 
Highlighted
Frequent Advisor

lpstat: printer "cowlas01" non-existent

We have problem with all the printers on the ystsem , though all the configurations are there on system , if we check by lpstat it shows not a print id or destination, please suggest what needs to be check

# cd /var/spool/lp/interface
# ll
total 368
-rwxr-xr-x 1 lp lp 11542 Dec 22 11:12 cowlas01
-rwxr-xr-x 1 lp lp 11542 Dec 22 11:12 cowlas02
-rwxr-xr-x 1 lp lp 11542 Dec 22 11:12 cowlas03
-rwxr-xr-x 1 lp lp 11542 Dec 22 11:12 cowlas04
-rwxr-xr-x 1 lp lp 11542 Dec 22 11:12 cowlas05
-rwxr-xr-x 1 lp lp 11542 Dec 22 11:12 cowlas06
-rwxr-xr-x 1 lp lp 11542 Dec 22 11:12 cowlas07
-rwxr-xr-x 1 lp lp 11542 Dec 22 11:12 cowlas08
-rwxr-xr-x 1 lp lp 5256 Dec 22 11:12 cowzeb02
-rwxr-xr-x 1 lp lp 5256 Dec 22 11:12 cowzeb05
-rwxr-xr-x 1 lp lp 5256 Dec 22 11:12 cowzeb06
-rwxr-xr-x 1 lp lp 5256 Dec 22 11:12 cowzeb10
-rwxr-xr-x 1 lp lp 5256 Dec 22 11:12 cowzeb11
-rwxr-xr-x 1 lp lp 5256 Dec 22 11:12 cowzeb12
drwxr-xr-x 2 lp bin 8192 Dec 22 11:26 model.orig
# lpstat -t
scheduler is running
no system default destination
device for cowlas05: /dev/null
device for cowlas01: /dev/null
device for cowlas02: /dev/null
device for cowlas03: /dev/null
device for cowlas04: /dev/null
device for cowlas06: /dev/null
device for cowlas07: /dev/null
device for cowlas08: /dev/null
device for cowzeb02: /dev/null
device for cowzeb05: /dev/null
device for cowzeb06: /dev/null
device for cowzeb10: /dev/null
device for cowzeb11: /dev/null
device for cowzeb12: /dev/null
cowlas05 accepting requests since Dec 31 05:29
printer cowlas05 is idle. enabled since Dec 31 09:17
fence priority : 0
no entries
# lpstat -pcowlas01
lpstat: printer "cowlas01" non-existent

# lpstat -ocowlas01
lpstat: "cowlas01" not a request id or a destination
4 REPLIES 4
Highlighted
Respected Contributor

Re: lpstat: printer "cowlas01" non-existent

We had a similiar incident, it turned out that /var/spool was mounted as a seperate file system and the entry was missing in /etc/fstab. When we rebooted the server, /var/spool didn't get mounted and we saw the same results you're experiencing. Once we mounted /var/spool everything looked and worked ok.

Just thought I'd throw that out.
Time to smoke and joke
Highlighted
Respected Contributor

Re: lpstat: printer "cowlas01" non-existent

> cd /var/spool/lp/interface

Are you sure? The interface directory is usually in /etc/lp.
Time to smoke and joke
Highlighted
Acclaimed Contributor

Re: lpstat: printer "cowlas01" non-existent

>Robert: Are you sure? The interface directory is usually in /etc/lp.

Yes, /var/spool/lp/interface is a tlink to /etc/lp/interface. (One of many there.)
Highlighted
Frequent Visitor

Re: lpstat: printer "cowlas01" non-existent

Hi Guys , it looks like the print queue is corrupted, so you need to restore the print spooler configuration for that perticular printer.

below are the steps...

1.sam

2.go to Printers and Plotters

3.go to LP Spooler

4.go to Save/Restore Spooler Configuration

5. mark for the perticular printer, go to action and do Restore Spooler Configuration

note:// it will stop the spooler so that you need to start the spooler again

6. now you can able to delete, modify and do other work for that printer.

 

Letme know if you have any doubt on this.....

 

Thanks & Regards,

Sitansu Mohanty

:smileyhappy: