System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

please help me install OpenOffice on SLES 9 asap

 
Highlighted
Valued Contributor

please help me install OpenOffice on SLES 9 asap

OS: SLES 9 SP 3 x86_64

SLES 9 doesnt ships with OpenOffice.

I have to install the OpenOffice_org-1.1.5-0.8.i586.rpm from the media of Novell Linux Desktop 9 x86_64-SP3(SUSE 9 Desktop), on SLES-9-x86_64-SP3

Novell Linux Desktop 9(NLD 9) is simply the Enterprise class Desktop version of SUSE 9 from Novell.

On SLES 9, Got the following error when tries to install OpenOffice from NLD 9 media

# rpm -ivh /media/cdrecorder/suse/i586/OpenOffice_org-1.1.5-0.8.i586.rpm
error: Failed dependencies:
OpenOffice_org-lang is needed by OpenOffice_org-1.1.5-0.8
libstartup-notification-1.so.0 is needed by OpenOffice_org-1.1.5-0.8

I searched Internet a lot for "OpenOffice_org-lang" but didnt find any rpm for suse 9.x.

Second and the most strange thing is that this system(SLES 9 SP 3) already has "libstartup-notification-1.so.0" in /usr/lib, but still OpenOffice is asking for "libstartup-notification-1.so.0" (see line # two of dependency error)

But as I have said libstartup-notification-1.so.0 is already present I did the following to confirm
# rpm -q --provides startup-notification
libstartup-notification-1.so.0()(64bit)
startup-notification = 0.5-319.1

So please help me install the OpenOffice Novell Edition on SLES 9 that comes with Novell Linux Desktop 9 SP 3 i.e OpenOffice_org-1.1.5-0.8
14 REPLIES 14
Highlighted
Honored Contributor

Re: please help me install OpenOffice on SLES 9 asap

Probably, your best option is to not use version shipped with the distribution Media.

Download the package distributed in www.openoffice.org:

http://download.openoffice.org/2.3.0/contribute.html?product=OpenOffice.org&os=linuxintelwjre〈=en-US&version=2.3.0
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Highlighted
Respected Contributor

Re: please help me install OpenOffice on SLES 9 asap

Do you have yum install?

if you do, you can install the dependencies by doing this:

yum install

If you want, you can skip the dep check by adding a flag to the rpm command.

rpm --nodeps ...

try this on a development box first.
Highlighted
Valued Contributor

Re: please help me install OpenOffice on SLES 9 asap

Dear Ivan thanks for help
No we cant install the vanilla version of OpenOffice ;), for some reasons we are restricted to install the Novell Edition of OpenOffice from NLD 9 media.

So please help me install the OpenOfice frm NLD 9 media.
Highlighted
Esteemed Contributor

Re: please help me install OpenOffice on SLES 9 asap

You may try adding the NLD 9 CD (installation media) to the installation sources & use the Yast Package Manager to install Openoffice, which should resolve the dependencies.

In addition, if you do feel that you have to get the dependencies manually, you can use www.rpmfind.net to find them.
Highlighted
Valued Contributor

Re: please help me install OpenOffice on SLES 9 asap

thanks Dear Wilfred Chau

>Do you have yum install?
No

>If you want, you can skip the dep check by adding a flag...
Yes I once have installed the OpenOffice as:
# rpm -ivh --nodeps --force /media/cdrecorder/suse/i586/OpenOffice_org-1.1.5-0.8.i586.rpm

By executing above command OpenOffice merely installed but failed to work.

# which oowriter
/usr/bin/oowriter

but when
# /usr/bin/oowriter

Your installation of OpenOffice doesnt provide the Selected icons set "default" ---

Installation of OpenOffice.org 1.1.5 failed:
'LD_LIBRARY_PATH=/usr/lib/ooo-1.1: /usr/lib/ooo-1.1/program /usr/lib/ooo-1.1/program/setup -R:/tmp/ooo- wrapper.autoresponse.file.M12434 -v -nogui >

It means that --nodeps is not the sol here in my case.

Please help

Regards

Maaz
Highlighted
Valued Contributor

Re: please help me install OpenOffice on SLES 9 asap

thanks adric for help

>You may... use the Yast Package Manager to install Openoffice
I tried, but Yast just merely installs the OpenOffice frm NLD 9 media, but that OpenOffice doesnt works.

I found that it is equivalent to install the OpenOffice from NLD 9 media using rpm with 'nodeps' and 'force' flags, or from YAST(after configuring/adding NLD 9 media in installation source), becuase after installing OO from YAST same error comes when executing oowriter
# /usr/bin/oowriter

Your installation of OpenOffice doesnt provide the Selected icons set "default" ---

Installation of OpenOffice.org 1.1.5 failed:
'LD_LIBRARY_PATH=/usr/lib/ooo-1.1: /usr/lib/ooo-1.1/program /usr/lib/ooo-1.1/program/setup -R:/tmp/ooo- wrapper.autoresponse.file.M12434 -v -nogui


> get the dependencies manually, you can use www.rpmfind.net to find them.
If you can please find out the dependencies/rpms that are required to install before OO 1.1.5 installation on SLES 9 SP 3, please let me know
Highlighted
Valued Contributor

Re: please help me install OpenOffice on SLES 9 asap

# rpm -q --provides startup-notification
libstartup-notification-1.so.0()(64bit)
startup-notification = 0.5-319.1

then why the Second Line in the output of "error: Failed dependencies:"
# rpm -ivh /media/cdrecorder/suse/i586/OpenOffice_org-1.1.5-0.8.i586.rpm
error: Failed dependencies:
OpenOffice_org-lang is needed by OpenOffice_org-1.1.5-0.8
libstartup-notification-1.so.0 is needed by OpenOffice_org-1.1.5-0.8

Highlighted
Honored Contributor

Re: please help me install OpenOffice on SLES 9 asap

>>> If you can please find out the dependencies/rpms that are required to install before OO 1.1.5 installation on SLES 9 SP 3, please let me know

You can identify the dependencies by running:

rpm -qRp package.rpm

>>> Second and the most strange thing is that this system(SLES 9 SP 3) already has

Probably, because rpm does not verify if the file exists, it just verify if was installed by a package name, thay may be different. If the file exists, you can ignore the dependency check using --nodeps. But OpenOffice_org-lang is needed, so you should run:

rpm -ivh OpenOffice_org-1*rpm OpenOffice_org-lang*rpm
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Highlighted
Respected Contributor

Re: please help me install OpenOffice on SLES 9 asap

it shouldn't be that hard....

try this:
open yast -> Software(or Software Management)

in the search box, enter Openoffice
See if you could install it from there.

If not, try to search for the 2 packages the OO needs and see if you could install it.

If all of the above failed, you need to install the missing packages first.

The find the rpm you can do this:

rpm -q --whatprovides
e.g.
# rpm -q --whatprovides libstartup-notification-1.so.0
startup-notification-0.8-4.1