System Administration
Showing results for 
Search instead for 
Did you mean: 

RHEL 5 get "vg metadata too large for circular buffer" . Why ?

Super Advisor

RHEL 5 get "vg metadata too large for circular buffer" . Why ?

One of my teammate is getting this when trying to grow a volume an RHEL filesystem


  Extending logical volume nms_u11 to 126.00 GB

  VG datadg metadata too large for circular buffer


good judgement comes from experience and experience comes from bad judgement.
Valued Contributor

Re: RHEL 5 get "vg metadata too large for circular buffer" . Why ?



By Default physical LVM volumes are created with 255 sectors of metadata space which is equivalent of 128KB.


If the data stored in the metadata exceeds the size allocated to it then you get that error, whenever you try to make a change that tries to modify the metadata.


use the below command to check the value of pvmetadatasize in /etc/lvm/lvm.conf


#grep pvmetadatasize /etc/lvm/lvm.conf


Check the backups for your volume group and see where the first physical extend begins. Using the default setting, it should begin at 384 PE's


#grep pestart /etc/lvm/backup/volgroup01


Physical LVM volumes need to be recreated with larger metadata size.


Physical volumes can be created with increased metadata size by using the below command:


#pvcreate --metadatasize 1020 /dev/mapper/newpvdisk


You can change the default metadata size in /etc/lvm/lvm.conf as shown below:


   # Approximate default size of on-disk metadata areas in sectors.
        # You should increase this if you have large volume groups or       

 # you want to retain a large on-disk history of your metadata changes.



    # pvmetadatasize = 255
    pvmetadatasize = 1020


After making the lvm.conf change, all pvcreate commands will use the new metadata size without requiring you to specify --metadatasize 


Hope this helps.


I am an HP employee.
Was this post useful? - You may click the KUDOS! star to say thank you.