cancel
Showing results for 
Search instead for 
Did you mean: 

RHEL5.3 multipath EVA 8000

 
Highlighted
Occasional Advisor

RHEL5.3 multipath EVA 8000

I have a newly installed RHEL 5.3 on a BL460c G6 with a dual port Qlogic QMH2462 HBA. I have 1 drive presented to this server from an EVA 8000. I have installed hp_qla2x00-2009-03-17 as well as HPDMmultipath-4.2.0. I have rebooted the server and multipathd is running, but multipathing is not working correctly. Below is the output of the multipath -l command. Does anyone know why it says [undef] next to each path to the EVA? What additional steps do I need to configure RHEL5.3 for EVA storage?

mpath0 (3600508b400105ce40001800004210000) dm-4 HP,HSV210
[size=100G][features=1 queue_if_no_path][hwhandler=0][rw]
\_ round-robin 0 [prio=0][active]
\_ 0:0:0:1 sda 8:0 [active][undef]
\_ 0:0:1:1 sdc 8:32 [active][undef]
\_ 1:0:0:1 sdi 8:128 [active][undef]
\_ 1:0:1:1 sdk 8:160 [active][undef]
\_ round-robin 0 [prio=0][enabled]
\_ 0:0:2:1 sde 8:64 [active][undef]
\_ 0:0:3:1 sdg 8:96 [active][undef]
\_ 1:0:2:1 sdm 8:192 [active][undef]
\_ 1:0:3:1 sdo 8:224 [active][undef]
5 REPLIES 5
Highlighted
Honored Contributor

Re: RHEL5.3 multipath EVA 8000

Hi,

Try running a 'multipath -ll' and see if it shows '[ready]' instead of '[undef]'.

I have a SLES10 box here using mulitpath and it does the same thing. I'll have to dig a bit to see why it reports undef on the '-l' option, but I know my multipath is working. I've pulled all the cables while the database is running, just to prove it out.

JP
Highlighted
Occasional Advisor

Re: RHEL5.3 multipath EVA 8000

I have noticed that as well and decided to try and mount the drive hoping it is just a warning. There is an existing volume group on the drive so I ran vgscan, activated the logical volume and mounted it to directory /home/solr. After that I tested the drive by trying to make a full copy of 1 of the folders on the drive to a new folder on the same drive. In this example I cp -Rp /home/solr/solrworks to /home/solr/solrworks2

Before copy output df -k /home/solr
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/mapper/vg--solr-lv--solr
103208224 26555788 71409764 28% /home/solr

After copy output df -k /home/solr
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/mapper/vg--solr-lv--solr
103208224 98180252 0 100% /home/solr

Output du -sk *
16 lost+found
26365320 solrworks
71924756 solrworks2
39588 utility

How is it that I copy more data then what exists on the disk?
Highlighted
Honored Contributor

Re: RHEL5.3 multipath EVA 8000

I don't know what happened with your copy. I've never been a big fan of 'cp -R' because that kind of thing happens to me too.

Can you post the exact syntax of your 'cp' command?

The last field in the path line is the dm status, which is how the kernel looks at it. The 'multipath -l' reports on the configuration from sysfs and the device mapper. The 'multipath -ll' reports from those two places plus any other components (path checkers, etc.) so it gives more information and is probably more accurate.

JP
Highlighted
Occasional Advisor

Re: RHEL5.3 multipath EVA 8000

The copy command I used was:

cp -Rp /home/solr/solrworks /home/solr/solrworks2

Also tried rsync:

rsync -avrt /home/solr/solrworks /home/solr/solrworks2

Same resullt.
Highlighted
Honored Contributor

Re: RHEL5.3 multipath EVA 8000

The output of multipath -l looks normal. As someone else stated use multipath -ll and the undef should change to read ready. I don't know why this is, but all of the systems I have running DM multipath show that way
No support by private messages. Please ask the forum!