Showing results for 
Search instead for 
Did you mean: 

SCSI conroller and linux


SCSI conroller and linux

Dear all. I have liitle proble maybe someone know how to help.

I inserted HP LSI20320 to PCI on Proliant DL380 G4. On boot time controller was found and after controler did discovering itself it found HP Ultrium 232.

Problem next in linux no scsi devices attached
lspci returns this

0a:01.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI (rev 07)

but I can not discover in linux my Ulrium. What can I do or where I an check this?

Thank you all verry much in advance, this problem is important to me
Honored Contributor

Re: SCSI conroller and linux


I would first check in the output of "dmesg" whether the tape drive was seen during startup...


Honored Contributor

Re: SCSI conroller and linux

if the drive is brand there is a chance of having factory default jumper setting which may have to be changed. Also check with the vendor any utility is availabale to scan and test the drive. IBM have one which i used when i had similar problem.

Re: SCSI conroller and linux

Thanks for point where to search.

I didnt found anythig in dmesg(maybe don't see ecouse dont know what can be strange :) )
I attahce dmesg if not minded please someody take a look.

About tools I tryed hp_ltt but it cannot found anything..

my lsmod

I added driver sym53c8xx but nothing changed

Module Size Used by
sym53c8xx 72033 0
scsi_transport_spi 17473 1 sym53c8xx
st 40029 0
sg 38113 0
autofs4 22085 0
i2c_dev 14273 0
i2c_core 25921 1 i2c_dev
ipt_REJECT 10561 1
ipt_state 5825 11
ip_conntrack 45957 1 ipt_state
iptable_filter 6721 1
ip_tables 21441 3 ipt_REJECT,ipt_state,iptable_filter
md5 8001 1
ipv6 238817 26
dm_mod 57157 0
button 10449 0
battery 12869 0
ac 8773 0
joydev 14209 0
uhci_hcd 32729 0
ehci_hcd 31813 0
tg3 79173 0
floppy 58065 0
aic7xxx 146552 0
ext3 118473 8
jbd 59481 1 ext3
cciss 45221 11
sd_mod 20545 0
scsi_mod 116557 7 sym53c8xx,scsi_transport_spi,st,sg,aic7xxx,cciss,sd_mod

Any body knows can problem be in absence of proper driver?

on HP site writen that this SCSI controller not need any drivers. But on LSI site I found LSI Logic Fusion-MPT (TM)
(Message Passing Technology) device drivers for Linux(TM). Do I need to instal this? some one knows for what this driver is? As I reed there is kernel recomplinig needed. It's verry hard I think I will brake server OS :(((

thanks in advance


Re: SCSI conroller and linux

you need to check if the controller is seen by the Linux

cat /proc/mpt/summary

cat /proc/mpt/version


cat /proc/scsi/scsi will show devices..

You might need to load the drivers for the card.

Also the driver for the st drivers might need to be loaded

use modprobe st for tape devices

Re: SCSI conroller and linux

1) I donthave mpt dir at all.

cat /proc/mpt/summary
cat /proc/mpt/version

cat /proc/scsi/scsi

Attached devices:

Acording to HP no drivers needed, I am confused ^(((

st is loaded


Re: SCSI conroller and linux

Ok i have some achivements but I dont kno why and is they safe.

insmod mptbase return that i dont have mptbase

then I did

locate mptbase return is

the I did insmod /lib/modules/2.6.9-5.ELsmp/kernel/drivers/message/fusion/mptbase.ko
and this is worked module is loaded

then i did the same for mptscsih and it worked too

no I have access to my TYPE but are my doings right? or i did completely unsafe?