System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to configure eth0 in Redhat rhel 5

 
Highlighted
Frequent Advisor

Unable to configure eth0 in Redhat rhel 5

Hi guys,

need some help, i've installed redhat rhel 5 in proliant bl460 g6 server. problem is i'm unable to configure the ip for the server. i already installed the driver but error still prompts.

#ifconfig eth0
eth0: error fetching interface information: Device not found

any suggestion? thanks
3 REPLIES 3
Highlighted
Honored Contributor

Re: Unable to configure eth0 in Redhat rhel 5

Run "ifconfig -a" to see all the NICs detected by the server.

If the server hardware has changed after the OS installation (for example, if this installation is duplicated from a disk image, or if the I/O module configuration has changed), the first NIC might not be named "eth0", but some higher number, e.g. "eth2".

MK
MK
Highlighted
Frequent Advisor

Re: Unable to configure eth0 in Redhat rhel 5

Hi,
1) can u post the command used to install Driver ?
2) This is an answer that i found it in other Forum may be that can help you to resolve your case :

**
For network cards names need to be consistent from one boot to the next, so udev is associating the conventional interface name (eth*) to it's unique MAC address (MAC address is build inside the device itself)


Those associations are stored in the folder /etc/udev/rules.d/ where you will find a "yx_persistent-net.rules" file ("yx" are random numbers, depends on your system).


Code:

SUBSYSTEM=="net", DRIVERS=="?*", ATTR{address}=="xx:xx:xx:xx:xx:xx", NAME="eth0"


(the xx:xx:xx... pattern will be replaced by a MAC address)

All you need to do is reading your actual network card MAC address with :

#sudo /sbin/ifconfig -a

("-a" option lists even non configured devices) , it will look like "HWaddr 00:1d:20:55:cf:67", and write this MAC address in the udev rule corresponding to the conventional name that suites you (eth0 for instance). You can delete old rules, add new ones for other cards.

You will need root privileges to edit the "yx_persistent-net.rules" file.

Reboot when done (restarting the network should be enough though...)

Hope that's will be a Good Help

best Regards
BCS SW/HW GSC Engineer (L1)
IEEE Student Member
LPI 3 CORE & High Availability
VCP Vshpere 5 Datacenter
Novell CLA and Data Center specialist Certified
.....
Microsoft Partner & Microsoft student Partner
Highlighted
Honored Contributor

Re: Unable to configure eth0 in Redhat rhel 5

What does "lspci" show you? Does it return the Flex-10 interface?

Do you have this Blade set up properly in a Blade Profile?

Have you installed the latest PSP?
If eth0 is not existent, then try "ethtool eth0".. if that does not return -- then you likely need PSP to enable the Flex-10 drivers for your 10GbE module or its "share" allocation from Blade Profile or the whole allocation itself if you use pass thru.

Hakuna Matata.