System Administration
Showing results for 
Search instead for 
Did you mean: 

vgimport unable to read physical volume

Go to solution
Valued Contributor

vgimport unable to read physical volume


I am upgrading from 11.11 to 11.31. I did a vgexport -m /tmp/ vg01 command and copied the file off to a tape.

I did a cold install of 11.31, copied the map file back off of tape into the tmp file. I then did a vgimport -m /tmp/ /dev/vg01. Then I get the following error

vgimport: unable to read physical volume.

What am I missing and can I get around this error with out destroying all the data on the vg01 disks.


Honored Contributor

Re: vgimport unable to read physical volume


what is the server? model?

are you using the same server and storage? sounds like you are.

if so what is the storage? FWD storage options are not supported on 11.31 for example so did you check your interfaces and storage works with 11.31

Also what is the version of lvm used on the 11.11 system? and are you using on the version 3 system?

Honored Contributor

Re: vgimport unable to read physical volume

You should always use the -s option with -m so you get a VGID number for all the PVs. However, the mapfile only contains lvol information so vgimport will scanning every disk available to the system. So one of the PVs is not working. It may not have anything to do with vg01 but it does need to be resolved. Since this was a cold install, all the disks available to the new system should still be OK. Start with a ioscan -fnCdisk looking for NO_HW, then run diskinfo on each of the raw disks to see if one (or more) of the disks hangs or returns an invalid size.

Bill Hassell, sysadmin
Valued Contributor

Re: vgimport unable to read physical volume

Thanks for the responses!


you were absolutely correct. I messed up and did not use the -s option. So here is one way that I found to fix it.

As usual any one that upgrades should have a new/current ignite tape. The ignite tape does create a map file in the /etc/lvmconf directory called vg01.mapfile.

I tared off the etc directory from the ignite tape and put it into the tmp directory. From their was able to do the following commands.

- vgcreate /dev/vg01
- mknod /dev/vg01/group -c 64 0x010000
- vgimport -v -s -m /tmp/etc/lvmconf/vg01.mapfile /dev/vg01
- vgchange -a y /dev/vg01
- Added the mount information in the /etc/fstab
- Added the mount point directories
- mount -a

This did the trick...

I don't think I will make that mistake again. but if someone else does this may help.