System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

XF86Next_VMode XF86Prev_Vmode in .xmodmap but do not work

 
SOLVED
Go to solution
Highlighted
Valued Contributor

XF86Next_VMode XF86Prev_Vmode in .xmodmap but do not work

Hello Everyone;

 

I'm running Fedora 16 with Motif Window Manager.

 

One of the neat abilities mwm supports is a "zoom" function: if your xf86config file (or now the xorg.conf) is configured with multiple modes in the "screen" section (like 1600x1200   1024x768  800x600) you can toggle between the resolutions by doing a Ctrl+Alt+[Keypad + and -] to switch modes.

 

Well, it doesn't work on Fedora 16.

 

I know my xorg.conf is good because there are no errors in the Xorg.0.log file or my .xsession-errors file. If I change the order of the modes, and restart X, whichever is the first mode will come up.

 

I've dumped the key codes with xmodmap -pk and the XFPrev_VMode and XFNext_VMode is there but when I run xkeycaps (a really cool program written by Jamie Z who is famous for the screensavers) and do the Ctrl+Alt_KP_Add it says that there are more key releases than presses.

 

I've reassigned the key sequence to other keys with the same results.

 

My guess is that whatever inteprets key codes doesn't have XFPrev_Vmode and XFNext_VMode properly decoded.

 

Anybody have any ideas?

 

regards,

tonp

 

REMEMBER: Once you eliminate your #1 problem, #2 gets a promotion.
2 REPLIES 2
Highlighted
Honored Contributor
Solution

Re: XF86Next_VMode XF86Prev_Vmode in .xmodmap but do not work

This is actually not related to mwm at all: it is an old function of the XFree86 X server, the predecessor of Xorg.

These keys are interpreted directly by the X server.

 

These days the RandR X11 protocol extension provides a standardized way for doing much the same thing (see "man xrandr" for a command-line tool), so the old key combinations may have been disabled in the default xorg.conf file (or in one of the files in /etc/X11/xorg.conf.d/ directory).

 

Please make sure your X configuration does not include a line like this anywhere in it:

Option "DontZoom" on

 This would disable the old resolution-switch key combinations.

 

If it turns out that these key combinations have been completely obsoleted, you can configure your window manager to run the xrandr command with suitable parameters (or a script that uses xrandr to cycle through the available resolutions) using a desktop menu item, or maybe when a particular key combination is used. If you actively use mwm, you probably know more of its capabilities than I do.

MK
Highlighted
Valued Contributor

Re: XF86Next_VMode XF86Prev_Vmode in .xmodmap but do not work

Matti - thank you very much!

 

regards,

tonyp

 

REMEMBER: Once you eliminate your #1 problem, #2 gets a promotion.