Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Spanning-tree with multiple VLAN an multiple uplink

 
SOLVED
Go to solution
Advisor

Spanning-tree with multiple VLAN an multiple uplink

Hi,

I'm unable to find a solution to that :

2 rooms with 2 switches procurve 2530 with

  • port 1-6 -> vlan 10 unttaged
  • port 7-8=trk1 -> vlan  10 untagged, used to copper uplink to neighbor (same room)
  • port 9-22 -> many vlan, let's say 1,2,3 tagged and untagged
  • port 23-24=trk3 -> vlan 1,2,3 used to copper ulink to neighbor
  • port 25-26=trk2 -> vlan 10, used to fiber uplink to another set of two switchs (other room)
  • port 27-28=trk4 -> vlan 1,2,3, used to fiber uplink to another set of two switchs

I tried to use instance (1 for vlan 10, 2 for vlan 1,2,3) to "separate" STP, but it always choose the trk1 as forwarding for ALL vlan.

I do not understand, i thought that trk1 or 2 will be choose for vlan 10 and trk 3 or 4 for vlan 1,2,3 ?! 

I found something on hp docs (see attached file) that says to have uplink for all vlan...

But i'd really like to dedicated uplink for vlan 10 to garanty troughput regarless of what vlan 1,2,3 are doing.

Any idea please ?

Thanks

 

10 REPLIES 10
Respected Contributor
Solution

Re: Spanning-tree with multiple VLAN an multiple uplink

I'd put all VLANs tagged and VLAN1 untagged on all trunks.  Then play around with port priority for specific MSTP instances.
This way, you can create multiple paths between switches, and have each path one MSTP instance being forwarded, and the other being blocked.

This isolates traffic like you want, and gives redundancy.

Advisor

Re: Spanning-tree with multiple VLAN an multiple uplink

Hi and thanks for this reply.

I tryied to play with priority, but with no luck, but i'm not very used with that...

Before opening this thread i found a thing like that, is this what you were talking about ? 

spanning-tree
spanning-tree config-name stpconfig
spanning-tree config-revision 1

spanning-tree priority 1

spanning-tree instance 1 vlan 10
spanning-tree instance 1 priority 1

spanning-tree instance 2 vlan 1 2 3 9 101 240 1110 1200
spanning-tree instance 2 priority 2

 

On the other switch, only have to "swap" priority : one switch is root for one instance, the other switch for the other instance.

But this is not ok... 

I do not know if this is important but vlan 1 is not on the trunk that forwards vlan 10.... maybe i should change that

 

 

edit : sorry my first reading was bad... i now see you want  to put ALL vlan on ALL trunk. And then dedicate trunk using priority... i do not see really how...

Respected Contributor

Re: Spanning-tree with multiple VLAN an multiple uplink

Having a different MST-root per instance might be usefull in lot of cases.  But won't help that much when connecting just 2 switches using different paths.
Play around with command "spanning-tree instance <1-16> port priority <number>"  command , to make paths preferable/less preferable per VLAN

Advisor

Re: Spanning-tree with multiple VLAN an multiple uplink

Ok,

as a sum up : 

  •  All VLAN on all trunks
  • one instance for vlan 10
  • one instance for other vlan
  • on trunk ports use port priority to "dedicate" this trunk for either vlan 10, either the other one

Is my understanding correct ?

 What about using path-cost ?

many thanks for your help

Respected Contributor

Re: Spanning-tree with multiple VLAN an multiple uplink

Your understanding is fine.
Indeed better use path-cost instead of priority.  Priority is only tie-breaker if costs are equal.

Advisor

Re: Spanning-tree with multiple VLAN an multiple uplink

Sorry, i just see your reply. I did some tests using your last advices. Then i did not use path-cost. Should i regarding what is below ?

Vlan10 is the vlan i'd like to see only on trk1&2. Others vlan should go on trk3&4.

As per you advice, all VLAN goes on all trunks

Here is what i did :

 

hostname "HP-2530-24G-SW2"
trunk 7-8 trk1 lacp
trunk 25-26 trk2 lacp
trunk 23-24 trk3 lacp
trunk 27-28 trk4 lacp
interface 7
   name "TRK-Storage-local"
   exit
interface 8
   name "TRK-Storage-local"
   exit
interface 23
   name "TRK-LAN-Local"
   exit
interface 24
   name "TRK-LAN-Local"
   exit
snmp-server community "public" unrestricted
vlan 1
   name "inside"
   no untagged 1-6,9
   untagged 10-22,Trk1-Trk4
   ip address 192.168.218.202 255.255.255.0
   exit
vlan 2
   name "hosting"
   tagged 9-22,Trk1-Trk4
   no ip address
   exit
vlan 3
   name "DMZ"
   tagged 9-22,Trk1-Trk4
   no ip address
   exit
vlan 9
   name "DMZP"
   tagged 9-22,Trk1-Trk4
   no ip address
   exit
vlan 10
   name "stockage"
   untagged 1-6
   tagged Trk1-Trk4
   no ip address
   jumbo
   exit
vlan 101
   name "hosting-101"
   tagged 9-22,Trk1-Trk4
   no ip address
   exit
vlan 240
   name "management"
   untagged 9
   tagged 10-22,Trk1-Trk4
   ip address 192.168.240.202 255.255.255.0
   exit
vlan 1110
   name "voip-1110"
   tagged 9-22,Trk1-Trk4
   no ip address
   exit
vlan 1200
   name "voip-1200"
   tagged 9-22,Trk1-Trk4
   no ip address
   exit
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
spanning-tree Trk3 priority 4
spanning-tree Trk4 priority 4
spanning-tree config-name "stpconfig"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 10
spanning-tree instance 1 priority 2
spanning-tree instance 1 Trk1 priority 1
spanning-tree instance 1 Trk2 priority 1
spanning-tree instance 1 Trk3 priority 4
spanning-tree instance 1 Trk4 priority 4
spanning-tree instance 2 vlan 1-9 11-1999
spanning-tree instance 2 priority 1
spanning-tree instance 2 Trk1 priority 4
spanning-tree instance 2 Trk2 priority 4
spanning-tree instance 2 Trk3 priority 1
spanning-tree instance 2 Trk4 priority 1
spanning-tree priority 1

 

And here is what i get purple is to show you what seems ok and important, i have problem with what is in red

 

HP-2530-24G-SW2(config)# sh spanning-tree instance 1
 MST Instance Information

  Instance ID : 1
  Mapped VLANs : 10
  Switch Priority         : 8192

  Topology Change Count   : 104
  Time Since Last Change  : 13 mins

  Regional Root MAC Address : 5820b1-2e4900
  Regional Root Priority    : 4096
  Regional Root Path Cost   : 20000
  Regional Root Port        : Trk1
  Remaining Hops            : 19

                                                             Designated
  Port  Type      Cost      Priority Role       State        Bridge
  ----- --------- --------- -------- ---------- ------------ --------------
  1     100/1000T Auto      128      Disabled   Disabled
  2     100/1000T 20000     128      Designated Forwarding   480fcf-931840
  3     100/1000T Auto      128      Disabled   Disabled
  4     100/1000T Auto      128      Disabled   Disabled
  5     100/1000T Auto      128      Disabled   Disabled
  6     100/1000T Auto      128      Disabled   Disabled
  9     100/1000T Auto      128      Disabled   Disabled
  10    100/1000T 200000    128      Designated Forwarding   480fcf-931840
  11    100/1000T 200000    128      Designated Forwarding   480fcf-931840
  12    100/1000T Auto      128      Disabled   Disabled
  13    100/1000T Auto      128      Disabled   Disabled
  14    100/1000T Auto      128      Disabled   Disabled
  15    100/1000T Auto      128      Disabled   Disabled
  16    100/1000T Auto      128      Disabled   Disabled
  17    100/1000T Auto      128      Disabled   Disabled
  18    100/1000T Auto      128      Disabled   Disabled
  19    100/1000T Auto      128      Disabled   Disabled
  20    100/1000T Auto      128      Disabled   Disabled
  21    100/1000T Auto      128      Disabled   Disabled
  22    100/1000T Auto      128      Disabled   Disabled
  Trk1            20000     16       Root       Forwarding   5820b1-2e4900
  Trk2            20000     16       Designated Forwarding   480fcf-931840
  Trk3            20000     64       Alternate  Blocking     5820b1-2e4900
  Trk4            20000     64       Designated Forwarding   480fcf-931840

And the other instance, same problem with what's in red :

HP-2530-24G-SW2(config)# sh spanning-tree instance 2
 MST Instance Information

  Instance ID : 2
  Mapped VLANs : 1-9,11-1999
  Switch Priority         : 4096

  Topology Change Count   : 149
  Time Since Last Change  : 13 mins

  Regional Root MAC Address : 480fcf-931840
  Regional Root Priority    : 4096
  Regional Root Path Cost   : 0
  Regional Root Port        : This switch is root
  Remaining Hops            : 20

                                                             Designated
  Port  Type      Cost      Priority Role       State        Bridge
  ----- --------- --------- -------- ---------- ------------ --------------
  1     100/1000T Auto      128      Disabled   Disabled
  2     100/1000T 20000     128      Designated Forwarding   480fcf-931840
  3     100/1000T Auto      128      Disabled   Disabled
  4     100/1000T Auto      128      Disabled   Disabled
  5     100/1000T Auto      128      Disabled   Disabled
  6     100/1000T Auto      128      Disabled   Disabled
  9     100/1000T Auto      128      Disabled   Disabled
  10    100/1000T 200000    128      Designated Forwarding   480fcf-931840
  11    100/1000T 200000    128      Designated Forwarding   480fcf-931840
  12    100/1000T Auto      128      Disabled   Disabled
  13    100/1000T Auto      128      Disabled   Disabled
  14    100/1000T Auto      128      Disabled   Disabled
  15    100/1000T Auto      128      Disabled   Disabled
  16    100/1000T Auto      128      Disabled   Disabled
  17    100/1000T Auto      128      Disabled   Disabled
  18    100/1000T Auto      128      Disabled   Disabled
  19    100/1000T Auto      128      Disabled   Disabled
  20    100/1000T Auto      128      Disabled   Disabled
  21    100/1000T Auto      128      Disabled   Disabled
  22    100/1000T Auto      128      Disabled   Disabled
  Trk1            20000     64       Designated Forwarding   480fcf-931840
  Trk2            20000     64       Designated Forwarding   480fcf-931840
  Trk3            20000     16       Designated Forwarding   480fcf-931840
  Trk4            20000     16       Designated Forwarding   480fcf-931840

Once again i really appreciate your help.

Have a nice day

Advisor

Re: Spanning-tree with multiple VLAN an multiple uplink

Hi,

can you please stiil help me ?

Any advices on what i did and get in my previous post ?

Thanks

Respected Contributor

Re: Spanning-tree with multiple VLAN an multiple uplink

Seems to me you're almost there.
Make switch1 root for all instances. It will have both TRK1  and TRK3 forwarding for both instances.  That is OK!

Switch2 eventually "decides" which TRK will be used ! Sw2 spanning tree output should look like:
Instance1
trk1 root-port  forwarding
trk3 alternate-blocking
instance2
trk1 alternate blocking
trk3 root port forwarding

Focus on Instance 1. Since Sw2 is blocking on trk3, sw1 will not learn any MAC addresses on that port......and will not send data on it

Advisor

Re: Spanning-tree with multiple VLAN an multiple uplink

Really many thanks, i'll try all of that