HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Getting error after installing Qlogic QMH2462 driver in RHEL 4 update 5 on BL460c

 
SOLVED
Go to solution

Getting error after installing Qlogic QMH2462 driver in RHEL 4 update 5 on BL460c

Hello Gurus,

I have a c7000 enclosure that has BL460c servers in it. I have installed RedHat Enterprise Linux Version 4 Update 5 on the BL460c servers. I have this enclosure connected to an EVA 4400. I have created vdisk on the EVA and have presented them to the servers. Each server is having Qlogic QMH2462 card installed and I have downloaded and installed the driver (hp_qla2x00-2007-10-05a.tar.gz) on each server. As soon as I installed the just mentioned driver, it gave a failed dependencies error requesting that this "gcc-3.4.6-8.i386.rpm" be install. After installing, it requested for "glibc-devel-2.3.4-2.36.i386.rpm" and so on for "glibc-headers-2.3.4-2.36.i386.rpm" & "glibc-kernheaders-2.4-9.1.100.EL.i386.rpm" After installing this last one, I again reinstalled the driver (hp_qla2x00-2007-10-05a.tar.gz)and now it's requesting again all that I've already installed. Due to this problem, I'm unable to see from the linux with fdisk -l the vdisks in my EVA. Can anyone help me on this?
Knowledge is vital but knowledge without understanding is nothing.
10 REPLIES
Bharath_Pingali
Trusted Contributor
Solution

Re: Getting error after installing Qlogic QMH2462 driver in RHEL 4 update 5 on BL460c

Hello,

Can you uninstall the kit using "./INSTALL -u" and reinstall, while reinstalling please capture and attach the output.

Also "rpm -qa " would be helpful.

-Thank You
Bharath
Thomas Callahan
Valued Contributor

Re: Getting error after installing Qlogic QMH2462 driver in RHEL 4 update 5 on BL460c

If you had to manually install the packages, you are not using the package manager in redhat.

Use "up2date -i gcc" and that should install all dependencies as well.

Start fresh by removing the /opt/hp/src directory.

I would also recommend using the rpm that HP provides for the qla2xxx drivers, as it installs the source to /opt/hp/src/hp_qla2x00src, and then you simply go into that directory and run:

./INSTALL -f (for failover support)
./INSTALL (for non-failover)
Thomas Callahan
Valued Contributor

Re: Getting error after installing Qlogic QMH2462 driver in RHEL 4 update 5 on BL460c

I take that back, I'm thinking of a different driver.

After installing the rpm, you use:

./set_parm -x (to enable failover)
./master.sh -l (to determine kernel)
./master.sh -m

This will build the driver, install it to the source tree, and update your initrd file.

Re: Getting error after installing Qlogic QMH2462 driver in RHEL 4 update 5 on BL460c

Still I'm having same problem but however attached is the output of rpm -qa.
Knowledge is vital but knowledge without understanding is nothing.
Bharath_Pingali
Trusted Contributor

Re: Getting error after installing Qlogic QMH2462 driver in RHEL 4 update 5 on BL460c

Hello,

I dont see "gcc" installed in the list attached.

I also noticed that you dont have kernel-devel package installed that is required by the driver to compile.

Hope this helps.

-Bharath

Re: Getting error after installing Qlogic QMH2462 driver in RHEL 4 update 5 on BL460c

Hello Gurus,

Like I discussed about my EVA 4400, it has 4 vdisks on it presented to 8 BL460c servers. I have now upgraded the servers in my c7000 enclosure by 4. I have presented only 1 out of the 4 vdisks already presented to the first 8 servers to the new 4 servers. But since I installed the driver now and recompiled the kernel, I can now see the vdisk from the fdisk -l output which is attached. My question is - do I still need to create filesystem on this vdisk since I have already done before presenting it to the first 8 servers or not?
Knowledge is vital but knowledge without understanding is nothing.

Re: Getting error after installing Qlogic QMH2462 driver in RHEL 4 update 5 on BL460c

now i've created a mount point but whenever i try to mount, i get this error:
#mount /dev/sda1 /data/cdr
mount: you must specify the filesystem type

and when i try this, i get this one too:
# mount -t ext3 /dev/sda1 /data/cdr
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
or too many mounted file systems

Can someone help me.
Knowledge is vital but knowledge without understanding is nothing.
Bharath_Pingali
Trusted Contributor

Re: Getting error after installing Qlogic QMH2462 driver in RHEL 4 update 5 on BL460c

Hello,

my guess is you have to create a filesystem on that Lun before trying to mount.

Hope this Helps.

Bharath

Re: Getting error after installing Qlogic QMH2462 driver in RHEL 4 update 5 on BL460c

According to the information I got from the first engineer, he told me that they had data on the lun from the EVA but when I ran fdisk /dev/sda and printed the filesystem table, I noticed that he lied. So I created sub-partitions and filesystem on them and mounted them easily. Thanks for your assistance.

Wilfred
Knowledge is vital but knowledge without understanding is nothing.

Re: Getting error after installing Qlogic QMH2462 driver in RHEL 4 update 5 on BL460c

Thanks to all. Your comments really helped me in solving this problem. I'm grateful.

Wilfred
Knowledge is vital but knowledge without understanding is nothing.