BladeSystem Virtual Connect

OneView SPP upgrades for virtual connect

 
CadenLange
Frequent Advisor

OneView SPP upgrades for virtual connect

Hi

I'm not sure if this is correct forum as it's a C7000 virtual connect question but involves HPE OneView.

I've taken on C7000 blade system that is managed by a OneView appliance. OneView is currnetly 4.10 and scheduled for updating to 6.5 over the coming weeks. I also need to update the C7000 OA and VC firmware which I'll do through OneView.

My question is around the number of firmware 'hops' I need to take to get to the latest VC and OA versions. The last SPP loaded into OneView was 2018.11.0 and this was used to update the VC and AO firmware. I 'think' there is a best practice not to jump too many SPP releases between updates - but I can't find any technote on this best practice saying how many SPPs I can skip between updates. I think I'm ok with the following hops but is anyine able to confirm this to be ok?

starting at 2018.11.0 I'll then upload 2019.09.1 into OneView and upgrade the VC and OA firmware; then to 2020.09.2 (update VC and OA) then to 2021.05.0 (update VC and OA) then finally to 2021.10.0 which is the latest - I will update the VC and OA firmware with each SPP as I go through.

Am I safe with this approach?

many thanks

6 REPLIES 6
Torsten.
Acclaimed Contributor

Re: OneView SPP upgrades for virtual connect

It depends on what VC hardware you have and what firmware is currently running.

Not all modules are able to run the latest and greatest firmware version.

See VC release notes for details.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
support_s
System Recommended

Query: OneView SPP upgrades for virtual connect

Torsten.
Acclaimed Contributor

Re: Query: OneView SPP upgrades for virtual connect

@support_s 

Don't get me wrong, but many of your links are not really related and will confusing the people.

 

This is what bots usually do ...


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
CadenLange
Frequent Advisor

Re: Query: OneView SPP upgrades for virtual connect

Hi Torsten

Thanks for the quick reply. The VC is a flexfabric 20/40 F8 which I can see on page 8 of the 4.85 release notes is supported. The current version is 4.63 of VC and 4.85 for OA.

I couldn't see anything in the release notes for the Flexfabric 20/40 showing the supported firmware paths to 4.85. There is a table on page 20 but no mention of 'flexfabric' unless it groups flexfabric under "VC-Enet Modules"

I plan to got to the latest for each which I beleive to be 4.85 for VC and 4.97 of OA - it's how many SPP updates I need to step through to get there safely.

Is it the case that VC and OA firmware should not be updated more than a single release at a time?

Should I be going starting at 2018.11.0 -> 2019.09.1 -> 2020.09.2 -> 2021.05.0 then finally to 2021.10.0 as I think I read somewhere that SPPs should be applied using versions released less than 12 months from the current version

thanks

Torsten.
Acclaimed Contributor

Re: Query: OneView SPP upgrades for virtual connect

The only mention of any steps in the notes are here

 

A network outage may result when upgrading directly from VC 2.xx release version to VC 4.6x and later releases in a
Multi-Enclosure environment. Upgrade from VC 2.xx to VC 3.70 or VC 4.10 first, and then upgrade from VC 3.70 or
VC 4.10 to VC 4.6x and later releases in a Multi-Enclosure stacked domain.

 

However, if you above 4.6x, you should be able to go directly to the latest, OV will check this too before doing the upgrade (may depend on your OV version).

 

However, update servers firmware and drivers first.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
CadenLange
Frequent Advisor

Re: Query: OneView SPP upgrades for virtual connect

Thanks again Torsten - that makes sense 

I hear what you say about updating the server firmware and drivers first - best practice for when there is alreay an OS on the blades. However, I'm trying to understand the section in the 4.63 VC release notes where is talks about SPP support on page 18. My blade environment was fully updated using SPP 2018.11.0 which was deployed to all the blades plus the VC and OA and it was this SPP that took the VC to 4.63 from 4.50. The notes on page 18 say:

VC 4.63 supports the following SPPs

  • :SPP 2018.06.0
  • SPP 2018.03.0

I'm already on SPP 2018.11.0 so it sounds like the release notes are showing a backward compatibility to two previous SPP versions. Does this 'SPP Support' mean the SPP firmware dpeloyed to the blades as that would infer that if I upgraded the blades first (say to SPP 2019.09.1) then I wouldn't be running an SPP version that 4.63 would not support....... Am I misinterpreting the release notes?

Thanks