General
cancel
Showing results for 
Search instead for 
Did you mean: 

Kernel string misimatch error while installing Driver for HP Controller

prakasse
Advisor

Kernel string misimatch error while installing Driver for HP Controller

Hi,

The server appears to have problem accessing the internal drive/Smart Array. The server has Oracle Enterprise Linux 4 Update 5 (2.6.9-55.0.0.0.2.ELsmp)

---

The current version of ‘cciss’ driver is

filename: /lib/modules/2.6.9-55.0.0.0.2.ELsmp/kernel/drivers/block/cciss.ko

license: GPL

version: 2.6.14 7F7EF038ECE8DBCA04C6F57

description: Driver for HP Controller SA5xxx SA6xxx version 2.6.14.RH2

I downloaded the latest Proliant Support Package for RHEL 4 for AMD64/EM64T. All but the Smart Array Controller component were installed successfully.

I tried to installe it using the RPM – It errored out stating the kernel version does not match: 2.6.9-55.0.0.0.2.ELsmp Vs 2.6.9.55.EL.

Could you advice me how to resolve this problem?

Thanks in advance,
Senthil.

P.S: Below is the log file.
---------------------------------
[root@iop95 cciss]# rpm -ivh cpq_cciss-2.6.18-5.rhel4.x86_64.rpm
Preparing... ########################################### [100%]
The currently running kernel (2.6.9-55.0.0.0.2.ELsmp) is not supported by this rpm. The supported kernels are:

2.6.9-11.EL
2.6.9-11.ELsmp
2.6.9-22.EL
2.6.9-22.ELsmp
2.6.9-34.EL
2.6.9-34.ELlargesmp
2.6.9-34.ELsmp
2.6.9-42.0.3.EL
2.6.9-42.0.3.ELlargesmp
2.6.9-42.0.3.ELsmp
2.6.9-42.EL
2.6.9-42.ELlargesmp
2.6.9-42.ELsmp
2.6.9-5.0.3.EL
2.6.9-5.0.3.ELsmp
2.6.9-55.EL
2.6.9-55.ELlargesmp
2.6.9-55.ELsmp
2.6.9-5.EL
2.6.9-5.ELsmp

Please boot into a supported kernel before installing this rpm
error: %pre(cpq_cciss-2.6.18-5.x86_64) scriptlet failed, exit status 1
error: install: %pre scriptlet failed (2), skipping cpq_cciss-2.6.18-5
3 REPLIES
Don Vanco - Linux Ninja
Regular Advisor

Re: Kernel string misimatch error while installing Driver for HP Controller

Well, it's not an issue easily "fixed" - it's the installer doing what it's supposed to do. It does not believe that your kernel is in the "supported list" of kernels.

It is, in fact, an Oracle fork as far as I can tell (but I'm no unbreakable guru). So unbreakable appears... broken.

I'd install the "genuine" RH kernel, but that will nuke your support from Oracle. Time to open a ticket with Oracle and tell them to un-fork their kernel.

Is there an older Oracle update kernel that you can fall back on that is in the support list?

Don't know if setting any kind of env. vars will help - you may be able to "spoof" it with a sym link in /lib if that's what the script is doing - but my guess is they're using uname, and I am not sure how to spoof that.... You'd have to look at the install script that is failing to see if there's a way around.....

Good luck
DV-LN
Don Vanco - Linux Ninja
Regular Advisor

Re: Kernel string misimatch error while installing Driver for HP Controller

Also - are you _sure_ that's the latest CCISS driver? I am pretty sure I've installed those that support the .55 family of kernels....

Run your model # through the HP Support and Downloads tool and make sure you have the latest driver, and not just that from the PSP

D
prakasse
Advisor

Re: Kernel string misimatch error while installing Driver for HP Controller

Mismatched driver