cancel
Showing results for 
Search instead for 
Did you mean: 

Linux not booting after imaging

SOLVED
Go to solution
Jase4772
Regular Advisor

Linux not booting after imaging

Hi,

I've just restored a captured imaged from a BL460c G1 Blade onto a BL460c G6 version and after rebuilding the GRUB loader (works for G1 to G1) I can't get passed the Uncompressing Linux line.

After removing the quiet option it is stopping at CPU 1 irqstacks, hard=c03f7000 soft=c03d7000 message.

Is there anything that I can try to get this to boot or is the hardware just too different for the server to be made to work?

Thanks
Jason
6 REPLIES
Matti_Kurkela
Honored Contributor
Solution

Re: Linux not booting after imaging

Perhaps the kernel is too old/requires a specific bugfix on BL460c G6 hardware?

The HP support matrix says BL460c G6 requires RHEL 4.7 or above in the RHEL 4.x series, or RHEL 5.3 or above in the RHEL 5.x.

Update at least the kernel package to the appropriate level at the source and re-image, if possible. Or get an installation media of supported level, boot the destination system into rescue mode, then update the installed kernel in rescue mode.

Check out HP's Technical Exceptions Matrices for RHEL and SLES:

http://h18004.www1.hp.com/products/servers/linux/supportmatrix/rhel/exceptions/rhel-exceptions.html

http://h18004.www1.hp.com/products/servers/linux/supportmatrix/sles/exceptions/sles-exceptions.html

MK
MK
Jase4772
Regular Advisor

Re: Linux not booting after imaging

Thanks for the links to the support matrix that makes things a lot simpler to understand.

Guess I'll see if I can get the version updated from 4.6 to 4.8 and if not a clean install will be the only option.

Many thanks!
Alan_152
Honored Contributor

Re: Linux not booting after imaging

Which version of Linux? If it is a SuSE variant, read over this link: http://www.novell.com/support/php/search.do?cmd=displayKC&docType=kc&externalId=3048119
Jase4772
Regular Advisor

Re: Linux not booting after imaging

It's Red Hat 4.6 we were having trouble with.

Fingers crossed an upgrade works but I doubt it.

Thanks
Jase
Alan_152
Honored Contributor

Re: Linux not booting after imaging

How are you doing the imaging? I've never had any problems with Red Hat, Fedora, or SuSE when piping dd over ssh.
Jase4772
Regular Advisor

Re: Linux not booting after imaging

Taking the image with Altiris (basically Ghost) and then dumping it back onto a new server.

Works great when the server was G1 to G1 or even G1 Blade to a DL360 G5, but G6 no dice.