General
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem compiling Apache 2.2.11 with openssl support.

SOLVED
Go to solution

Problem compiling Apache 2.2.11 with openssl support.

Hi,

I've a little problem chen I try to compiling the new Apache 2.2.11 available since this morning on HP-UX website.

First of all, this is my configure command :

#!/bin/ksh

(
cd src/sources/apache2-2.2.11

GMK="/bustools/apache/2.2.10/make-3.81/bin/gmake"
PRFX="/bustools/apache/2.2.10"

${GMK} clean

PKG_CONFIG_PATH="/bustools/apache/2.2.10/openssl-0.9.8i/" \
MAKEOPTS="-j16" \
PATH="${PRFX}/apr-1.3.3/bin:${PRFX}/apr-util-1.3.4/bin:${PRFX}/openssl-0.9.8i/bin:${PRFX}/pkgconfig-0.23/bin:${PRFX}/expat-2.0.1/bin:${PRFX}/m4-1.4.12/bin:${PRFX}/bison-2.4
/bin:${PRFX}/texinfo-4.13/bin:${PRFX}/freetype-2.3.7/bin:${PRFX}/make-3.81/bin:${PRFX}/gettext-0.17/bin:${PRFX}/libiconv-1.12/bin:${PRFX}/fontconfig-2.6.0/bin:${PRFX}/libXf
t-2.1.13/bin:${PRFX}/tcltk-8.5.5/tcl/bin:${PRFX}/tcltk-8.5.5/tk/bin:${PRFX}/db-4.7.25/bin:$PATH" \
LDFLAGS="-L${PRFX}/renderproto-0.9.3/lib -L${PRFX}/gdbm-1.8.3/lib -L${PRFX}/expat-2.0.1/lib -L${PRFX}/m4-1.4.12/lib -L${PRFX}/bison-2.4/lib -L${PRFX}/texinfo-4.13/lib -L${P
RFX}/zlib-1.2.3/lib -L${PRFX}/freetype-2.3.7/lib -L${PRFX}/gettext-0.17/lib -L${PRFX}/libiconv-1.12/lib -L${PRFX}/fontconfig-2.6.0/lib -L${PRFX}/tcltk-8.5.5/tcl/lib -L${PRF
X}/tcltk-8.5.5/tk/lib -L${PRFX}/db-4.7.25/lib -L${PRFX}/openssl-0.9.8i/lib -L${PRFX}/apr-0.9.17/lib -L${PRFX}/apr_util-0.9.15/lib -L${PRFX}/perl-5.10.0/lib -L${PRFX}/perl-5
.10.0/lib/perl5/5.10.0/unicore/lib -L${PRFX}/apr-1.3.3/lib -L${PRFX}/apr-util-1.3.4/lib" \
LIBS="-L${PRFX}/renderproto-0.9.3/lib -L${PRFX}/gdbm-1.8.3/lib -L${PRFX}/expat-2.0.1/lib -L${PRFX}/m4-1.4.12/lib -L${PRFX}/bison-2.4/lib -L${PRFX}/texinfo-4.13/lib -L${PRFX
}/zlib-1.2.3/lib -L${PRFX}/freetype-2.3.7/lib -L${PRFX}/gettext-0.17/lib -L${PRFX}/libiconv-1.12/lib -L${PRFX}/fontconfig-2.6.0/lib -L${PRFX}/tcltk-8.5.5/tcl/lib -L${PRFX}/
tcltk-8.5.5/tk/lib -L${PRFX}/db-4.7.25/lib -L${PRFX}/openssl-0.9.8i/lib -L${PRFX}/apr-0.9.17/lib -L${PRFX}/apr_util-0.9.15/lib -L${PRFX}/perl-5.10.0/lib -L${PRFX}/perl-5.10
.0/lib/perl5/5.10.0/unicore/lib -L${PRFX}/apr-1.3.3/lib -L${PRFX}/apr-util-1.3.4/lib" \
./configure --prefix=${PRFX}/apache2-2.2.11 --with-included-apr --with-apr=${PRFX}/apr-1.3.3/bin/apr-1-config --with-apr-utils=${PRFX}/apr-util-1.3.4/bin/apu-1-config --wit
h-ssl=${PRFX}/openssl-0.9.8i --with-z=${PRFX}/zlib-1.2.3 \
&& ${GMK} && ${GMK} install
) && echo "Apache OK" || echo "Apache KO"

The result is :

checking for SSL/TLS toolkit base... /bustools/apache/2.2.10/openssl-0.9.8i
adding "-I/bustools/apache/2.2.10/openssl-0.9.8i/include" to CPPFLAGS
adding "-I/bustools/apache/2.2.10/openssl-0.9.8i/include" to INCLUDES
adding "-L/bustools/apache/2.2.10/openssl-0.9.8i/lib" to LDFLAGS
checking for OpenSSL version... checking openssl/opensslv.h usability... yes
checking openssl/opensslv.h presence... yes
checking for openssl/opensslv.h... yes
checking openssl/ssl.h usability... yes
checking openssl/ssl.h presence... yes
checking for openssl/ssl.h... yes
OK
forcing SSL_LIBS to "-lssl -lcrypto -ldld "
adding "-lssl" to LIBS
adding "-lcrypto" to LIBS
adding "-ldld" to LIBS
checking openssl/engine.h usability... yes
checking openssl/engine.h presence... yes
checking for openssl/engine.h... yes
checking for SSLeay_version... no
checking for SSL_CTX_new... no
checking for ENGINE_init... no
checking for ENGINE_load_builtin_engines... no
checking for SSL_set_cert_store... no
configure: error: ... Error, SSL/TLS libraries were missing or unusable
Apache KO


In previous versions, this bug was corriged by a patch but in this version the bug already was.
The old bug was available at https://issues.apache.org/bugzilla/show_bug.cgi?id=46018
And the patch corresponding :

Index: acinclude.m4
===================================================================
--- acinclude.m4 (Revision 711951)
+++ acinclude.m4 (Arbeitskopie)
@@ -447,10 +447,10 @@
pkglookup="`$PKGCONFIG --libs-only-L --libs-only-other openssl`"
APR_ADDTO(LDFLAGS, [$pkglookup])
else
- ap_ssltk_libs="-lssl -lcrypto"
+ ap_ssltk_libs="-lssl -lcrypto `$apr_config --libs`"
fi
else
- ap_ssltk_libs="-lssl -lcrypto"
+ ap_ssltk_libs="-lssl -lcrypto `$apr_config --libs`"
fi
fi
APR_SETVAR(SSL_LIBS, [$ap_ssltk_libs])


I may have forgot an option or something else. Or bad installed something but I think not.

Thanks in advance.
18 REPLIES

Re: Problem compiling Apache 2.2.11 with openssl support.

My config script more readable :

#!/bin/ksh

(
cd src/sources/apache2-2.2.11

GMK="/bustools/apache/2.2.10/make-3.81/bin/gmake"
PRFX="/bustools/apache/2.2.10"

${GMK} clean

PKG_CONFIG_PATH="/bustools/apache/2.2.10/openssl-0.9.8i/" \
MAKEOPTS="-j16" \
PATH="\
${PRFX}/apr-1.3.3/bin:\
${PRFX}/apr-util-1.3.4/bin:\
${PRFX}/openssl-0.9.8i/bin:\
${PRFX}/pkgconfig-0.23/bin:\
${PRFX}/expat-2.0.1/bin:\
${PRFX}/m4-1.4.12/bin:\
${PRFX}/bison-2.4/bin:\
${PRFX}/texinfo-4.13/bin:\
${PRFX}/freetype-2.3.7/bin:\
${PRFX}/make-3.81/bin:\
${PRFX}/gettext-0.17/bin:\
${PRFX}/libiconv-1.12/bin:\
${PRFX}/fontconfig-2.6.0/bin:\
${PRFX}/libXft-2.1.13/bin:\
${PRFX}/tcltk-8.5.5/tcl/bin:\
${PRFX}/tcltk-8.5.5/tk/bin:\
${PRFX}/db-4.7.25/bin:$PATH" \
LDFLAGS="\
-L${PRFX}/renderproto-0.9.3/lib \
-L${PRFX}/gdbm-1.8.3/lib \
-L${PRFX}/expat-2.0.1/lib \
-L${PRFX}/m4-1.4.12/lib \
-L${PRFX}/bison-2.4/lib \
-L${PRFX}/texinfo-4.13/lib \
-L${PRFX}/zlib-1.2.3/lib \
-L${PRFX}/freetype-2.3.7/lib \
-L${PRFX}/gettext-0.17/lib \
-L${PRFX}/libiconv-1.12/lib \
-L${PRFX}/fontconfig-2.6.0/lib \
-L${PRFX}/tcltk-8.5.5/tcl/lib \
-L${PRFX}/tcltk-8.5.5/tk/lib \
-L${PRFX}/db-4.7.25/lib \
-L${PRFX}/openssl-0.9.8i/lib \
-L${PRFX}/apr-0.9.17/lib \
-L${PRFX}/apr_util-0.9.15/lib \
-L${PRFX}/perl-5.10.0/lib \
-L${PRFX}/perl-5.10.0/lib/perl5/5.10.0/unicore/lib \
-L${PRFX}/apr-1.3.3/lib \
-L${PRFX}/apr-util-1.3.4/lib" \
LIBS="\
-L${PRFX}/renderproto-0.9.3/lib \
-L${PRFX}/gdbm-1.8.3/lib \
-L${PRFX}/expat-2.0.1/lib \
-L${PRFX}/m4-1.4.12/lib \
-L${PRFX}/bison-2.4/lib \
-L${PRFX}/texinfo-4.13/lib \
-L${PRFX}/zlib-1.2.3/lib \
-L${PRFX}/freetype-2.3.7/lib \
-L${PRFX}/gettext-0.17/lib \
-L${PRFX}/libiconv-1.12/lib \
-L${PRFX}/fontconfig-2.6.0/lib \
-L${PRFX}/tcltk-8.5.5/tcl/lib \
-L${PRFX}/tcltk-8.5.5/tk/lib \
-L${PRFX}/db-4.7.25/lib \
-L${PRFX}/openssl-0.9.8i/lib \
-L${PRFX}/apr-0.9.17/lib \
-L${PRFX}/apr_util-0.9.15/lib \
-L${PRFX}/perl-5.10.0/lib \
-L${PRFX}/perl-5.10.0/lib/perl5/5.10.0/unicore/lib \
-L${PRFX}/apr-1.3.3/lib \
-L${PRFX}/apr-util-1.3.4/lib" \
./configure \
--prefix=${PRFX}/apache2-2.2.11 \
--with-included-apr \
--with-apr=${PRFX}/apr-1.3.3/bin/apr-1-config \
--with-apr-utils=${PRFX}/apr-util-1.3.4/bin/apu-1-config \
--with-ssl=${PRFX}/openssl-0.9.8i \
--with-z=${PRFX}/zlib-1.2.3 \
&& ${GMK} && ${GMK} install
) && echo "Apache OK" || echo "Apache KO"
Steven E. Protter
Exalted Contributor

Re: Problem compiling Apache 2.2.11 with openssl support.

Shalom,

Apache 2.2 might be available in depot form on http://software.hp.com

ssl support will be compiled in. Depot install saves you this trouble.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com

Re: Problem compiling Apache 2.2.11 with openssl support.

Unfortunatly, I need to compile myself Apache. Binary version can't help me.

Re: Problem compiling Apache 2.2.11 with openssl support.

This is a part of my config.log...

sharedstatedir='${prefix}/com'
sysconfdir='${prefix}/etc'
target='hppa2.0w-hp-hpux11.11'
target_alias=''
target_cpu='hppa2.0w'
target_os='hpux11.11'
target_vendor='hp'

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_NAME ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define PACKAGE_STRING ""
#define PACKAGE_BUGREPORT ""
#define STDC_HEADERS 1
#define HAVE_SYS_TYPES_H 1
#define HAVE_SYS_STAT_H 1
#define HAVE_STDLIB_H 1
#define HAVE_STRING_H 1
#define HAVE_MEMORY_H 1
#define HAVE_STRINGS_H 1
#define HAVE_INTTYPES_H 1
#define HAVE_UNISTD_H 1
#define __EXTENSIONS__ 1
#define _ALL_SOURCE 1
#define _GNU_SOURCE 1
#define _POSIX_PTHREAD_SEMANTICS 1
#define _TANDEM_SOURCE 1
#define STDC_HEADERS 1
#define HAVE_STRING_H 1
#define HAVE_LIMITS_H 1
#define HAVE_UNISTD_H 1
#define HAVE_SYS_SOCKET_H 1
#define HAVE_PWD_H 1
#define HAVE_GRP_H 1
#define HAVE_STRINGS_H 1
#define HAVE_SYS_SEM_H 1
#define HAVE_SYS_WAIT_H 1
#define HAVE_GETPWNAM 1
#define HAVE_GETGRNAM 1
#define HAVE_INITGROUPS 1
#define HAVE_GETPGID 1
#define AP_ENABLE_V4_MAPPED 1
#define HAVE_SYS_TIMES_H 1
#define HAVE_TIMES 1
#define HAVE_OPENSSL_OPENSSLV_H 1
#define HAVE_OPENSSL_SSL_H 1
#define HAVE_OPENSSL_ENGINE_H 1

configure: exit 1

Thanks in advance.
Shinji Teragaito_1
Respected Contributor

Re: Problem compiling Apache 2.2.11 with openssl support.

Hi,

I tried to build Apache 2.2.11 with OpenSSL support on HP-UX 11.11:

* use HP-UX OpenSSL A.00.09.07m.032 installed at /opt/openssl
* make no changes to acinclude.m4 as you described

Eventually I can not duplicate your configure script problem on
my environment.

% model
9000/800/A500-5X
% uname -r
B.11.11
% swlist | grep OpenSSL
OpenSSL A.00.09.07m.032 Secure Network Communications Protocol
%

Here's my configure line:

% env CC=cc CFLAGS="+O2" LDFLAGS="-Wl,-E \
-Wl,+b,/usr/local/apache2/lib:/usr/local/lib:/opt/openssl/lib \
-L/usr/local/lib -L`pwd`/srclib/apr/.libs \
-L`pwd`/srclib/apr-util/xml/expat/lib/.libs \
-L`pwd`/srclib/apr-util/.libs -L/opt/openssl/lib" \
./configure --enable-so --with-mpm=worker --enable-mod-shared=all \
--enable-ssl --with-ssl=/opt/openssl --enable-module=ssl \
--prefix=/usr/local/apache2 2>&1 | tee configure.log

Best Regards,

Shinji

Re: Problem compiling Apache 2.2.11 with openssl support.

I had not remarked OpenSSL was already installed. I decided to use it.

root@miahp052:/Datas/MIADZFR4/INSTALL_APACHE # swlist | grep OpenSSL
OpenSSL A.00.09.07l Secure Network Communications Protocol

This is my new apache install command :

-------------------------------------------
#!/bin/ksh

(
cd src/sources/apache2-2.2.11

GMK="/bustools/apache/2.2.10/make-3.81/bin/gmake"
PRFX="/bustools/apache/2.2.10"

${GMK} clean

LIBS="-ldl" \
PKG_CONFIG_PATH="/bustools/apache/2.2.10/openssl-0.9.8i/" \
MAKEOPTS="-j16" \
PATH="\
${PRFX}/apr-1.3.3/bin:\
${PRFX}/apr-util-1.3.4/bin:\
${PRFX}/openssl-0.9.8i/bin:\
/opt/openssl/bin:\
${PRFX}/pkgconfig-0.23/bin:\
${PRFX}/expat-2.0.1/bin:\
${PRFX}/m4-1.4.12/bin:\
${PRFX}/bison-2.4/bin:\
${PRFX}/texinfo-4.13/bin:\
${PRFX}/freetype-2.3.7/bin:\
${PRFX}/make-3.81/bin:\
${PRFX}/gettext-0.17/bin:\
${PRFX}/libiconv-1.12/bin:\
${PRFX}/fontconfig-2.6.0/bin:\
${PRFX}/libXft-2.1.13/bin:\
${PRFX}/tcltk-8.5.5/tcl/bin:\
${PRFX}/tcltk-8.5.5/tk/bin:\
${PRFX}/db-4.7.25/bin:$PATH" \
LDFLAGS="\
-Wl,-E -Wl,+b,{PRFX}/renderproto-0.9.3/lib\
:${PRFX}/gdbm-1.8.3/lib\
:${PRFX}/expat-2.0.1/lib\
:${PRFX}/m4-1.4.12/lib\
:${PRFX}/bison-2.4/lib\
:${PRFX}/texinfo-4.13/lib\
:${PRFX}/zlib-1.2.3/lib\
:${PRFX}/freetype-2.3.7/lib\
:${PRFX}/gettext-0.17/lib\
:${PRFX}/libiconv-1.12/lib\
:${PRFX}/fontconfig-2.6.0/lib\
:${PRFX}/tcltk-8.5.5/tcl/lib\
:${PRFX}/tcltk-8.5.5/tk/lib\
:${PRFX}/db-4.7.25/lib\
:${PRFX}/openssl-0.9.8i/lib\
:${PRFX}/apr-0.9.17/lib\
:${PRFX}/apr_util-0.9.15/lib\
:${PRFX}/perl-5.10.0/lib\
:${PRFX}/perl-5.10.0/lib/perl5/5.10.0/unicore/lib\
:${PRFX}/apr-1.3.3/lib\
:${PRFX}/apr-util-1.3.4/lib\
:/opt/openssl/lib \
-L${PRFX}/renderproto-0.9.3/lib \
-L${PRFX}/gdbm-1.8.3/lib \
-L${PRFX}/expat-2.0.1/lib \
-L${PRFX}/m4-1.4.12/lib \
-L${PRFX}/bison-2.4/lib \
-L${PRFX}/texinfo-4.13/lib \
-L${PRFX}/zlib-1.2.3/lib \
-L${PRFX}/freetype-2.3.7/lib \
-L${PRFX}/gettext-0.17/lib \
-L${PRFX}/libiconv-1.12/lib \
-L${PRFX}/fontconfig-2.6.0/lib \
-L${PRFX}/tcltk-8.5.5/tcl/lib \
-L${PRFX}/tcltk-8.5.5/tk/lib \
-L${PRFX}/db-4.7.25/lib \
-L${PRFX}/openssl-0.9.8i/lib \
-L/opt/openssl/lib \
-L${PRFX}/apr-0.9.17/lib \
-L${PRFX}/apr_util-0.9.15/lib \
-L${PRFX}/perl-5.10.0/lib \
-L${PRFX}/perl-5.10.0/lib/perl5/5.10.0/unicore/lib \
-L${PRFX}/apr-1.3.3/lib \
-L${PRFX}/apr-util-1.3.4/lib" \
LIBS="\
-L${PRFX}/renderproto-0.9.3/lib \
-L${PRFX}/gdbm-1.8.3/lib \
-L${PRFX}/expat-2.0.1/lib \
-L${PRFX}/m4-1.4.12/lib \
-L${PRFX}/bison-2.4/lib \
-L${PRFX}/texinfo-4.13/lib \
-L${PRFX}/zlib-1.2.3/lib \
-L${PRFX}/freetype-2.3.7/lib \
-L${PRFX}/gettext-0.17/lib \
-L${PRFX}/libiconv-1.12/lib \
-L${PRFX}/fontconfig-2.6.0/lib \
-L${PRFX}/tcltk-8.5.5/tcl/lib \
-L${PRFX}/tcltk-8.5.5/tk/lib \
-L${PRFX}/db-4.7.25/lib \
-L${PRFX}/openssl-0.9.8i/lib \
-L/opt/openssl/lib \
-L${PRFX}/apr-0.9.17/lib \
-L${PRFX}/apr_util-0.9.15/lib \
-L${PRFX}/perl-5.10.0/lib \
-L${PRFX}/perl-5.10.0/lib/perl5/5.10.0/unicore/lib \
-L${PRFX}/apr-1.3.3/lib \
-L${PRFX}/apr-util-1.3.4/lib" \
./configure \
--prefix=${PRFX}/apache2-2.2.11 \
--with-included-apr \
--enable-module=ssl \
--enable-ssl \
--with-apr=${PRFX}/apr-1.3.3/bin/apr-1-config \
--with-apr-utils=${PRFX}/apr-util-1.3.4/bin/apu-1-config \
--with-ssl=/opt/openssl \
--with-z=${PRFX}/zlib-1.2.3 \
&& ${GMK} && ${GMK} install
) && echo "Apache OK" || echo "Apache KO"
-------------------------------------------

Thanks in advance.
Shinji Teragaito_1
Respected Contributor
Solution

Re: Problem compiling Apache 2.2.11 with openssl support.

Hi Florian,

Even if you installed OpenSSL, do you receive the same error
from the configure script ?

If yes, you should removed the following first line from your
configure line to use HP OpenSSL:

-L${PRFX}/openssl-0.9.8i/lib \ <---- REMOVE
-L/opt/openssl/lib \

By the way, have you ever confirmed you can compile Apache
2.2.11 with very simple configurations ("--enable-so
--with-mpm=worker --enable-mods-shared=all
--with-z=${PRFX}/zlib-1.2.3" only) on your development
environment ?If you have not, I'd like to recommend you to do
that. Small start may be worthwhile :-)

Best Regards,

Shinji

Re: Problem compiling Apache 2.2.11 with openssl support.

Hi Shinji,

I've done modification you told me.
First, I've removed the openssl-0.9.8i lines in my configure line.
Second, I've tryed to compile with just these options :

+---
|--enable-so \
|--with-mpm=worker \
|--with-included-apr \
|--enable-mods-shared=all \
|--prefix=${PRFX}/apache2-2.2.11 \
|--with-z=${PRFX}/zlib-1.2.3 \
+---

Of course, I have let my $PATH and $LIBS var because of I've not installed libraries in a compliant folder ;).

I hurt on the same problem with this two configuration... :(

+---
|configure: error: ... Error, SSL/TLS |libraries were missing or unusable
+---

Why does openssl isn't recognized as usable by apache ?

Thanks for your help.
Shinji Teragaito_1
Respected Contributor

Re: Problem compiling Apache 2.2.11 with openssl support.

Hi Florian,

First please let me correct slightly my previous message:

> 2.2.11 with very simple configurations ("--enable-so
> --with-mpm=worker --enable-mods-shared=all
> --with-z=${PRFX}/zlib-1.2.3" only) on your development

As the simple configurations, I was going to write "--enable-so
--with-mpm=worker". Terribly sorry.

Anyway, if this configure line doesn't cause any problem, you
should confirm if 'make' works successfully.

If this configure line causes a problem, you should try to
launch the configure script such as 'sh -x ./configure ....' .

|configure: error: ... Error, SSL/TLS |libraries were missing or unusable

You should find where 'liberrors' is configured as "yes" from
the output messages from 'sh -x ./configure'.

Best Regards,

Shinji

Re: Problem compiling Apache 2.2.11 with openssl support.

Hi,
I've just come to remove "yes" to liberrors value corresponding to my problem. The configuration step still look work.
Now I have a problem during compilation :

/bin/sh /Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib/apr/libtool --silent --mode=compile cc -Ae +Z +DAportable -mt -O +Onoprocelim -I/usr/local/include -DHAVE_CONFIG_H -DHPUX11 -D_REENTRANT -D_HPUX_SOURCE -D_LARGEFILE64_SOURCE -O +Onoprocelim -I/usr/local/include -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib/apr-util/include -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib/apr-util/include/private -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib/apr/include -I/usr/local/include -o uri/apr_uri.lo -c uri/apr_uri.c && touch uri/apr_uri.lo
/bin/sh /Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib/apr/libtool --silent --mode=compile cc -Ae +Z +DAportable -mt -O +Onoprocelim -I/usr/local/include -DHAVE_CONFIG_H -DHPUX11 -D_REENTRANT -D_HPUX_SOURCE -D_LARGEFILE64_SOURCE -O +Onoprocelim -I/usr/local/include -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib/apr-util/include -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib/apr-util/include/private -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib/apr/include -I/usr/local/include -o xml/apr_xml.lo -c xml/apr_xml.c && touch xml/apr_xml.lo
cpp: "xml/apr_xml.c", line 35: error 4036: Can't open include file 'expat.h'.
gmake[3]: *** [xml/apr_xml.lo] Error 1
gmake[3]: Leaving directory `/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib/apr-util'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib/apr-util'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib'
gmake: *** [all-recursive] Error 1
Apache KO

But expat.h exists in my INCLUDE var and is present in the directory :

root@miahp052:/Datas/MIADZFR4/INSTALL_APACHE # find /bustools/apache/2.2.10/expat-2.0.1 -name expat.h -follow
/bustools/apache/2.2.10/expat-2.0.1/include/expat.h

Any idea ??

Re: Problem compiling Apache 2.2.11 with openssl support.

OK. I've just resolved the problem concerning the missing expat.h -> The Apache's configure call the apr-util's configure but before that, the path of my expat.h was disapeared of the apr-util's Makefile. I had to had it myself in the INCLUDE line.

I'm confronted to another problem but I will search myself this afternoon and come back here tomorrow. ;)

Re: Problem compiling Apache 2.2.11 with openssl support.

Hi all,

I have another little problem :) ... but I think that it will be the last one. When I compile Apache, I'm knocked into this error :

gmake[2]: Entering directory `/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/support'
/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib/apr/libtool --silent --mode=compile cc -Ae +Z +DAportable -mt -O +Onoprocelim -I/usr/local/include -DHPUX11 -D_REENTRANT -D_HPUX_SOURCE -D_LARGEFILE64_SOURCE -O +Onoprocelim -I/usr/local/include -I/bustools/apache/2.2.10/renderproto-0.9.3/include -I/bustools/apache/2.2.10/gdbm-1.8.3/include -I/bustools/apache/2.2.10/expat-2.0.1/include -I/bustools/apache/2.2.10/zlib-1.2.3/include -I/bustools/apache/2.2.10/freetype-2.3.7/include -I/bustools/apache/2.2.10/gettext-0.17/include -I/bustools/apache/2.2.10/libiconv-1.12/include -I/bustools/apache/2.2.10/fontconfig-2.6.0/include -I/bustools/apache/2.2.10/tcltk-8.5.5/tcl/include -I/bustools/apache/2.2.10/tcltk-8.5.5/tk/include -I/bustools/apache/2.2.10/db-4.7.25/include -I/bustools/apache/2.2.10/openssl-0.9.8i/include -I/bustools/apache/2.2.10/apr-1.3.3/include -I/bustools/apache/2.2.10/apr-util-1.3.4/include -I/bustools/apache/2.2.10/apr-1.3.3/include/apr/include -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib/pcre -I. -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/os/unix -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/server/mpm/worker -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/modules/http -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/modules/filters -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/modules/proxy -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/include -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/modules/generators -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/modules/mappers -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/modules/database -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib/apr/include -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib/apr-util/include -I/usr/local/include -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/server -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/modules/proxy/../generators -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/modules/ssl -I/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/modules/dav/main -prefer-non-pic -static -c htpasswd.c && touch htpasswd.lo
/Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib/apr/libtool --silent --mode=link cc -Ae +Z +DAportable -mt -O +Onoprocelim -I/usr/local/include -L/bustools/apache/2.2.10/zlib-1.2.3/lib -L/bustools/apache/2.2.10/openssl-0.9.8i/lib -L/usr/local/lib -L/usr/local/lib/hpux32 -Wl,+b -Wl,/usr/local/lib:/usr/local/lib/hpux32:/usr/local/apache2/lib -o htpasswd htpasswd.lo -lm /Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib/pcre/libpcre.la /Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib/apr-util/libaprutil-1.la /Datas/MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib/apr/libapr-1.la -lrt -lm -lpthread -ldld -L../srclib/apr/.libs
libtool: link: warning: this platform does not like uninstalled shared libraries
libtool: link: `htpasswd' will be relinked during installation
/usr/ccs/bin/ld: Unsatisfied symbols:
apr_generate_random_bytes (first referenced in .libs/htpasswd.o) (code)
gmake[2]: *** [htpasswd] Error 1
Dennis Handly
Acclaimed Contributor

Re: Problem compiling Apache 2.2.11 with openssl support.

>I'm knocked into this error:

You don't know where apr_generate_random_bytes is defined?

If you have a bunch of libs you can look at each with:
nm -pxAN path-to-libs/lib* | grep apr_generate_random_bytes
Shinji Teragaito_1
Respected Contributor

Re: Problem compiling Apache 2.2.11 with openssl support.

Hi Florian,

Let us know if libapr is generated or not.

Here's my libapr when building Apache + OpenSSL:

% ll srclib/apr/.libs
total 1250
-rw-r--r-- 1 shinji users 323236 Jan 7 17:21 libapr-1.a
lrwxr-xr-x 1 shinji users 14 Jan 7 17:21 libapr-1.la -> ../libapr-1.la
-rw-r--r-- 1 shinji users 1019 Jan 7 17:21 libapr-1.lai
lrwxr-xr-x 1 shinji users 15 Jan 7 17:21 libapr-1.sl -> libapr-1.sl.3.3
lrwxr-xr-x 1 shinji users 15 Jan 7 17:21 libapr-1.sl.3 -> libapr-1.sl.3.3
-rwxr-xr-x 1 shinji users 315392 Jan 7 17:21 libapr-1.sl.3.3
%

Regards,

Shinji

Re: Problem compiling Apache 2.2.11 with openssl support.

MIADZFR4/INSTALL_APACHE/src/sources/apache2-2.2.11/srclib/apr/.libs # ll
total 1244
-rw-r--r-- 1 root sys 319220 Jan 9 17:22 libapr-1.a
lrwxr-xr-x 1 root sys 14 Jan 9 17:22 libapr-1.la -> ../libapr-1.la
-rw-r--r-- 1 root sys 1735 Jan 9 17:22 libapr-1.lai
lrwxr-xr-x 1 root sys 15 Jan 9 17:22 libapr-1.sl -> libapr-1.sl.3.3
lrwxr-xr-x 1 root sys 15 Jan 9 17:22 libapr-1.sl.3 -> libapr-1.sl.3.3
-rwxr-xr-x 1 root sys 315392 Jan 9 17:22 libapr-1.sl.3.3


Generated...
Shinji Teragaito_1
Respected Contributor

Re: Problem compiling Apache 2.2.11 with openssl support.

Hi Florian,

I attempted to use the latest expat library like you.

NOTE: apr and apr-util have not been built prior to the Apache build
because Apache 2.2.11 has bundled the latest version.

Please refer to my steps in the attached file.

Best Regards,

Shinji
Shinji Teragaito_1
Respected Contributor

Re: Problem compiling Apache 2.2.11 with openssl support.

I failed to attach a file to my previous message.

I try again. Here you go.
Scott R Bell
Occasional Visitor

Re: Problem compiling Apache 2.2.11 with openssl support.

Hi there. So far as I can tell, apr_generate_random_bytes is not defined anywhere that gets compiled. I see it in several source files inside of the apr directory of the Apache install, but not inside of any of the libraries.

Nothing here in this question seems to answer how to get past the problem during make when we get the unsatisfied symbols error. I am not trying to install expat (of any version) so that does not seem likely to be a problem. Has anyone had this error and been able to solve it?