Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

X -query not working

X -query not working

Hi,

Ive got a PC running standard RedHat 7.0. X works fine.
From my HP workstation if I do; X -query I get a grey screen up but never a login. If I do a -query to any other HP server it works fine.

What do I need to do with my Redhat setup to allow remote X queries to work ?

Thanks.
13 REPLIES
Vincenzo Restuccia
Honored Contributor

Re: X -query not working

X -once -query

Re: X -query not working


X -once -query doesnt work. Same problem. Any more ideas anyone ?
Vincenzo Restuccia
Honored Contributor

Re: X -query not working

Michael Aos
Advisor

Re: X -query not working

Assuming gnome, you need to modify /etc/X11/gdm/gdm.conf. Under:

[xdmcp]
enable=true

Re: X -query not working


Thanks for the replies guys but no good. Tried them all, still only get a grey screen up, no login. Any more ideas ??

Vincenzo Restuccia
Honored Contributor
Michael Aos
Advisor

Re: X -query not working

I suspected the font path would cause him grief (great URL, wish I'd found that a couple years ago!) as well, but it doesn't sound like he's even getting that far.

Have you tried restarting gdm since modifying gdm.conf?

Re: X -query not working


Hi,

I have restarted gdm (Iand the PC). Still no joy. Im running the X -query from my HP workstation so surely I need a font server up and running on the PC running RedHat to point to ?? Ive tried pointing to my font server running on my HP but no good. Still same problem - I get a grey X screen up, but no login.

Any more ideas ???
Michael Aos
Advisor

Re: X -query not working

Actually, you need the font server running on an HP-UX box.

The problem was that CDE required some HP-specific fonts and dies without them.

Mike
Michael Aos
Advisor

Re: X -query not working

Oops, sorry, I was starting to get confused in what you wanted to do.

If you're wanting to get an HP CDE (dtlogin) on your RedHat Linux box, then setting up an HP-UX font server did the trick for me.

If you just want a gdm / xdm login prompt on your HP-UX box, then setting up xdm or gdm should do it for you. No font server required.

Mike

Re: X -query not working

Michael,

thanks for the replies. Yes, Im on my HP workstation in command line mode (no CDE) and Im trying to X -query to my Redhat PC. Cant get it to work at all. The question is how do you setup gdm or xdm so it will work ??
Mark Fenton
Esteemed Contributor

Re: X -query not working

Here's the gdm.conf I'm using (RH 6.2, sorry, but I think it'd be essentially the same for 7.0....) which seems to work normally:

And yes, all I had to do was edit the .conf and restart gdm.

[root@linux2 gdm]# cat gdm.conf
[daemon]
Chooser=/usr/bin/gdmchooser --disable-sound --disable-crash-dialog
DefaultPath=/usr/bin:/bin:/usr/X11R6/bin:/usr/local/bin:/opt/bin
DisplayInitDir=/etc/X11/gdm/Init
Greeter=/usr/bin/gdmlogin --disable-sound --disable-crash-dialog
Group=gdm
HaltCommand=/sbin/shutdown -h now
KillInitClients=1
LogDir=/var/gdm
PidFile=/var/run/gdm.pid
PostSessionScriptDir=/etc/X11/gdm/PostSession/
PreSessionScriptDir=/etc/X11/gdm/PreSession/
RebootCommand=/sbin/shutdown -r now
RootPath=/sbin:/usr/sbin:/usr/bin:/bin:/usr/X11R6/bin:/usr/local/bin:/opt/bin
ServAuthDir=/var/gdm
SessionDir=/etc/X11/gdm/Sessions/
User=gdm
UserAuthDir=
UserAuthFBDir=/tmp
UserAuthFile=.Xauthority

[security]
AllowRoot=1
RelaxPermissions=1
RetryDelay=3
UserMaxFile=65536
VerboseAuth=1

[xdmcp]
Enable=1
HonorIndirect=1
MaxPending=4
MaxPendingIndirect=4
MaxSessions=16
MaxWait=30
MaxWaitIndirect=30
Port=177

[gui]
GtkRC=
MaxIconWidth=128
MaxIconHeight=128

[greeter]
Browser=1
DefaultFace=/usr/share/pixmaps/nobody.png
DefaultLocale=english
Exclude=bin,daemon,adm,lp,sync,shutdown,halt,mail,news,uucp,operator,nobody
Font=-adobe-helvetica-bold-r-normal-*-*-180-*-*-*-*-*-*
GlobalFaceDir=/usr/share/faces/
Icon=/usr/share/pixmaps/gdm.xpm
LocaleFile=/etc/X11/gdm/locale.alias
Logo=/usr/share/pixmaps/gnome-logo-large.png
Quiver=0
SystemMenu=1
Welcome=Welcome to %n
Welcome[de]=Willkommen auf %n
Welcome[fr]=Bienvenue sur %n
Welcome[ja]=%n ??????????
[chooser]
DefaultHostImg=/usr/share/pixmaps/nohost.png
HostImageDir=/usr/share/hosts/
ScanTime=3

[debug]
Enable=0

[servers]
0=/usr/bin/X11/X
1=/usr/bin/X11/X

Best regards.

Re: X -query not working

Mark,

thanks for the info. Tried it but still the same problem. Ive even tried rebuilding my HP workstation so its nice and clean, still same problem.

Anybody got any more ideas ?