cancel
Showing results for 
Search instead for 
Did you mean: 

fbackup help

Tiago_BP
Occasional Advisor

fbackup help

Always use tar to backup, but there is a limit of 8 GB per file, so I want to backup with fbackup

I'm trying to backup with fbackup, but the following is happening, what is wrong?

the tape must be cleaned before the process? How?

PS: sorry, writing via google translator...

 

fbackup -f /dev/rtape/tape1_BESTn -i /u/desfontes/tiago –v

 

fbackup -f /dev/rtape/tape1_BESTn -i /u/desfontes/tiago -v

fbackup(1004): session begins on Fri Dec  7 08:38:13 2012

fbackup(3205): WARNING: unable to read a volume header

fbackup(3024): writing volume 1 to the output file /dev/rtape/tape1_BESTn

   1: / 16

   2: /u 2

   3: /u/desfontes 136

   4: /u/desfontes/tiago 2

   5: /u/desfontes/tiago/piscof_0612 15860

   6: /u/desfontes/tiago/piscof_1012 15837

fbackup(1005): run time: 17 seconds

fbackup(3055): total file blocks read for backup: 31853

fbackup(3056): total blocks written to output file /dev/rtape/tape1_BESTn: 31892

fbackup(1030): warnings encountered during backup

 

 

frecover -f /dev/rtape/tape1_BESTn -x -N –v

frecover(2105): did not find expected file marker

frecover(5409): unable to read volume header

frecover(5418): not an fbackup volume; unable to read volume header

frecover(2105): did not find expected file marker

frecover(5412): Do you wish to try to salvage this volume? (^[yY]/^[nN]) Y

frecover(5413): attempting to read backup following bad volume header

frecover(5426): read error while attempting to read index.  Skipping.

 

 

 

frecover -f /dev/rtape/tape1_BESTn -x -v -i /u/desfontes/tiago/piscof_0612

frecover(5419): checksum on volume header is incorrect.

frecover(5420): not an fbackup volume; magic value is incorrect

frecover(2105): did not find expected file marker

frecover(5412): Do you wish to try to salvage this volume? (^[yY]/^[nN])

1 REPLY
Dennis Handly
Acclaimed Contributor

Re: fbackup help

>there is a limit of 8 GB per file

 

pax(1) doesn't have that limit but slower than

 

You're using a no rewind tape.  (I thought that would produce an obvious error and reject it?)

 

Here is what fbackup(1m) says:
fbackup should not be used with no-rewind devices, for example, /dev/rmt/0mn or
/dev/rtape/tape1_BESTn on systems where legacy Device Special Files (DSF) is disabled.