cancel
Showing results for 
Search instead for 
Did you mean: 

how to setup disabling GUI start

SOLVED
Go to solution
file system
Frequent Advisor

how to setup disabling GUI start

Hi all

I'm going to stop loading Gui start next time.
what can I should do.

can you help me?

any tips are good. and I want that it dose not need to reboot.
6 REPLIES
Ragu_3
Trusted Contributor
Solution

Re: how to setup disabling GUI start

>> to stop loading Gui start next time

Either you have one of the X managers (kdm/gdm/xdm) load by default via runlevel 2 or your /etc/inittab having an entry like "id:5:initdefault:", change the 5 to 2 or 3.
Please do an "update-rc.d -f kdm remove" too.
Debian GNU/Linux for the Enterprise! Ask HP ...
file system
Frequent Advisor

Re: how to setup disabling GUI start

Dose it have command like below?

update-rc.d -f kdm remove


Linux dose not have update-rc.d.
Can you give more details about that command?
Silju
Advisor

Re: how to setup disabling GUI start

Hi,

you can disable the GUI start by keeping the default runlevel at 3
edit
/etc/inittab and change the entry "id:5:initdefault:" "id:3:initdefault:"

give the command init 3. It will switch to the runlevel 3 now.

Warm regards
Silju
Technology to empower all
Alpha977
Valued Contributor

Re: how to setup disabling GUI start

Hello!

Into the file /etc/inittab change the id:5:initdefault row in id:3:initdefault.

Then if you want to switch into the GUI, type startx or init5.

Bye!
George Liu_4
Trusted Contributor

Re: how to setup disabling GUI start

change default id to 3 instead of 5

Also, may suggest add norhgb in grub conf. It sometimes has issue too. But is not related to your question
Tor-Arne Nostdal
Trusted Contributor

Re: how to setup disabling GUI start

Hard to understand your question.

You don't want to load Gui start next time...
That's what you have got some answers on - changing runlevel to 3.
You do not need to reboot to perform the change, but this does not stop the current running Gui. You will not see this until next reboot...
Changing the runlevel like this will be permanent until you change it back again.

The startup/stop is handled by script files.

Where the scripts are located depends upon what kind of unix variant you're running.

SuSe Linux store the start/stop scripts in /etc/init.d
They can also be runned individually from command line.
example:
/etc/init.d/xdm stop
/etc/init.d/xdm start
See /etc/rc.d.README and /etc/init.d/README

Or run command: man INIT.D
This will explain what you need related to runlevels, how to configure aso.


Disable xdm startup on SuSe Linux (even runlevel 5)
****************************
Just remove the start/stop links:
lrwxrwxrwx 1 root root 6 2006-08-07 11:19 /etc/init.d/rc5.d/K12xdm -> ../xdm
lrwxrwxrwx 1 root root 6 2006-08-07 11:19 /etc/init.d/rc5.d/S10xdm -> ../xdm

rm /etc/init.d/rc5.d/S10xdm
rm /etc/init.d/rc5.d/K12xdm

Enable it again
****************
Simply create the links again:
cd /etc/init.d/rc.5
ln -s ../xdm K12xdm
ln -s ../xdm S10xdm

Some unix systems also uses a file where you can set an environment variable specifying if you want to run the service or not.

In SuSe there is a file named /etc/sysconfig/displaymanager which control what kind of display you want.
If this is a server it might be that you want to set DISPLAYMANAGER=console here.
This should prevent starting X.

/Tor-Arne
I'm trying to become President of the state I'm in...