IMC

How to Limit active SSH Sessions on custom Adapter?

 
SOLVED
Go to solution
merkCH
Occasional Visitor

How to Limit active SSH Sessions on custom Adapter?

Hi

I'm trying to build a custom adapter for a Moxa Switch, which support only 1 active SSH-connection.

  • Is there a way to limit the SSH Session to 1 in custom adapters?
  • Where can I find a reference table for all possibles variables in initialize.tcl?

 

 

 

5 REPLIES 5
akg7
HPE Pro

Re: How to Limit active SSH Sessions on custom Adapter?

Hello @merkCH ,

Are you looking for some help in IMC or or in Moxa Switch?

Thanks!

Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the companyAccept or Kudo
merkCH
Occasional Visitor

Re: How to Limit active SSH Sessions on custom Adapter?

Looking for help in IMC.

akg7
HPE Pro

Re: How to Limit active SSH Sessions on custom Adapter?

Hello @merkCH ,

I believe it is not feasible in IMC.

Thanks!

Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the companyAccept or Kudo
RPapaux
Valued Contributor
Solution

Re: How to Limit active SSH Sessions on custom Adapter?

Why do you need to limit number of SSH session in custom adaptor?

1 SSH session is enough, as long as you do only 1 access (job) at the time.

I'm ussing a custom adaptor for MOXA, and I had 2 issues at the beginning, so:

- ensure that the MOXA is configured for raw CLI mode (by default it uses a kind a character mode menu)

- ensure that the adaptor is closing the SSH session correctly at the end of the job. If you don't the next backup will fail and staled "plink" processes will be stacking up in IMC.

BR

Ray

 

 

 

merkCH
Occasional Visitor

Re: How to Limit active SSH Sessions on custom Adapter?

I have found the issue "error: extra characters after close-brace" int the log  "imccfgbakdm.*txt" with debug mode enabled.

Now i have to check/rewrite my TCL-scripts backup_running_config_tftp and backup_startup_config_tftp.tcl.

 

First I guessed the error will come from the 1 SSH connection limit.

 

Thanks