IMC

Problems with Software Library

 
JeromeB
Occasional Advisor

Problems with Software Library

Hello,

I have multiple problems with Software Library :

  • LiveUpdate works fine, but downloaded firmwares do not appear within the library list or within iMC\server\data\image.
  • Manually adding a *.swi file in iMC\server\data\image does not show it within Software Library.
  • Trying to import software from manually downloaded firmwares systematically returns "Reading File failed".

Patching IMC to E0705P12 did not solve the problem.

Any help would be much appreciated !

Kind Regards,

Jerome.

9 REPLIES 9
akg7
HPE Pro

Re: Problems with Software Library

Hello @JeromeB ,

 

Can you confirm if it was working earlier?

Is it showing anything under receiver:

'C:\Program Files\iMC\data'

Can you confirm the status of these processes:

'imcupgdm'

'imciccdm'

'imccmdmgrdm'

'tftpserver'

Also configmr are no space issue?

Thanks!

Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the companyAccept or Kudo
JeromeB
Occasional Advisor

Re: Problems with Software Library

Hello,

Thank you for your reply.

Yes, it was working prior to E0705P10, not sure if the problem exists since this specific patch though.

Attached you wil find screenshots of imcdata, processes (looking OK) and space (7Go+ remaining) :  Process & spaceProcess & space

Imcdata receivingImcdata receiving

akg7
HPE Pro

Re: Problems with Software Library

Hello @JeromeB ,

These outputs looks normal.

Is it possible to share debug level logs of ''imcupgdm'?

System-->System Configuration-->Log Collection

Look for 'imcupgdm' Process and change 'Log Level' from info to Debug.

Repeat the process of download firmware, manually add file.

Go to again at Log colletion and download the logs and share with me.

And also change the Debug levle back to info.

Thanks!

Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the companyAccept or Kudo
JeromeB
Occasional Advisor

Re: Problems with Software Library

Hello @akg7 , and thank you for helping !

Below you'll find the link to my debug logs of imcupgdm (could not join the zip file as valid extension).

https://rhenuslogistics.sharefile.com/d-s10bd3efb6b6f4000b55833737a009aea

Kind Regards,

Jérôme.

akg7
HPE Pro

Re: Problems with Software Library

Hello @JeromeB,

Logs looks fine and no issue reported.

I will advise you to log a case with support because it needs remote/LAB intervention.

https://support.hpe.com/hpesc/public/home/

Or for last try before reaching to LAB, Is it possible for you to share the detailed logs.

Steps to collect it:

For Windows: <IMC>/deploy/logfiles.bat -->Run this file and collect it from <imc>/tmp

For Linux: <IMC>/deploy/logfiles.sh -->Run this file and collect it from <imc>/tmp

This will take time to complete and file size quite  big.

Hopefully will get some info from there.

Thanks!

Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the companyAccept or Kudo
JeromeB
Occasional Advisor

Re: Problems with Software Library

Hello @akg7 ,

Here are the detailed logs : https://rhenuslogistics.sharefile.com/d-s997517d4dac945ebafe070d064291715

Thanks for your time and help, I'll open a case if you don't find anything special in there.

Kind Regards,

Jérôme

akg7
HPE Pro

Re: Problems with Software Library

Hello @JeromeB,

Thank You sharing logs, I will check it today and will share an update.

 

Thanks!

Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the companyAccept or Kudo
akg7
HPE Pro

Re: Problems with Software Library

Hello @JeromeB ,

Apologies for delayed response.

I have seen logs and there are not much information related to the issue.

Is there any possibility to reboot the server?

If this won't resolve issue then please log a case with support.

Thanks!

Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the companyAccept or Kudo
JeromeB
Occasional Advisor

Re: Problems with Software Library

Hi @akg7 ,

Thank you for your time and help.

Rebooting the server was the first thing I tried since I discovered this problem, didn't solve it unfortunately.

I'll open a case to support then.

Have a nice day !