LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

Moving from EIGRP to OSPF

 
SOLVED
Go to solution

Moving from EIGRP to OSPF

I currently have 3 sites, each with Cisco devices behind them. They are a 6509 at one site and 3750s at the others. Currently we are doing EIGRP to communicate our subnets around.

I am replacing the 6509 with and IRF of 5800s so need to move away from EIGRP. I have followed some online resources that mae it sound pretty easy to move from EIGRP to OSPF but I just cannot get it to work.  Currently I have

6509:

!

router eigrp 1234

network 64.35.25.168 0.0.0.3

network 65.206.167.0 0.0.0.15

network 65.206.167.16 0.0.0.7

network 65.206.167.24 0.0.0.7

network 65.206.167.32 0.0.0.15

network 65.206.167.48 0.0.0.15

network 65.206.167.64 0.0.0.31

network 65.206.167.96 0.0.0.31

network 129.33.38.75 0.0.0.0

network 172.16.1.0 0.0.0.255

network 172.16.2.0 0.0.0.255

network 172.16.3.0 0.0.0.255

network 172.16.4.0 0.0.0.255

network 172.16.5.0 0.0.0.255

network 172.16.6.0 0.0.0.255

network 172.16.30.0 0.0.0.255

network 172.16.31.0 0.0.0.255

network 172.16.40.0 0.0.0.255

network 172.16.41.0 0.0.0.255

network 172.16.42.0 0.0.0.255

network 172.16.101.0 0.0.0.255

network 172.16.178.0 0.0.0.255

network 172.16.203.0 0.0.0.255

network 172.16.210.0 0.0.0.255

network 172.16.254.0 0.0.0.7

redistribute connected

redistribute static

!

3750:

!

router eigrp 1234

network 65.44.21.176 0.0.0.3

network 172.16.11.0 0.0.0.255

network 172.16.110.0 0.0.0.255

redistribute static

eigrp stub connected summary

!

3750:

!

router eigrp 1234

network 65.44.63.116 0.0.0.3

network 172.16.12.0 0.0.0.255

network 172.16.120.0 0.0.0.255

network 172.16.122.0 0.0.0.255

network 172.16.123.0 0.0.0.255

network 172.16.125.0 0.0.0.255

network 172.16.130.0 0.0.0.255

redistribute static

eigrp stub connected summary

!

I replaced this with the following OSPF stuff on the 5800 and 3750s

5800:

Ospf 1 router ID 240.1.1.1

Area 0

 network 64.35.25.168 0.0.0.3

 network 65.206.167.0 0.0.0.15

 network 65.206.167.16 0.0.0.7

 network 65.206.167.24 0.0.0.7

 network 65.206.167.32 0.0.0.15

 network 65.206.167.48 0.0.0.15

 network 65.206.167.64 0.0.0.31

 network 65.206.167.96 0.0.0.31

 network 129.33.38.75 0.0.0.0

 network 172.16.1.0 0.0.0.255

 network 172.16.2.0 0.0.0.255

 network 172.16.3.0 0.0.0.255

 network 172.16.4.0 0.0.0.255

 network 172.16.5.0 0.0.0.255

 network 172.16.6.0 0.0.0.255

 network 172.16.30.0 0.0.0.255

 network 172.16.31.0 0.0.0.255

 network 172.16.40.0 0.0.0.255

 network 172.16.41.0 0.0.0.255

 network 172.16.42.0 0.0.0.255

 network 172.16.101.0 0.0.0.255

 network 172.16.178.0 0.0.0.255

 network 172.16.203.0 0.0.0.255

 network 172.16.210.0 0.0.0.255

 network 172.16.254.0 0.0.0.7

 

3750:

Router ospf 1

Router id 240.11.11.11

 network 65.44.21.176 0.0.0.3 area 0

 network 172.16.11.0 0.0.0.255 area 0

 network 172.16.110.0 0.0.0.255 area 0

 

3750:

Router ospf 1

Router ID 240.12.12.12

 network 65.44.63.116 0.0.0.3 area 0

 network 172.16.12.0 0.0.0.255 area 0

 network 172.16.120.0 0.0.0.255 area 0

 network 172.16.122.0 0.0.0.255 area 0

 network 172.16.123.0 0.0.0.255 area 0

 network 172.16.125.0 0.0.0.255 area 0

 network 172.16.130.0 0.0.0.255 area 0

 

So far, area 0 is not replicating around. Any ideas?

 

Thanks much!

Dave

11 REPLIES
Fredrik Lönnman
Honored Contributor

Re: Moving from EIGRP to OSPF

no redistribute static and connected on the 5800?

---
CCIE Service Provider
MASE Network Infrastructure [2011]
H3CSE
CCNP R&S

Re: Moving from EIGRP to OSPF

I put these now on the 5800

 import-route direct
 import-route static

 

Looks like the redistribute is a Cisco command. Checking out if I need to put those on the 5720s or not.

paulgear
Esteemed Contributor

Re: Moving from EIGRP to OSPF

import-route is the equivalent of redistribute on Cisco.

 

You might want to check out the HP Networking and Cisco CLI Reference Guide.  I've found it very helpful in switching between the two HP CLIs and Cisco.

Regards,
Paul
paulgear
Esteemed Contributor

Re: Moving from EIGRP to OSPF

P.S. You should also consider using MD5 authentication and possibly tuning your timers from the defaults. Here's a short config excerpt from one of my 5500s:

...
interface Vlan-interfaceXXXX
description OSPF interface
ip address X.X.X.X M.M.M.M
ospf timer hello 1
ospf timer dead 10
ospf authentication-mode md5 1 PASSWORD
ospf dr-priority 100
...
ospf 1000
silent-interface all
undo silent-interface Vlan-interfaceXXXX
undo rfc1583 compatible
area 0.0.0.0
abr-summary X.X.X.X M.M.M.M
authentication-mode md5
network X.X.X.X M.M.M.M
...
Regards,
Paul

Re: Moving from EIGRP to OSPF

Excellent suggestions. I will try these. Blasted OSPF will not work. The Cisco switches are not seeing each other or the HP 5800 so it is either something on the WAN or I do not have it configured correctly. I would like to say that there is no way it coul dbe my issue, but know that is not the truth! :)  Time to find a consultant to help.

 

I have been using that PDF that you sent hte link to. That has been such a great help in getting the 5800 set up.

 

Thanks much!

Spoiler
 

 

paulgear
Esteemed Contributor

Re: Moving from EIGRP to OSPF

If you post the OSPF config of the 3 devices, along with the output of "show ip ospf neigbor" (IOS), "display ospf peer" (Comware), "show ip ospf database" (IOS), and "display ospf lsdb" (on Comware), we might be able to point you in the right direction.

Regards,
Paul
Fredrik Lönnman
Honored Contributor

Re: Moving from EIGRP to OSPF

Also, a diagram of how the switches are interconnected. Looking at the configs on the 3750s I would have guessed that the 65.44.63.116/30 and 65.44.21.176/30 where link nets in to the 6500, and that the 172.16.x.x networks where internal behind each 3750. But there are not network statements for 65.44.63.116/30 or 65.44.21.176/30 in the 6500 so where are those connected? :)

 

Are those devices perhaps connected over some L3VPN? Then you cannot change the routing protocol without coordinating it with your provider.  And as paulgear said, those show and display command will help.

---
CCIE Service Provider
MASE Network Infrastructure [2011]
H3CSE
CCNP R&S

Re: Moving from EIGRP to OSPF

I will know more tomorrow. I finally heard back from our WAN provider yesterday and it looks like they may nee dto open something up. I guess they are providing only EIGRP across the WAN right now and not OSPF, which would be why I am not seeing anything. After I talk to them today and know if they need to do anything I will update the post. Thanks so much for both of you and the help you have provided so far.

Fredrik Lönnman
Honored Contributor
Solution

Re: Moving from EIGRP to OSPF

Alright, that really sounds like you have a L3VPN from your provider. That means that instead of peering directly between your own devices you peer with the provider who carries the routes through their network between your devices. So you'll have to coordinate with them, and make them also change to OSPF transport :)
---
CCIE Service Provider
MASE Network Infrastructure [2011]
H3CSE
CCNP R&S

paulgear
Esteemed Contributor

Re: Moving from EIGRP to OSPF

Glad to hear you're making some progress, David.

Frredrik, I can't think why providers or customers would ever want to peer with each other for IGPs like EIGRP and OSPF - do you understand why ISPs offer this as a service? I would always prefer L2VPN all the way through so i could peer with my own routers.
Regards,
Paul

Re: Moving from EIGRP to OSPF

My provider turned on OSPF last night and I am seeing OSPF propagated through the environment. Everything appears to be working.

 

Which is a good thing since I no longer see EIGRP in the routing tables so it looks like when they turned on OSPF they turned off EIGRP even though I specifically told them not to. This morning could have been very messy.

 

Thanks to you both for all the help and insights into this. It is much apprecaited.

 

Dave