LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

problem with routing inter-vlan

splouxe
Visitor

problem with routing inter-vlan

I am new to a company and I can not get to solve this problem

I have a problem of inter-vlan routing, I have a core switch 5300xl and two switches in each room floor.  


I created a vlan 11 and I give him an IP address and i enabled the ip routing in the core and in the switches in each room floor and I can not have the routing with another VLAN and, most all other vlan are not router, please how to do ???  


Below config core and a switch to floor,


Please, I'am blocked, plz i need help  
I can not have access to the other sub networks  with the ip 11.11.11.254/24

 

=============================================

CORE Switch : 

 

show running-config
Running configuration:
; J4819A Configuration Editor; Created on release #E.11.38
hostname "HP ProCurve Switch 5308xl"  
snmp-server contact "test"  
mirror-port D11  
module 6 type J4907A  
module 5 type J4907A  
module 4 type J4907A  
module 1 type J4878B  
module 2 type J4878B  
module 3 type J4878B  
ip routing  
snmp-server community "public" Unrestricted  
vlan 1  
name "DEFAULT_VLAN"  
untagged A1-A4,B1-B4,C1-C4,D15-D16,E1-E16,F3-F4,F6-F9,F11-F16  
ip address 172.16.X.1 255.255.0.0  
ip address 10.10.X.250 255.255.255.0  
no untagged D1-D14,F1-F2,F5,F10  
exit  
vlan 2  
name "WIFI"  
untagged F1-F2,F5,F10  
tagged A4,B4  
exit  
vlan 100  
name "DMZ"  
untagged D6-D7,D13-D14  
ip address 192.168.X.254 255.255.255.0  
exit  
vlan 200  
name "INTERNET"  
untagged D1-D5,D8-D12  
ip address 192.168.X.254 255.255.255.0  
monitor  
exit  
vlan 3  
name "MANAGEMENT"  
ip address 172.17.X.1 255.255.0.0  
exit
 
 
Vlan 11
name "test"
11.11.10.254 255.255.255.0
exit
 
banner motd "This is a private system maintained by the Allied Widget Corporatio
n.
Unauthorized use of this system can result in civil and criminal penalities !"
spanning-tree
spanning-tree priority 2
router rip
exit
vlan 1
ip rip
ip rip receive V1-only
ip rip send V1-only
exit
vlan 100
ip rip
ip rip receive V1-only
ip rip send V1-only
exit

 

 

 

===============

 

floor switch :

 

ProCurve 2910al-48G-1E-2#  
ProCurve 2910al-48G-1E-2#  
ProCurve 2910al-48G-1E-2#  
ProCurve 2910al-48G-1E-2# sh running-config
Running configuration:
; J9147A Configuration Editor; Created on release #W.14.70
hostname "ProCurve 2910al-48G-1E-2"  
module 1 type J9147A  
ip routing  
vlan 1  
name "DEFAULT_VLAN"  
untagged 1-48  
ip address 172.16.X.5 255.255.0.0  
exit  
gvrp  

snmp-server community "public" unrestricted
spanning-tree force-version rstp-operation
password manager
password operator
ProCurve 2910al-48G-1E-2
 
 
plz help me

1 REPLY
Vince-Whirlwind
Honored Contributor

Re: problem with routing inter-vlan

Get rid of "ip routing" off your floor switches.

 

Add in ip default gateway 172.16.X.1 onto the floor switches.

 

Make sure the interfaces your floor switches patch to on the "Core" are untagged in VLAN1.

 

Make sure your hosts patched to VLAN1 switchports also have a default gateway of 172.16.X.1.

 

-------

 

Add in a "Description" to each of your live switchports on your core, eg, "Link to Floor Switch 1E-2"

Add in a description on the upolink ports on your floor switches.