LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

vlan communication and routing

 
Highlighted
Occasional Contributor

vlan communication and routing

Router


!
!
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.196.113.1 255.255.255.0 secondary
ip address 10.196.112.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
router rip
version 2
network 192.168.112.0
network 192.168.113.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.1
!
ip http server
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 permit any
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end

 

 

Switch to Router
Running configuration:

; J9086A Configuration Editor; Created on release #R.11.22

hostname "ProCurve Switch 2610-24/12PWR"
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 20-24,26-28
no ip address
no untagged 1-19,25
exit
vlan 112
name "VLAN112"
untagged 1-15,25
ip address 10.196.112.40 255.255.255.0
tagged 26-28
exit
vlan 113
name "VLAN113"
untagged 16-19
ip address 10.196.113.40 255.255.255.0
tagged 26-28
exit
spanning-tree
spanning-tree config-name "she"
spanning-tree config-revision 1
ip ssh


The router is connected to switch port 25, and am able to get internet on the ip range 10.196.112.2-254

but any device connected to ip range 10.196.113.2-254 is unable to get internet.

The device in 10.196.112.2-254 range can ping 10.196.113.1 and 10.196.112.1 getway

1 REPLY 1
Highlighted
HPE Pro

Re: vlan communication and routing

Hi,

 

Where you are conencting the other devices?

Type of other device, its client or another switch?

How the IP alloacted to other device--static or dhcp?

 

Thanks!

I am an HPE Employee

Accept or Kudo