vgcreate problem with EVA

 
SOLVED
Go to solution
ITeam
Super Advisor

vgcreate problem with EVA

Hi,
Getting error: /dev/vg01/group not a character device
- when I try to vgcreate vg01 /dev/dsk/c14t0d0
, where c14t0d0 is a 300GB space allocated on an EVA box. I've done the pvcreate okay and dont have trouble with vgcreate on non-EVA "disks".

Suggestions/comments about my stupidity most welcome!

(PS: Yes, I have checked in ioscan that the path to the EVA exists on 255.255.0.0 !).

Many thanks.
4 REPLIES 4
Alex Lavrov.
Honored Contributor
Solution

Re: vgcreate problem with EVA

What's the output of:
diskinfo /dev/rdsk/c14t0d0 ?

And did you create /dev/vg01/group?
I don't give a damn for a man that can only spell a word one way. (M. Twain)
Thayanidhi
Honored Contributor

Re: vgcreate problem with EVA

Hi,
I doubt you didn't create group file.
use mknod.
If you are not familier with commands use SAM to create new VG/LV/FS.

Regds
TT

mkdir /dev/vgnew
mknod /dev/vgnew/group c 64 0x0y0000
(y system wide unique VGid)
pvcreate /dev/rdsk/cxtydz
vgcreate /dev/vgnew /dev/dsk/cxtydz
lvcreate ......
newfs....
mount ....

Refer to man pages
Attitude (not aptitude) determines altitude.
ITeam
Super Advisor

Re: vgcreate problem with EVA

Ho-hum! Yep - it was the lack of a mknod that was the start of it all!

Have now created one and am getting further (I just now need to play around with the extents sizing so it can use all the available size!).

Many thanks for the amazingly fast responses!
ITeam
Super Advisor

Re: vgcreate problem with EVA

just to save other people's valuable time, I'll close this thread off now.
Thanks again everyone!