Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Languages and Scripting
cancel
Showing results for 
Search instead for 
Did you mean: 

Support for Java 7 on HP-UX 11i PA-RISC based systems

pfhmks0
Occasional Visitor

Support for Java 7 on HP-UX 11i PA-RISC based systems

Does anyone know when (and if) HP is planning on releasing support for Java 7 platform.  Currently, it only has Java 7 support available on Itanium based systems.  It is a major issue for our software which runs on Java 1.7.  Without this support we cannot claim support for HP-UX on PA-RISC machines.

 

There is no information on this in the entire HP information world.  Thanks.

 

 

P.S. This thread has been moved from HP-UX > General to HP-UX > languages - HP Forums Moderator

6 REPLIES
Patrick Wallek
Honored Contributor

Re: Support for Java 7 on HP-UX 11i PA-RISC based systems

Everything I have read matches what you have read.  Java 7 is only available on Itanium for 11iv2/11.23 and 11iv3/11.31.  My guess is that it will NOT be back ported to PA-RISC.  I would imagine that the same will be true for Java 8 when it is released (supposedly later this year).

 

PA-RISC servers have been unavailable for sale for several years and I doubt that much development, other than that required for HP-UX itself, is being done for them.

 

 **Edited to correct a typo...

Dennis Handly
Acclaimed Contributor

Re: Support for Java 7 on HP-UX PA-RISC based systems

>PA-RISC servers have been available for sale

 

Did you mean unavailable?  (You can use Post Options > Edit Reply to correct.)

 

>It is a major issue for our software which runs on Java 1.7.  Without this support we cannot claim support for HP-UX on PA-RISC machines.

 

Do you really think you'll have sales for PA-RISC?

 

It's been more than a year since Java 7.0 was released.  The release notes for Java 7.0 only mentions Integrity servers:

http://bizsupport2.austin.hp.com/bc/docs/support/SupportManual/c03598223/c03598223.pdf

Patrick Wallek
Honored Contributor

Re: Support for Java 7 on HP-UX 11i PA-RISC based systems

Yes, I did.  Thanks Dennis!

SoumitraC
Frequent Advisor

Re: Support for Java 7 on HP-UX 11i PA-RISC based systems

We do not have any plans of supporting Java 7 for PA-RISC platforms.

 

Can you please elaborate on your requirements requiring Java 7 on PA-RISC?

 

 

Soumitra C
HP-UX Compilers
prakash_st
Occasional Visitor

Re: Support for Java 7 on HP-UX 11i PA-RISC based systems

can I have the steps to install Java 7 on HP-UX 11i PA-RISC based systems
Dennis Handly
Acclaimed Contributor

Re: Support for Java 7 on HP-UX PA-RISC based systems

>can I have the steps to install Java 7 on HP-UX PA-RISC based systems

 

Unless things have changed since SoumitraC's post in April, it doesn't exist.