cancel
Showing results for 
Search instead for 
Did you mean: 

backspace is not working

 
Highlighted
Frequent Advisor

backspace is not working

Hi
i have a very strange problem,i have a L2000 hp-ux system OS11i, informix and 4gl are installed on the system.
we have many 4gl program, these program were working properly, but yesterday inside all the program the backspace didn't work any more.
we restart the system the program works fine for 2hours then again the backspace stop working.
i found that these program use termcap files i replaced this file from another system but the problem persist.
the termcap is loaded in the kernel???
whow to restart the funcionality of the backspace without restarting the system?

plz this is very urgent.
i need an immediate help
regards
10 REPLIES 10
Highlighted
Exalted Contributor

Re: backspace is not working

Shalom,

maybe its stty settings.

stty -a

Lets see what we got.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Highlighted
Frequent Advisor

Re: backspace is not working

Hi steven
the backspace at unix level is working properly,i compered the output of stty -a on two system and i found no difference.
the problem with backspace is inside the 4gl program,after rebooting the system the program works fine for 2 hours . then the backspace stop working, (it should move to a previous page in the program)
how to reload the termcap to the kernel???
Highlighted
Valued Contributor

Re: backspace is not working

hi,

try this...

# stty erase

Highlighted
Trusted Contributor

Re: backspace is not working

Hassoun,
You can press the Ctrl key and the h key at the same time for backspace until you figure out your termcap issue. Good Luck.
RD
rdarling@southwickclothing.com
Highlighted
Acclaimed Contributor

Re: backspace is not working

Hi:

> the problem with backspace is inside the 4gl program, after rebooting the system the program works fine for 2 hours then the backspace stop working, (it should move to a previous page in the program) how to reload the termcap to the kernel???

The problem would appear to be in your program. Perhaps it is corrupting it's own variables. I suggest when the problm appears that you terminate and restart your program (not the whole server). The 'terminfo' ('termcap') files are not loaded into the kernel.

Regards!

...JRF...
Highlighted
Acclaimed Contributor

Re: backspace is not working

This is a very typical problem with curses based applications (ie those that use terminfo/termcap) and occurs when an application does not terminate properly and does not call the endwin() function to restore the terminal and port to their initial states. The terminal can be left in application mode and the port can be left with unexpected settings. You need to find out why your application is not exiting gracefully.
If it ain't broke, I can fix that.
Highlighted
Trusted Contributor

Re: backspace is not working

When your back space key stops working, have you looked to see what it is giving out as a backspace?

vi junkfile
i (for insert)
^v (control-v for treat next command literally)
(hit the backspace key)
Look at what thingy showed up.

Highlighted
Honored Contributor

Re: backspace is not working

check your 4gl program for any accessibility may be some configuration can make backspace idle.

Awadhesh
It's kind of fun to do the impossible
Highlighted
Honored Contributor

Re: backspace is not working

Check to see if your backspace key has been remapped to the delete key. Now comes the problem: have you tried using a different terminal emulator? Many emulators can be reconfigured with special characters streaming out of the application. For instance, WRQ's Reflection series defines backspace for HP emulation and delete for vt100 emulations, a carry over from the DEC days...

So to rule out the emulator, check the settings to see if the emulator changed. If all is well (backspace = backspace) then see if the pty device has been changed. stty can be called by any program so (badly written) code may be changing the setting. Use stty -a and connect it to the pty device with the problem.


Bill Hassell, sysadmin