MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

MSA2000 SQL Performance

 
jonqueue
Advisor

MSA2000 SQL Performance

we have an MSA2000 and during some admittedly very long write queries everything just stops.
the query returns some values about every 30 minutes and sometimes will just stop doing this. There are no errors on the server or on the MSA. if you watch task manager for the iSCSI NIC you can see traffic all of a sudden stop. it's pretty sporadic and sometimes will take 14 hours of this query running before having an issue.

Anyone having similar issues with the MSA?
Anyone having similar issues with SQL on an iSCSI SAN?
5 REPLIES 5
Uwe Zessin
Honored Contributor

Re: MSA2000 SQL Performance

Have you checked the Windows Event Log for any messages?
.
jonqueue
Advisor

Re: MSA2000 SQL Performance

yes. Windows event logs don't show anything either.
Sql logs also don't show anything which is very strange.
i just don't know where else to look.
Uwe Zessin
Honored Contributor

Re: MSA2000 SQL Performance

Outch.
Can you access the file system after the I/O has stopped?

I don't really have an idea, sorry. How about running an IOMETER task (should be set up to only do a little I/O) against the same disk at the same time to see if the MSA stalls or SQL server?
.
jonqueue
Advisor

Re: MSA2000 SQL Performance

we don't have any problems accessing the file system. In fact we have backups running on that SAN almost all day for a nearline backup. Only SQL gives us headaches.
IOMeter might be an option but as far as i can tell it won't really give me data at specific times. it just gives me averages. I could be wrong.
if the query runs ok for 10 hours the averages don't help too much.
Perfmon didn't show anything strange though.
jonqueue
Advisor

Re: MSA2000 SQL Performance

I believe we found the issue.
We were running iSCSI over our Broadcom NetExtreme II GigE adapter that was built into the Dell Poweredge 2950.
We bought a new Intel card and ran iSCSI through that instead and have had no issues in 2 days.
i saw on another forum that someone else was having san issues with this adapter as well.

hope this helps someone else in the future.