MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

MSA2050 threshold warning - the overcommit is not enabled

 
SOLVED
Go to solution
Highlighted
Frequent Visitor

MSA2050 threshold warning - the overcommit is not enabled

Hi HP people and users!

I have a problem with HP MSA2050, giving kernel errors on server about "thin provisioning soft threshold reached". But the "overcommit" is disabled.

The space reported as used by server is under 30%. I raised the Low Threshold limit from 50% to 70% but I got the error again.

The Disk Group has 3TB, No Affinity on Volumes, No performance enhancements.

Thank you.

7 REPLIES 7
Highlighted
Frequent Visitor

Re: MSA2050 threshold warning - the overcommit is not enabled

My setup is simple, no Overcommit, no Replica, just a simple setup. The DiskGroup of 3.00TB; the Allocated space (per Storage) is <2TB; the Used space (per Server) is <1TB.

I raised the Threshold from 50% to %60 but today I got those warnings again. I insist that the space used is almost 1TB, while the space "Allocated" is almost 2GB and the Physical space is 3TB.

 

I add the most similar post that I could find - but no response on it..

https://community.hpe.com/t5/MSA-Storage/MSA2040-error-code-473/m-p/6839906

Thank you for ideas!

Highlighted

Re: MSA2050 threshold warning - the overcommit is not enabled

You can't disable overcommit for a thin VV volume. If you disable then the VV no longer a Thin VV.

You need to check Pool size and set the threshold limit according to that.

Please let us know what is the Pool Size, Volume Size, Virtual Disk Group Size.

How many Volume present in that Pool ?

How many VDG present on that Pool?

I assume 3TB is your Pool size and overcommit is disabled and you have set Low threshold value 60%.

Now if you create only one volume of size let's say 1.8TB which is 60% of Pool size and this much space will be fully allocated because overcommit is disabled and that's why you will get alert. Here doesn't matter how much actual data in this volume because space already got allocated from MSA side.

If you have overcommit enabled then situation will be different because that time it will logical space rather than physical space.

 

 

Hope this helps!
Regards
Subhajit

I am an HPE employee

If you feel this was helpful please click the KUDOS! thumb below!

***********************************************************************


I work for HPE
Accept or Kudo
Highlighted
Frequent Visitor

Re: MSA2050 threshold warning - the overcommit is not enabled

Thank you for answer!

 

There is no overcommit enabled. I can enable it in Pool's setting but I dont want.

Hovering the mouse on GUI over the Pool, I see:

"Name: A"

"Serial: ..."

"Size: 3000MB

"Available: 950MB"

"Overcommit: Disabled"

"Pool overcommited: False"

Low Threshold

Mid Threshold

High Threshold

Allocated pages: 473400

Snapshot: 0

Available pages: 200 (a very bit rounded numbers for easy typing)

I only wish to use the existing space, that's all. The Pool's size is 3 TB, has only one Group of physical drives.

The OS uses/reports less than 1TB, the Storage says there are Allocated almost 2TB from the size of 3TB.

 

I am not sure what you mean by VV..

 

Thank you.

Highlighted
Frequent Visitor

Re: MSA2050 threshold warning - the overcommit is not enabled

Referring this "Now if you create only one volume of size let's say 1.8TB which is 60% of Pool size and this much space will be fully allocated because overcommit is disabled and that's why you will get alert. Here doesn't matter how much actual data in this volume because space already got allocated from MSA side."

I have a big Volume of 2.5TB Total size (Allocated 2TB by Storage but used 1TB by real data) and two smaller volumes (in total of 0.5TB) which have no data on them at this moment

The "thin provisioning soft threshold reached" is annoying to see in logs,  should not be there.

I wanted the classical/physical way this is why the Overcommit is disabled and it was all the time.

 

Thank you.

Highlighted

Re: MSA2050 threshold warning - the overcommit is not enabled

MSA 2050 is fully Virtually Array so initially whatever volume that you have created for example Volume A with 2.5TB size is actually provisioned size. Now physical space gets allocated as per the data write happens but limitation is if Pool level overcommit option is disabled then no write can exceed actual physical capacity of the Pool.

Overcommit is a setting that controls whether a virtual pool is allowed to have volumes whose total size exceeds the
physical capacity of the pool.

As you have mentioned Volume Size 2.5TB and I see Allocated pages mentioned 473400 which means (473400 x 4MB Pages) or 1849GB got allocated of 3TB Pool size which is almost 62% of the Pool Size

You are receiving alert because of this.

 

Hope this helps!
Regards
Subhajit

I am an HPE employee

If you feel this was helpful please click the KUDOS! thumb below!

**********************************************************************

 


I work for HPE
Accept or Kudo
Highlighted
Frequent Visitor

Re: MSA2050 threshold warning - the overcommit is not enabled

Thank you for response.

Your math is right, you understood well.

Rechecking, I found no explicit way on the Reference Guide or Best Practices for 2050 to create an Linear Volume or a Linear Disk Group. so I guess MSA2050 is all virtual as you say.

One more question:  Could these warnings be disabled somehow (maybe on CLI) ? I guess not, but just to make sure.

Thank you.

Highlighted
Solution

Re: MSA2050 threshold warning - the overcommit is not enabled

Yes MSA2050 and MSA2052 pure Virtual Array. There is no linear concept any more from Gen 5 MSA array.

I would never suggest you to disable threshold alert (not sure if possible or not as don't see any such command to do this). You can modify the limit % but can't disable I guess.

You can check MSA 2050 Quickspec to get details about the product,

https://h20195.www2.hpe.com/v2/GetDocument.aspx?docname=a00008276enw

 

 

Hope this helps!
Regards
Subhajit

I am an HPE employee

If you feel this was helpful please click the KUDOS! thumb below!

**********************************************************************


I work for HPE
Accept or Kudo