MSA Storage

Problem with SSH/TELNET/HTTP/CLI connection to MSA 2040

 
SOLVED
Go to solution
Ahmed_Aljiledi
Occasional Advisor

Problem with SSH/TELNET/HTTP/CLI connection to MSA 2040

Hi,

I can't connect to the Management Services include all of them SSH, TELNET, HTTPS, and CLI.

but the Disk Volumes still accessible by server and all VMs works fine without any issue.

when try to connect over HTTPS, the answer is "the Page Not Found"

when try to connect over SSH or Telnet, the connection was established and ask for user and password, when enter a correct credential the connection will be termnated "cut off connection and close the terminal", but when try to enter a wrong credential it shows wrong user or password.

when try to connect over Mini USB for console connection, the connection was established and ask for user and password, when enter a correct credential it shown the following error

home/appuser/appshell: line 34: mccli: not found

------------------------------------------------------------

Trying the following without any result:

1: unplugging power cable from storage for hours, and insure stop LED blinking on controllers.

------------------------------------------------------------

LED Color on Controllers.

the cache LED is Green on both controllers


Thank You

5 REPLIES 5
Shawn_K
HPE Pro

Re: Problem with SSH/TELNET/HTTP/CLI connection to MSA 2040

Hello Ahmed,

Are you getting the same responses from both the A and B controllers? 

Also, when trying to connect via mini USB be sure to have the COM port correctly configured. The default COM port settings are usually set at a BAUD rate 8200. For the MSA use the following:

Baud rate 115200

Data bits 8

Parity None

Stop bits 1

Flow control None

Be sure you are connecting to the serial mini USB port and not a service port.

Cheers,
Shawn

I work for Hewlett Packard Enterprise. The comments in this post are my own and do not represent an official reply from HPE. No warranty or guarantees of any kind are expressed in my reply.


I work for HPE

Accept or Kudo

Ahmed_Aljiledi
Occasional Advisor

Re: Problem with SSH/TELNET/HTTP/CLI connection to MSA 2040

Thank you for replay Shawn_K

 

yes from both Controller A and B.

yes, I configure the COM with these right setting.

Ahmed_Aljiledi
Occasional Advisor

Re: Problem with SSH/TELNET/HTTP/CLI connection to MSA 2040

Actually this problem occurred after one of the Volumes has full space usage.

Ahmed_Aljiledi
Occasional Advisor

Re: Problem with SSH/TELNET/HTTP/CLI connection to MSA 2040

Hi Shawn_K,

any advice ?

Ahmed_Aljiledi
Occasional Advisor
Solution

Re: Problem with SSH/TELNET/HTTP/CLI connection to MSA 2040

I was resolved the problem after trying all options available.

the firmware was corrupted on both Controller, and the only Service available to update the firmware via FTP TCP 21, all other service is corrupted.

The FTP Client used is Windows CMD, google it if you want, (Upgrade Firmware MSA 2040 FTP)

Regards