Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

LAN failset devices are not working

Debasis Bhar
Occasional Advisor

LAN failset devices are not working

LAN failset devices are not working after installing VMS732_LAN-V0500 patch kit. Does anyone know the workaround for it. We have two nic cards and i need to create one logical device to point these two nics in failover mode.
6 REPLIES
EdgarZamora_1
Respected Contributor

Re: LAN failset devices are not working

Use LANCP CONVERT DEVICE_DATABASE after installing the patch.

Debasis Bhar
Occasional Advisor

Re: LAN failset devices are not working

I have installed the patch in many systems. For some systems below workaround is working. For other it is not working. I have logged a call to HP and probably they will release a new patch for it.

====
$ rename SYS$SYSTEM:LAN$DEVICE_DATABASE.DAT *.DAT_OLD
LANCP> list dev
%LANCP-I-FNFDEV, File not found, LAN$DEVICE_DATABASE
-LANCP-I-CREATDEV, Created LAN$DEVICE_DATABASE file

LANCP> define device LLA0/fail=(EIA0,EID0)/enable
LANCP> set device LLA0/fail=(EIA0,EID0)/enable
%LANCP-E-LLANACT, LAN device active, cannot be added to or removed from Logical
LAN LLA0
LANCP> clear device LLa0
LANCP> purge device LLA0
LANCP> define device LLA0/fail=(EIA0,EID0)/enable
LANCP> set device LLA0/fail=(EIA0,EID0)/enable
===========
EdgarZamora_1
Respected Contributor

Re: LAN failset devices are not working

I think if you just did a CONVERT like I suggested previously you wouldn't have to go through all that.
Volker Halle
Honored Contributor

Re: LAN failset devices are not working

Edgar,

I had reason to install VMS732_LAN-V0500 at a customer site yesterday. Although I was aware of this issue and although I did a MC LANCP CONVERT DEVICE immediately after installation of the patch, both LAN failover sets did not form with any member devices after the reboot. LANCP LIS DEV/CHAR showed the correct state (LL devices members and enabled during startup). The LL devices at this site had been created a couple of years agao with an older V7.3-2 LAN patch level.

Purging and re-defining the LL devices did help.

Volker.
EdgarZamora_1
Respected Contributor

Re: LAN failset devices are not working

Thanks Volker. I've done this on six systems and the converts worked on all six, but I guess these systems are more recent systems.
Volker Halle
Honored Contributor

Re: LAN failset devices are not working

OpenVMS LAN engineering is still diagnosing and working on a fix. There may have been former LAN patch kit, which causes the LANCP CONVERT DEVICE not to work.

Volker.