Operating System - OpenVMS

Need Help. Unable to use COPY command or DIR to another node. OpenVMS over DECNET/TCPIP.

 
J_LZ
Occasional Contributor

Need Help. Unable to use COPY command or DIR to another node. OpenVMS over DECNET/TCPIP.

Hi Folks,

Greetings! I am still learning about Open VMS and currently, I have a project where I need to make our old server (A) up and running to sync with another server (B) with the same specs.  Already configured the server and I can ping from A to B and vise versa via UCX. I am able to transfer files via FTP but unfortunately, whenever I try to use "COPY" or "RENAME" to duplicate or move files directly from Server A to B, I am getting an error.

Here's the message that I am receiving: 

From A to B

"%DIRECT-E-OPENIN, error opening 10.116.51.11::SERVERB$DKA1:[000000]*.*;* as input
-RMS-F-DEV, error in device name or inappropriate device type for operation"

*** I have the same error whenever I try to use DIR (DIRECTORY) command to list files.

From B to A

%DIRECT-E-OPENIN, error opening SERVERA::SERVERA$DKA2:[000000]*.*;* as input
-RMS-E-FND, ACP file or directory lookup failed
-SYSTEM-F-UNREACHABLE, remote node is not currently reachable

This is how my "AUTHORIZE" PROXY Config looks like (Not actual values)

10.116.10.10::USERNAME
* (D)

SERVERA::USERNAME
USERNAME (D)

10.116.10.11::USERNAME
* (D)

SERVERB::USERNAME
USERNAME (D)

This is how my "TCPIP/UCX" PROXY Config looks like (Not actual values)

VMS User_name      Type           User_ID            Group_ID         Host_name
USERNAME             CD              USERNAME                             SERVERA, SERVERB, 10.116.51.10, 10.116.51.11

Server A TCPIP Version : 
HP TCP/IP Services for OpenVMS Industry Standard 64 Version V5.7 - ECO 2
on an HP Integrity rx2800 i2 (1.60GHz/5.0MB) running OpenVMS V8.4

Server B TCPIP Version: 
HP TCP/IP Services for OpenVMS Industry Standard 64 Version V5.7 - ECO 4
on an HP Integrity rx2800 i2 (1.60GHz/5.0MB) running OpenVMS V8.4

Is there anything I need to look for aside from those? Kindly let me know if you need further info or if I've been providing unnecessary information.

Please correct me if I am using the wrong terminologies about servers and networking. Still learning about it

Thank you in advance!

 

5 REPLIES 5
Steven Schweda
Honored Contributor

Re: Need Help. Unable to use COPY command or DIR to another node. OpenVMS over DECNET/TCPIP.

> [...] over DECNET/TCPIP.

   I do almost nothing with this stuff, and infrequently, too, so I know
nothing, but...

> [...] I can ping from A to B and vise versa [...]

   Ok.

> *** I have the same error whenever I try to use DIR (DIRECTORY)
> command to list files.

   I'd stick with DIR for a while.  No need to fight
permission/protection problems at both ends.

   Have you compared SHOW NETWORK /FULL DECNET between the two nodes?
Is there a DNA_IP under Identifiers on both?

   How about "From A to A" and "From B to B"?  (You might need to add
more (harmless) proxies.)  Start simple, I always say.

> -RMS-E-FND, ACP file or directory lookup failed
> -SYSTEM-F-UNREACHABLE, remote node is not currently reachable

   I can get that by targeting a Mac instead of a VMS system:

ITS $ dir 10.0.0.140::d0:[smsm]login ! The same VMS system.

Directory 10.0.0.140::ITS$DKA0:[SMSm]

login.com;1

Total of 1 file.

ITS $ dir 10.0.0.29::d0:[smsm]login ! A Mac.
%DIRECT-E-OPENIN, error opening 10.0.0.29::D0:[SMSM]LOGIN.*;* as input
-RMS-E-FND, ACP file or directory lookup failed
-SYSTEM-F-UNREACHABLE, remote node is not currently reachable

   That Mac knows nothing about DECnet (hence "not currently
reachable"), so that message could mean that your SERVERA knows not much
about DECnet over IP.  (But what do I know?)

Volker Halle
Honored Contributor

Re: Need Help. Unable to use COPY command or DIR to another node. OpenVMS over DECNET/TCPIP.

J_LZ,

did you correctly configure DECnet-over-IP on both nodes ?

- @TCPIP$CONFIG PWIPDRIVER
- @NET$CONFIGURE ADVANCED  OSI Transport, Naming: domain,local
- create DECnet-over-IP Proxies 
- Define DECnet-Node-Names as local IP-Alias
- remove DECnet-Node-Names from DECnet Registry -> forces BIND Lookup !

Test with the local node(s) first on both nodes, then try node-to-node.

Note that you can't use RENAME between nodes, not even between different disk volumes.

Volker. 

J_LZ
Occasional Contributor

Re: Need Help. Unable to use COPY command or DIR to another node. OpenVMS over DECNET/TCPIP.

@Steven Schweda  @Volker Halle  Thank you guys so much for the help! I've spent almost a month doing research to get this up and running and it only took you 1 post to have it resolved. Maybe I was using the wrong keywords when I was searching for answers but hey, I really learned a lot! This is awesome!

What I did:

1. $ SHOW NETWORK/FULL DECNET

- Found out that DECNET isn't really set up properly or isn't really configured at all.  

Product: DECNET Manufacturer: Hewlett-Packard Company
Node: SERVERAAddress(es): 1.1
Network Type: DNA V Interface(s): net 0

Node 0
at 2021-06-17-14:14:48.806+08:00Iinf

Identifiers

Name =
Address = <Default value>

Status

UID = 2F5EC000-53A6-11E2-8001-AB0014000104
State = Off
Functions Enabled =
{
}
ID = 00-24-7C-45-26-A2

Characteristics

Version = T5.0.3
Implementation =
{
[
Name = OpenVMS I64 ,
Version = "V8.4 "
] ,
[
Name = HP DECnet-Plus for OpenVMS ,
Version = "V8.4 ECO01 22-JUN-2010 22:35:55.29"
]
}
Script Location = <Default value>
Maximum Listeners = 0
Listener Template = <Default value>
Secondary Names =
{
}

Counters

Creation Time = 1858-11-17-08:00:00.000+08:00Iinf
Renames = 0
Changes of ID = 2
IDROM Check Failures = 0
Changes of Address = 0

%NCL-E-CMLSENDFAILED, error sending command request
-CML-E-EMAAPROB, error returned from VMS EMA agent
-NCL-E-ENTCLSNOTSUPP, entity class not supported
%NCL-E-CMLSENDFAILED, error sending command request
-CML-E-EMAAPROB, error returned from VMS EMA agent
-NCL-E-ENTCLSNOTSUPP, entity class not supported

$

 

2. After DECNET was configured using the command "@sys$manager:net$configure", it seems like there was a bit of improvement. DECNET information is now populated.

The error message I was receiving also changed to the below prompt. 

"%DIRECT-E-OPENIN, error opening  10.116.51.11::SERVERB$DKA1:[000000]*.*;* as input
-RMS-E-FND, ACP file or directory lookup failed
-SYSTEM-F-UNREACHABLE, remote node is not currently reachable"

3.  One thing I've noticed is that, DNA_IP isn't also configured. By using "$ mcr ncl show add" command, found out that DNA_IP is set to 0.0.0.0. Did some more research and it pointed me to PWIP drivers.

4. Used "@SYS$MANAGER:UCX$CONFIG" to configure PWIP, and voila! DNA_IP got populated with the correct IP address and I am now also able to DIR and COPY to local and the remote server.

 

It may be a simple fix to those who are really familiar with the VMS systems, but for beginners, we really appreciate the help and we learned a lot! Hope this also helps other "starting up" folks in case they encounter the same situation.

 Now, I will have to do more research about my problem when transferring from SERVERB to SERVERA.

Again, thanks a lot! 

 

Steven Schweda
Honored Contributor

Re: Need Help. Unable to use COPY command or DIR to another node. OpenVMS over DECNET/TCPIP.

> It may be a simple fix to those who are really familiar with the VMS
> systems, [...]

   VMS is sufficiently old-fashioned to have loads of mostly good
documentation, but the quantity can be near overwhelming, and
DECnet-Plus ("Phase V") has enough flexibility to overload my brain.

> Now, I will have to do more research about my problem when
> transferring from SERVERB to SERVERA.

   What does work now, and what still fails?

J_LZ
Occasional Contributor

Re: Need Help. Unable to use COPY command or DIR to another node. OpenVMS over DECNET/TCPIP.

> What does work now, and what still fails?

Tried to shutdown/restart TCPIP and everything seems to be working now. I am able to transfer from A to B and vise versa. 

Thank you so much for the help