Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
Operating System - VMware
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot set auto-negotiate on nic

Hettegger Matthias
Occasional Contributor

Cannot set auto-negotiate on nic

We tried to set the network interface cards (NICS) in our esxi hosts  to auto-negotiate the duplex and speed settings without success.

vCenter displayed the following error:
Call "HostNetworkSystem.UpdatePhysicalNicLinkSpeed" for object "networkSystem-9" on vCenter Server "SWZLMGT1.efswlager.ch" failed.
Operation failed, diagnostics report: Operation not supported: Operation not supported

We then tried to change the nics to auto-negotiate by using the ssh support console but again, an error occured:
~ # esxcfg-nics -a vmnic1
Error: Operation not supported: Operation not supported

We are using the following hardware/software configuration for the esxi hosts:

  • - HP ProLiant BL460c G7 with a
  • - HP NC553i Dual Port FlexFabric 10Gb network adapter
  • - HP ethernet passthru module (1gbe)
  • - VMware esxi 4.1 U1 (348481)


The firmware and driver version in use are listed below:


~ # ethtool -i vmnic1
driver: be2net
version: 2.102.518.0
firmware-version: 3.102.453.0
bus-info: 0000:02:00.1

 

Does anyone have a suggestions on how to solve this problem?

1 REPLY
Mjonesy
Occasional Visitor

Re: Cannot set auto-negotiate on nic

I think this might be a limitation on the 10Gb cards.  We are using NC523SFP's and they are the same.  We just set the switches to no negotiate, full duplex, 10gb.