ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Installing Insight Management Agents on DL380 G4 with 2008 R2

Lane McMullen
Occasional Visitor

Installing Insight Management Agents on DL380 G4 with 2008 R2

I have a HP DL380 G4 with Windows Server 2008 R2 on it. I have been able to install the OS and configure my array without any problem. I used the HP firmware update DVD (9.3) to update the firmware on all installed devices appropriately, however I noticed that the HP Insight Management Agents were not installed. If I try to install them from the latest PSP (8.7) I receive the following error:

 

Installation for "HP Insight Management Agents for Windows Server 2003/2008 x64 Editions" requires one or more of the following that is not currently installed or in the install set:

- HP ProLiant Advanced System Management Controller Driver for Windows
- HP ProLiant iLO Advanced and Enhanced System Management Controller Driver for Windows
- HP ProLiant iLO 2 Management Controller Driver for Windows
- HP ProLiant iLO 3 Management Controller Driver for Windows
- HP ProLiant iLO 3 Management Controller Driver for Windows
- HP ProLiant 100-Series Management Controller Driver for Windows

 

I tried installing the latest driver for Ilo, but it says that it is already installed. Am I missing something? Can I chalk this up to assume that this software just isn’t supported with the 380 G4 and 2008 R2? I realize the the Proliant support matrix doesn't list the 380 G4 for 2008 R2, but I have read posts from others that seems to be working with 2008 without any problem. Anyone else have this issue?

14 REPLIES
Ralph Frampton
Frequent Advisor

Re: Installing Insight Management Agents on DL380 G4 with 2008 R2

If you know that the associated drivers etc. are already installed then look for the check box re "Automatically install minimum dependencies" (something like that off the top of my head) & un-check it, I think you'll find that you can get that HP software installed now.

 

RF

 

Lane McMullen
Occasional Visitor

Re: Installing Insight Management Agents on DL380 G4 with 2008 R2

Ralph, thanks for the tip. Where exactly would I see this option? Would I see this when installing the PSP somehwere after it takes inventory of items to be installed? Let me know if I am missing something.

Ralph Frampton
Frequent Advisor

Re: Installing Insight Management Agents on DL380 G4 with 2008 R2

Example for VCA Home - Software Status - Installed Software:

Last Generated:  8/17/11 17:20:27
Version Control Agent 6.3.0.870

 

The "Automatically Install Minimum Dependencies"  check box is immediately to the left of the Install button.

 

Now that I think of it, you may not see this option if your version of VCA is some what older (don't recall exactly when it was introduced).

 

RF

 

Lane McMullen
Occasional Visitor

Re: Installing Insight Management Agents on DL380 G4 with 2008 R2

When I try to install the Insight Management Agents, it notes that it cannot continue because a Advanced and Enhanced System Management Controller is not installed. When I try to install the HP ProLiant iLO Advanced and Enhanced System Management Controller Driver for Windows Server 2008 x64 Editions, it fails noting that the OS is not supported. There doesn't seem to be much support for this generation of 380 and R2.

Ralph Frampton
Frequent Advisor

Re: Installing Insight Management Agents on DL380 G4 with 2008 R2

Sorry, we've been using VCA/VCRM so long now that I no longer remember how it's done from within a PSP.

 

Version Control Agent method will require a Version Control Repository Mgmt installed somewhere (eg. we have ours on our HPSIM server). 

 

If you don't have a VCRM for the VCA's to connect/use then I suppose you could try running the Insight Mgmt Agents executable (eg. cpXXXXXX.exe) directly on the server instead of from within the PSP installer (ie. navigate to the appropriate folder or download it from HP site).

 

RF

 

Ralph Frampton
Frequent Advisor

Re: Installing Insight Management Agents on DL380 G4 with 2008 R2

Your last reply could be the barrier... my experience with 2008 R2 is only on a DL 180 G6 so far... and all of our older G5/G4/G3's etc. are using Windows 2003.

 

Sorry, better luck next time.

 

RF

 

Shane Schirmer
Occasional Visitor

Re: Installing Insight Management Agents on DL380 G4 with 2008 R2

I ran across this same problem on my DL360 G4's.  Here's how I fixed it:

  1. Download the HP ProLiant ILO Advanced controller driver for Windows Server 2008 x64 editions
  2. Right-Click and select properties for the downloaded file
  3. Click the compatibility tab
  4. Under Compatibility Mode, check the box and select Windows Server 2008 (Service Pack 1)
  5. Install the driver
  6. You should now be able to install the management agents.
FRD
Occasional Visitor

Re: Installing Insight Management Agents on DL380 G4 with 2008 R2

Thanks for this advice. It works very fine. So we can still use our older servers.

Franck (from Paris)

Frank_O
Occasional Contributor

Re: Installing Insight Management Agents on DL380 G4 with 2008 R2

Hello all,

 

today I had the same problem and I tried all CPxxxxxx that I could find.

But I would never had the idea with the compatibility settings! Now it is working.

Thank you, Shane! You saved my day.

 

regards

Frank

Fisher1
Occasional Visitor

Re: Installing Insight Management Agents on DL380 G4 with 2008 R2

Excellent work

JayS75
Occasional Visitor

Re: Installing Insight Management Agents on DL380 G4 with 2008 R2

Awesome !!! Thank you Shane for sharing this solution.

Malohe12
Occasional Collector

Re: Installing Insight Management Agents on DL380 G4 with 2008 R2

Excelente aporte... resuelto
foleyit
Occasional Visitor

Re: Installing Insight Management Agents on DL380 G4 with 2008 R2

Shane,

 

Thank you very much for sharing this solution!

acarbonari
Visitor

Re: Installing Insight Management Agents on DL380 G4 with 2008 R2

Muy buen trabajo, gracias por compartir!