Server Management - Remote Server Management

ILO access using ssh

 
Anupam_1
New Member

ILO access using ssh

I am trying to access the ILO from a Linux machine. I am getting the following error.

192.1.10.253 is the IP address for ILO

ssh anurag@192.1.10.253
anupam@192.1.10.253's password:
dispatch_protocal_error: type 100 seq 7
buffer_get: trying to get more bytes 4 than in buffer 0

It accept the password and produce this error. How to solve this?
13 REPLIES 13
acartes
Honored Contributor

Re: ILO access using ssh

What version of ssh are you using?

How about the output of "ssh -V" to get the version number and maybe "ssh -v 192.1.10.253" to get some verbose output.
Rod Jackson
New Member

Re: ILO access using ssh

I'm having the same problem.
The ssh version is:
OpenSSH_3.9p1, OpenSSL 0.9.7e 25 Oct 2004

I'm running SuSE linux 9.3, kernel 2.6.11 .
Goetz Rieger
New Member

Re: ILO access using ssh

Hi,

the easiest way is to "unset LANG". At least
that helped me.

Setting LANG to some other value then the SUSE
9.3 standard UTF (de_DE.UTF-8 for german) should help also, but I haven´t tried it.

Goetz
Rod Jackson
New Member

Re: ILO access using ssh

Unsetting LANG didn't help. I suspect a version mismatch, but don't know how to debug this other than to use ssh -vvv . This outputs a number of "Ignored env BLAH" messages for every environment variable, all of which are normal and occur for logins to other machines. However, those logins succeed.

Any more ideas or discoveries, anyone?
David Pullman_1
New Member

Re: ILO access using ssh

We just received a couple of new DL585s. Had the same error message from ssh using OpenSSH_3.6.1p2. Tried firmware update to 1.80, no change. Called HP, was told that "we really recommend that you use the web browser".

I reviewed the -v output and it occurred to me to try and comment out the config settings I have for agent and X11. Seems like not having agent forwarding lets me get in. Either commenting out the config value or use -a on the command line and I'm in.

Best wishes

--David
Rod Jackson
New Member

Re: ILO access using ssh

Using -a and/or -x doesn't work either. Perhaps it's because I'm using OpenSSH_3.9p1 , later version.
If HP doesn't want to support ssh, why did they put it in?
Chris Cockerham
New Member

Re: ILO access using ssh

Just got around this today...

I had to unset LANG and unset LC_CTYPE on the SUSE 9.3 side before the iLO card would let me in using SSH...
Tim McMurphy
Occasional Contributor

Re: ILO access using ssh

I put in a call to HP (3211800883) asking what terminal emulation I should use when I ssh in and use remcons. I am getting lots of bad screen redraws and I can't vi files.

They said that "the functionality you want isn't available" and "use the browser". If you are on a network where port 80 is not available and port 22 is the only one HP's ILO is kind of useless.

Why do they say in the manual that you can admin text based operating systems via ssh on the ILO port when you clearly can not?

Has anyone got ILO via ssh to work reliably? If so what terminal emulation do you use? I have tried all the common ones.
acartes
Honored Contributor

Re: ILO access using ssh

>> what terminal emulation I should use when I ssh in and use remcons.

iLO builds-in a VT320 serial client when accessing the virtual serial port via the browser interface.

>> I am getting lots of bad screen redraws and I can't vi files.

Check your vi termtype and configure your client to use the same.

>> They said that "the functionality you want isn't available" and "use the browser".

"They" say things like that sometimes :(

>> If you are on a network where port 80 is not available and port 22 is the only one HP's ILO is kind of useless.

I suggest using SSH to access iLO and then to access the virtual serial port (VSP) instead of remcons. I assume you are using a flavor of Linux or Unix. There is a HOWTO whitepaper that has details here:
http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?contentType=SupportManual&locale=en_US&docIndexId=179166&taskId=101&prodTypeId=15351&prodSeriesId=397989

Look for the one titled, "Integrated Lights-Out Virtual Serial Port configuration and operation HOWTO"

Not only will this address your issues with remcons, it is much more true to Unix.

>> Why do they say in the manual that you can admin text based operating systems via ssh on the ILO port when you clearly can not?

Try the VSP and report back. I think you'll be satisfied.

>> Has anyone got ILO via ssh to work reliably?

Yes. We usually use PuTTY and VT100 or VT320. It is the console ANSI cursor movements that can get in the way.