Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Invalid Support Packs in Version Control Repository

SOLVED
Go to solution
Dan Stebbins
Advisor

Invalid Support Packs in Version Control Repository

Each Windows 2003 support pack on 3 instances of the repository are marked as invalid. Each one reports that the missing component is for the Version Control Agent. The file is not missing nor is it corrupt. I have upgraded the VCRM and VCA manually, replaced the "missing" file, uploaded entire support packs again and every other possible fix I could find or think up. Still no luck. I think the problem is not with a missing component file, but the associated manifest (.mnf) file, which is missing in each case.
6 REPLIES
Predator
Trusted Contributor
Solution

Re: Invalid Support Packs in Version Control Repository

If the mnf files are not created for a particular component, the support which contains that component will be marked as invalid by VCRM.

Browse to VCRM catalog tab, give the option for rescanning the repository.

b/w which versin of 2k3 support pack are you refering to ?

Thnx
Predator
Dan Stebbins
Advisor

Re: Invalid Support Packs in Version Control Repository

I have support packs 8.15, 8.25 and 8.30. All have the same problem. The VCA components are different for each support pack, but it is always the VCA component that has the problem. I have rescanned the repository, restarted it and upgraded it. I verified that the component cpxxx.exe files exist and are good. Still no joy. SIM and VCRM are running on Win2003 Std. SIM version 5.1 SP1, VCRM version 2.1
Daniel Leblanc
Honored Contributor

Re: Invalid Support Packs in Version Control Repository

There are many option
From the command prompt, enter the following command:
vcrmcli.exe /os "OS version"
The command configures the operating systems listed to download ProLiant Support Packs.
Example:
vcrmcli.exe /os â win2003x64, win2003x86, win2008x64, win2008x86, win2k8 R2,
Rhel5, Rhel5x64, Rhel4, Rhel4x64â

Read this document:
http://bizsupport2.austin.hp.com/bc/docs/support/SupportManual/c00293365/c00293365.pdf

hope this help out
Dan Stebbins
Advisor

Re: Invalid Support Packs in Version Control Repository

There is no vcrmcli.exe on the system so I could not try that method. I have manually downloaded the support pack and imported it so I'm not sure the result would be any different. There msut be something about the VCA package causing the problem. It is always the VCA component regardless of the support pack or VCA version. All the other components are successfully imported into the catalog.
Predator
Trusted Contributor

Re: Invalid Support Packs in Version Control Repository

You can find the vcrmcli.exe in the path c:\hp\hpsmh\data\cgi-bin\vcrepository\vcrmcli.exe

If you are using an older version of VCRM, then upgrade to latest released one 2.2.2.835

This is the link for that download
http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&swItem=MTX-e9d33708f449487f99bb443331&jumpid=reg_R1002_USEN

Thnx
Predator
A.Maksimov
Occasional Advisor

Re: Invalid Support Packs in Version Control Repository

For Invalid Support Packs problem on HP Service Pack for ProLiant Version 2013.09.0c (English (US), Japanese)

 

cp013802.symbols.zip - The referenced component is not in the catalog.
cp013803.symbols.zip - The referenced component is not in the catalog.

 

read this:  HP VCRM — Invalid Support Packs — HP Service Pack for ProLiant Version 2013.09.0c