HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

communication Issues with WBEM when identifying systems

 
SOLVED
Go to solution
ALgon
Advisor

communication Issues with WBEM when identifying systems

Hi,

 

CMS Server - Windows 2012 R2

Target server - Widows 2012 R2

Latest version of SIM -7.3 with hotfix

 

Everything was working fine, but for some reason when I attempt to re-identify systems, I get the following error in the task results:

 

Critical: HP SIM cannot communicate with these systems using the WBEM protocol

 

Now I can’t use WBEM to monitor these systems. 

It’s happening on all of my servers so it must be a problem on the CMS server.   For testing, the firewall has been disabled on both the CMS server and target server.

 

Which logs can I check and where are they? 

 

Thanks loads in advance.

7 REPLIES
ALgon
Advisor

Re: communication Issues with WBEM when identifying systems

Here's the results from the task

 

********* Significant issues and overall target discovery/identification
status:
Normal: The system has valid hardware data (model, serial number, and
unique identifier) and has been identified properly for SIM to
manage.
Critical: HP SIM cannot communicate with these systems using the WBEM
protocol.

********* Additional results (listed for information only):

* Starting identification process...
* Checking for known running web servers...
* Checking for SNMP protocol support on system...
Normal: The system responded to an SNMP request; it supports SNMP Protocol
and has a valid read community string.
* Checking for SNMPv3 protocol support on system...
Minor: Global SNMPv3 Identification is disabled.
* Running HP ProLiant management agent identification...
Normal: Identification can get the system information from the ProLiant
SNMP Foundation agents for servers.
* Running SNMP base cluster identification using common cluster
MIB...
Normal: This system does not have the common cluster MIBs support.
* Checking for WBEM protocol support on system...
Minor: This system does not have any SMI-S CIMOMs installed. No storage
systems will be found on this system.
Minor: The Central Management System (CMS) cannot communicate with the
CIMOM locally installed on the managed system using the WBEM
protocol, Identification will try to identify Windows systems using
the WMI Mapper as proxy; for Linux and HP-UX systems, check
credentials by going to Options->Security->Credentials->System
Credentials. For Linux systems also check if the HP WBEM provider
is installed.
* Running WBEM rules based identification...
Minor: Identification cannot get computer system hardware data from the
WBEM / WMI providers.
* Running Virtual Machine (VM) Host (non HP Integrity VM Host)
Identification...
Normal: The system is not a VM Host (non HP Integrity VM Host), or WBEM
credentials may not be specified so skipping VM Identification.
* Running Storage identification...
* Did not detect the WBEM protocol support on this system. SMI
storage identification will be skipped.
* Storage identification completed.
* Running HP NetServer identification...
Normal: System supports the NetServer SNMP agent, adding system type.
* Running HP-UX SNMP identification...
Normal: System does not have the HP-UX SNMP agents installed.
* Running OA Identifier which will discover systems in an enclosure
if the automatic enclosure discovery option for OA is enabled...
Normal: A non-embedded operating system is detected so skipping the OA
identification.
* Running XMLReply Identifier which will discover systems in a
rack/enclosure if the automatic discovery option for the container
node is enabled...
Normal: A non-embedded operating system is detected so skipping the
Management processor identification.
* Running iLO Identifier which will discover the server if the
automatic server discovery option for iLO is enabled...
Normal: A non-embedded operating system is detected so skipping the ILO
identification.
* Running p-Class Identifier...
Normal: The system is not a p-Class so skipping p-Class identification.
* Running IPMI protocol identification...
Normal: Skipping IPMI discovery in favor of WBEM/SNMP discovery.
* Running SSH Protocol identification...
Minor: The system(s) do not have Secure Shell (SSH) installed or it is not
running on the managed system(s).
* Running SSH Identification...
Normal: SSH Protocol is not enabled so skipping SSH Identification.
* Running WS-Man identification...
Normal: A non-embedded operating system is detected so skipping the WS-MAN
identification.
* Running Monarch OA Identification...
Normal: The system is not a monarch OA so skipping monarch OA
identification.
* Checking for System Management Homepage and other HP web agents...
Normal: System Management Homepage (SMH) is installed or is responding on
the system(s).
* Running HP Serviceguard Identification...
Normal: The system is not part of HP Serviceguard cluster.
* Running SNMP System Type manager ...
Normal: No matching SNMP System Type Manager rule for sysObjID was found.
* Running SNMP subtypes identification...
* No additional subtype(s) found from SNMP.
* Resolving DNS names...
Normal: The fully qualified domain name was successfully resolved for the
system.
* Checking if the Node is a Virtual Center...
Normal: Node is not a Virtual Center Node
* Running Virtual Machine Management (VMM) Plug-in Identification...
* Building system relationships...
Normal: The trust between the CMS and the managed system is established.
* Running system Manage Communication diagnosis...
* System identification finished on system.

Andrew_Haak
Honored Contributor

Re: communication Issues with WBEM when identifying systems

Hello thrre,

 

Did you update the Pegasus WMI mapper application? You could update it or uninstall and reinstall the app.

Kind regards,

Andrew
ALgon
Advisor

Re: communication Issues with WBEM when identifying systems

Great, thanks for the reply. 

 

No I didn't.  Is this separate from the SIM hotfix update?  How do I go about updating this?  I take it this is on the CMS sever?

ALgon
Advisor

Re: communication Issues with WBEM when identifying systems

Okay, I found the WMIMapper install file from the SIM hotfix download.  I've re-installed this but it's made no difference to my problem.  Are there any logs I can check to get more details?

ALgon
Advisor

Re: communication Issues with WBEM when identifying systems

I have compared the Pegasus WMI Mapper service on a working SIM server with the non-working SIM server and noticed the account used to run the service is different.  On the non-working system, it's using the local system account. On the working system, it's using the NT SERVICE\WMI Mapper account.  Could this have anything to do with it?  I didn't set this account on the working system, so how do set this on the non-working system.

Andrew_Haak
Honored Contributor
Solution

Re: communication Issues with WBEM when identifying systems

Hello again,

 

I believe that the pegasus app is also a service so change the credentials in the service mmc. The credentials should be configurable at setup. You did uninstall the Pegasus wmi mapper and then do a fresh install? The Wmi mapper app has been updated because of the open ssl bug

Either option should work.

Kind regards,

Andrew
ALgon
Advisor

Re: communication Issues with WBEM when identifying systems

Okay, I completely uninstalled the WMI Mapper and re-installed.  This time it set the correct logon account.  Thanks for your help, Andrew J.  However, I should mention it doesn't allow you to specify an account during install.