StoreVirtual Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Lefthand P4300 - OS 11.0 - The procedure doesn't complete

Padula
Regular Visitor

Lefthand P4300 - OS 11.0 - The procedure doesn't complete

Hi,

 

I am trying to recover a SAN lefthand P4300 using the procedure HP LeftHand P4000 SAN Solutions - System Recovery Procedures  but when the CD with the image start to install the new image I got the following message:

 

**** Starting HP LeftHand OS 11.0.00 1263 CD Installer ****

 

Failed to mount CD...exiting

mount: /mnt/cdrom: not mounted

eject: tried to use '/mnt/cdrom' as device name but it is no block device

eject: unable to find or open device for: 'cdrom'

Auto Imaging Done

Hit CTRL+ALT+DEL to Reboot 

 

Even with the "Auto Imaging Done" after the reboot the machine doesn't show the prompt command to enter and set the network information (IP, Mask, etc)

 

I was trying to download the Lefthand OS 9.5 because my hardware version is the P4300 and not the P4300 G2 but I couldn't find it on HP Business Support Center

 

Procedure link:

http://h20566.www2.hp.com/portal/site/hpsc/template.PAGE/public/psi/mostViewedDisplay/?javax.portlet.begCacheTok=com.vignette.cachetoken&javax.portlet.endCacheTok=com.vignette.cachetoken&javax.portlet.prp_efb5c0793523e51970c8fa22b053ce01=wsrp-navigationalState%3DdocId%253Demr_na-c01852189-1%257CdocLocale%253Den_US&javax.portlet.tpst=efb5c0793523e51970c8fa22b053ce01&sp4ts.oid=3936136&ac.admitted=13...

 

Tks

Danilo

 

 

P.S. This thread has been moved from Storage Area Networks (SAN) (Enterprise) to HP StoreVirtual Storage / LeftHand. -HP Forum Moderator

 

12 REPLIES
Padula
Regular Visitor

Re: Lefthand P4300 - OS 11.0 - The procedure doesn't complete

Hi Grey,

 

 

Tks for you reply. After the post I tried to use the version 9.5 (HP_P4300G2_P4500G2_P4800G2_Storage_System_Quick_Restore_DVD_AX694-11004.iso) and the ISO HP_P4300_4500_Storage_System_Quick_Restore_CD_AX694-11003. I have tried the SAN IQ 8.5 as well, but nothing is working.

 

I all of them I got the same problem.

 

chown: 'root:root' :  invalid user

Error: Expecting "slot=#"

no of drives:0

Filed to open /dev/cciss/c0d0

This machine does NOT meet the requirements for installing LeftHand Networks Sofware

Please view the /root/hwinfo.log log file for more information

Auto Imaging Fone

Hit CTRL+ALT+DEL to Reboot

 

When I checked the hwinfo file it is empty. Look the picture that show the file with 0B of size. If I use the cat or the vi to see the file it shows me that there is nothing inside.

 

I tried to remove half of the HDs (8x300G), So I tried with 4 HDs (number 1 to 4 - slot 5,6, 7 and 8 empty )and nothing changed. After that I tried to remove and put again the memory to confirm that the hardware is OK. The same problem.

 

Do you have other idea? Tks

oikjn
Honored Contributor

Re: Lefthand P4300 - OS 11.0 - The procedure doesn't complete

Do the drives show up in the bios?  looks like there are no drives showing up which would be a problem for installing the OS ;)

 

what is the history with these nodes?  Why do you need to recover them in the first place?

Greybeard
Esteemed Contributor

Re: Lefthand P4300 - OS 11.0 - The procedure doesn't complete

Hi Padula, have you tried the server diagnostics as suggested in the recovey procedure, and did you have the USB key inserted?
_________________________________________________
How to assign points on this new forum? Click the Kudos Star!
Padula
Regular Visitor

Re: Lefthand P4300 - OS 11.0 - The procedure doesn't complete

Hello Oikjn,

 

Yes, I can see the drives at bios. To be honest I don't the story about the nodes, but we have to set up a enviroment for a new project. I need to recover them to set up a IP address to manage the node from the HP manager tool.

 

 

Padula
Regular Visitor

Re: Lefthand P4300 - OS 11.0 - The procedure doesn't complete

Hi Grey,

 

Yes, one of the first things that I did was the hardware test. I used the Proliant DL185 G5 software CD (I found it on the procedure). The hardware is 100% perfect! Another thing that I did was the upgrade of the firmware.

 

I've got the key from HP license support. It's working, because after start the recover procedure, the linux request the key in a pen drive and after validate the key it starts the instalation. After start the installation the errors that I told you apper.

 

Yesterday we tried to boot the machine with 2 and 4GB of ram to see if the quantity of memory should be the default value that came with the server. We got the same errors.

 

 

Greybeard
Esteemed Contributor

Re: Lefthand P4300 - OS 11.0 - The procedure doesn't complete

Hi Padula, not sure about the RAM but the disks should be the same as original spec. Do you have a working node? The failure to find d0 is odd and I'm wondering if pre-configuring the raid would help, provided it gets past root being invalid, odd that it then still looks for disks though. I'm not sure how the LUNs are set up on the 4300 which is why I ask about a working node, to see if setting up the disks to match helps.
_________________________________________________
How to assign points on this new forum? Click the Kudos Star!
Padula
Regular Visitor

Re: Lefthand P4300 - OS 11.0 - The procedure doesn't complete

Hi Grey,

 

Unfortunately I don't have another node here.

I will try to find out if someone has the same enviroment to I have a look. Tks for your help.

Re: Lefthand P4300 - OS 11.0 - The procedure doesn't complete

Hi Danilo,

This weekend i tried to add 2 StoreVirtual P4330 nodes with a factory software version 11.0 to a 10.5 Management cluster consisting of 2 P4300G2 nodes.
Since we have a number of direct connected Windows 2003-R2 servers, 10.5 is the maximum version we can have before losing connectivity.
this requirerd the P4330 nodes to be downgraded to 10.5.
i followed the procedure given by HP to the letter, but received the same error, after the bootsequence said it could not find the licensefile. Which is strange because i added the license file in the format stated by the HP directive. The featurekey_MAC file was placed in the root of the USB key, which was initially created using UNETBootin and extracted the ISO with the quickrestore DVD.
After trying to type in the MAC address after the prompt the error is displayed.
Since you stated that 9.5 als displayed the same errors I did not try to use those.
Did you solve this problem?
Hope to hear from you,

Kind regards,
Eric

Re: Lefthand P4300 - OS 11.0 - The procedure doesn't complete - SOLVED!!

Everyone,

 

The solution to this problem is very elegantly.

Log in to the ILO of the Node.

Select Remote Console.

Force a reboot with the Power Switch from the bar above.

Connect the HP_StoreVirtual_Quick_restore-DVD_for_iSCSI_AX694-11009.ISO using "Virtual Drives" 

and now the Bootprocess runs as it should be.

 

Enter the License key which you received by verifying the "License Entitlement Certificate + MAC address LAN Port1"

restore the node to version 10.5 SAN/IQ.

 

With many thanks to Steven Naudts of HP Support.

 

I hope someone saves a couple of hours with this.

 

kind regards,

Eric

NTRao
Occasional Visitor

Re: Lefthand P4300 - OS 11.0 - The procedure doesn't complete

Hi Team,

 

I have the same problem, but i dont have ILO, i configured LO 100 but in this there is know remote tab to take remote console

 

please find the attachments and suggest needful

 

Thanks & Regards,

NTRao

Robsi
Occasional Visitor

Re: Lefthand P4300 - OS 11.0 - The procedure doesn't complete

Does anyone have a solution for this. 

 

I also don't have the remote console option in the iLO (though it isn't technically an iLO.) 

 

 

Please help -  I need to have these setup tomorrow and I am not getting anywhere! 

 

Thanks