Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Procurve Manager 2.2 Database Faults

PDnet
Advisor

Procurve Manager 2.2 Database Faults

Every time I try to access the DB on the PNM server using MySQL tools the database server faults and stops. The NT Event Viewer returns this error message:

Faulting application mysqld-max-nt.exe, version 0.0.0.0, faulting module mysqld-max-nt.exe, version 0.0.0.0, fault address 0x00138d34.

It doesn't matter if I access it using the CLI or the GUI interfaces, the service crashes. Does anyone have any insight into this problem?

stu...
7 REPLIES
Ralph Bean_2
Trusted Contributor

Re: Procurve Manager 2.2 Database Faults

Hello Stu -

This sort of issue is very difficult to troubleshoot outside of the scope of the sort of data-gathering and problem isolation work of a formal trouble call.

This is not a known problem or symptom to the ProCurve Lab or Support.

Regards,
Ralph
PDnet
Advisor

Re: Procurve Manager 2.2 Database Faults

Thank Ralph. I am pursuing this through other channels as well. Hopefully I will find a resolution in an alternate forum.


thanks

stu...
Ralph Bean_2
Trusted Contributor

Re: Procurve Manager 2.2 Database Faults

stu -

On further thought, I have a theory as to what may be going wrong, although I'll need you to give me the mySQL version so that I'll know whether my theory holds water.

I believe that mySQL tells you the version number when you execute mysql.exe from the command line.

Thanks,
Ralph
PDnet
Advisor

Re: Procurve Manager 2.2 Database Faults

Ralph,
I've got version 5.0.2-alpha-nt-max running on the server.

Have we met?

stu...
Ralph Bean_2
Trusted Contributor

Re: Procurve Manager 2.2 Database Faults

Stu -

I am going to make a wild guess that your last name starts with a 'j', in which case I think that I have had the pleasure of working with you the past.

The correct mySQL version for PCM 2.2.1 and PCM 2.2 AU1 is '5.0.24a-community-nt-max', which is newer than the one you have installed.

There is a good chance that the failure that you've reported is fixed in the new mySQL.

Have you installed any PCM 2.2 Auto Updates yet?

Ralph
PDnet
Advisor

Re: Procurve Manager 2.2 Database Faults

Ralph,
I knew I recognized your name! It's good to talk to you again.

I am up to date on PCM patches. However, I recently received some information on accessing the PCM database from an external machine. To do that, I installed the MySQL Query Browser. I am guessing that back-revved the PCM database engine. I have uninstalled the Query Browser, but the damage appears to be done.

I've tried re-applying the latest patch set to the server, but it will not re-install. I can't find any command line switches for the install program that will allow me to override this default behavior. Am I out of luck until the next PCM update is released? Or is there a way to fix this one.

I think DD has referred this to the lab folks as well, so hopefully we'll get a resolution one way or another.

thanks

stu...
OLARU Dan
Trusted Contributor

Re: Procurve Manager 2.2 Database Faults

stu,
has Ralph solved your problem?