cancel
Showing results for 
Search instead for 
Did you mean: 

How to enable ftp access

 
SOLVED
Go to solution
Robert Peregrin
Frequent Advisor

How to enable ftp access

Hi I have 2 user accounts. One of them (mn011704) has ftp access to one server and the other (rp010650) doesn't have ftp access to the same server.

I need help to verify which configuration file I should edit. The file /etc/ftpd/ftpusers is not found in the server.

The file /var/adm/inetd.sec contains the following entries:


tftp allow \
172.24.34.80 \
172.24.34.81 \
172.30.102.166 \
172.30.102.167 \
172.30.81.215 \
172.30.102.168 \
172.20.7.47 \
172.20.7.48 \
172.20.7.49 \
172.30.81.216 \
172.30.81.217 \
172.30.81.218 \
172.24.30.40 \
172.20.110.11

I was thinking if there is config file for ftp where the user account "mn011704" could be found, then I could also add rp010650.


Regards,

Robert Peregrin
5 REPLIES
Bijeesh
Respected Contributor

Re: How to enable ftp access

Hi,
Is the login shell of both users are same?
If not, add the shell of the denied user in /etc/shells.
Also check syslog.log for the error messages while you are trying to logging.
Robert Peregrin
Frequent Advisor

Re: How to enable ftp access

Hi,

/etc/shells is not found. There was no error found in syslog when I ftp to the server where I have received access denied message.



Regards,

Robert
Bijeesh
Respected Contributor
Solution

Re: How to enable ftp access

Hi,
What is the default shell of these users?
Check it in /etc/passwd file.
#cat /etc/passwd | grep
#cat /etc/passwd | grep

Login Shell of both users are same or not ??
Robert Peregrin
Frequent Advisor

Re: How to enable ftp access

Thanks Bijeesh. The default shell difference was the reason. Now both user accounts can ftp to the servers.
Steven Schweda
Honored Contributor

Re: How to enable ftp access

> [...] Now both user accounts can ftp to the
> servers.

What did you change?

> /etc/shells is not found. [...]

You can make one. Just be sure to include
all the shells which different users may use.