cancel
Showing results for 
Search instead for 
Did you mean: 

how to enable talk

how to enable talk

I want to use the talk facility on HP-UX, following are the entries in

/etc/services
talk 517/udp # conversation
ntalk 518/udp # new talk, conversation

/etc/inetd.conf
ntalk dgram udp wait root /usr/lbin/ntalkd ntalkd

when I want to talk to cord user I type
#talk cord
I get an error

[No connection yet]
[Your party is not logged on]

Can someone guide me please?
12 REPLIES
rariasn
Honored Contributor

Re: how to enable talk

Hi:

No connection yet]
[Your party is not logged on]

User "cord" is not logged yet.

rgs

Re: how to enable talk

even though "cord" user is logged on get the same error msg.
rariasn
Honored Contributor

Re: how to enable talk

Hi:

Verify "mesg" permissions:

mesg [-] y allows applications such as write or talk to send messages to the user's terminal (that is, without restrictions).

man mesg.

grep talk /var/adm/syslog/syslog.log

rgs,



Re: how to enable talk

mesg is set to Y. still it gives the same error.
rariasn
Honored Contributor

Re: how to enable talk

Hi:

# grep -i talk /var/adm/syslog/syslog.log

and verify than "ntalk" is not deny in /var/adm/inetd.sec file

rgs,

Re: how to enable talk

# grep -i talk /var/adm/syslog/syslog.log

Oct 30 00:05:32 cmcdev inetd[1275]: ntalk/udp: Added service, server /usr/lbin/ntalkd

put this entry in
/var/adm/inetd.sec
ntalk allow 127.0.0.1 cmcdev

change and let inetd re-read the configuration, with "inetd -c"

still the same error.

rariasn
Honored Contributor

Re: how to enable talk

Hi Gerard:

Apparently all is well.


# finger cord

# who -T| grep -i cord

# who am i

rgs,

Re: how to enable talk

# finger cord
Login name: cord
Directory: /home/cord Shell: /usr/bin/ksh
On since Dec 3 15:49:47 on pts/te from 172.16.25.121
7 minutes 49 seconds Idle Time
No unread mail
No Plan.

# who -T |grep -i cord
cord + pts/te Dec 3 15:49 0:08 26182 172.16.25.121

# who am i
root pts/tf Dec 3 15:49

# who
cord pts/te Dec 3 15:49
root pts/tf Dec 3 15:49


rariasn
Honored Contributor

Re: how to enable talk

Hi Gerard:

With root user:

# talk cord

Output similar to:

[No connection yet]
[Waiting for your party to respond]

...


rgs,

Re: how to enable talk

# talk cord
[No connection yet]
[Your party is not logged on]
rariasn
Honored Contributor

Re: how to enable talk

Hi Gerard:

Sample of reproduction of the problem

My user is "ran":

$ who -T
ran + pts/3 Dec 3 11:07 . 15148 xxxxxx.intraduero.net
$ tty
/dev/pts/3

I open other hpterm with user "ran":

$ who -T
ran - pts/2 Dec 3 13:02 . 19660 xxxxxx.intraduero.net
ran + pts/3 Dec 3 11:07 . 15148 xxxxx.intraduero.net

$ tty
/dev/pts/2

From this terminal:

$ su -

# id

uid=0(root)

# tty

/dev/pts/2

# who -T
ran - pts/2 Dec 3 13:02 . 19660 xxxxxx.intraduero.net
ran + pts/3 Dec 3 11:07 0:03 15148 xxxxxx.intraduero.net

# talk ran

[No connection yet]
[Your party is refusing messages]

Ok.

- close connections root and ran.

- Open new connection with efective uid ran
- Open new connection with efective uid root (not su)

# who -T

root - pts/2 Dec 3 13:09 . 19862 xxxxxx.intraduero.net
ran - pts/3 Dec 3 13:06 0:02 19777 xxxxxx.intraduero.net

# talk ran

[No connection yet]
[Waiting for your party to respond]

Output from ran terminal:

Message from Talk_Daemon@minerva at 13:11 ...
talk: connection requested by root@minerva.intraduero.net.
talk: respond with: talk root@minerva.intraduero.net

$ talk root

[No connection yet]
[Connection established]

rgs,



gnaid1
Occasional Visitor

Re: how to enable talk

Login with ssh (to get tty like pts/0). If you use telnet you must give the ttyname argument:

 

talk user1@host2 pts/ta

 

In absence of ttyname , talk will try to contact the user
on the user's *most recently used* terminal. ( pts/0, etc.)

 

Also, set 'mesg y' for that tty.

 

Regards,

G