General
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot find block device file for boot device

 
SOLVED
Go to solution
Highlighted
Frequent Advisor

Cannot find block device file for boot device

Hi all, I can't seem to install HP-UX 11.31 September 2008 on my rx6600 with P400 raid controller card.

below is the errors.

Launching :IINSTALL
SIZE: Text:50892K + Data:8336K + BSS:23776K = Total:83006K
Console is on Serial Device - via PCDP
Booting kernel...

0.30.60.7krs_read_mfs: Error 5 opening MFS.
Loaded ACPI revision 2.0 tables.
krs_read_mfs: Error 5 opening MFS.

Memory Class Setup
-------------------------------------------------------------------------
Class Physmem Lockmem Swapmem
-------------------------------------------------------------------------
System : 7762 MB 7762 MB 7762 MB
Kernel : 7762 MB 7762 MB 7762 MB
User : 7095 MB 6290 MB 6315 MB
-------------------------------------------------------------------------

ktracer is off until requested.
Installing Socket Protocol families AF_INET and AF_INET6
Kernel EVM initialized
sec_init(): kernel RPC authentication/security initialization.
secgss_init(): kernel RPCSEC_GSS security initialization.
rpc_init(): kernel RPC initialization.
rpcmod_install(): kernel RPC STREAMS module "rpcmod" installation. ...(driver_install)
NOTICE: nfs_client_pv3_install(): nfs3 File system was registered at index 11.
NOTICE: nfs_client_pv4_install(): nfs4 File system was registered at index 12.
NOTICE: USB device attached. Identification String:
Devices/Device/USB/Standard/hp/Multibay/0_a1
<2.1.3.10.1008.294.161>
NOTICE: USB device attached. Identification String:
Devices/MassStorage-SCSI/USB/BulkOnly/hp/Multibay/0_a1
<2.310.3.150.1008.294.161>
NOTICE: USB device attached. Identification String:
Devices/ScsiControllerAdaptor/USB/BulkOnly/hp/Multibay
<2.1000.3.150.1008.294>
NOTICE: USB device attached. Identification String:
Devices/Device/USB/Standard/hp/Multibay/0_a1
<2.1.3.10.1008.294.161>
NOTICE: USB device attached. Identification String:
Devices/MassStorage-SCSI/USB/BulkOnly/hp/Multibay/0_a1
<2.310.3.150.1008.294.161>
NOTICE: USB device attached. Identification String:
Devices/ScsiControllerAdaptor/USB/BulkOnly/hp/Multibay
<2.1000.3.150.1008.294>
CISS: RAID SA controller on hardware path 0/6/0/0/0/0/4/0/0/0 is now online.

System Console is on the Built-In Serial Interface
iether0: INITIALIZING HP A7012-60601 PCI/PCI-X 1000Base-T Dual-port Adapter at hardware path 0/1/1/0
iether1: INITIALIZING HP A7012-60601 PCI/PCI-X 1000Base-T Dual-port Adapter at hardware path 0/1/1/1
iether2: INITIALIZING HP AB352-60003 PCI/PCI-X 1000Base-T Dual-port Core at hardware path 0/4/2/0
iether3: INITIALIZING HP AB352-60003 PCI/PCI-X 1000Base-T Dual-port Core at hardware path 0/4/2/1
AF_INET socket/streams output daemon running, pid 34
afinet_prelink: module installed
Starting the STREAMS daemons-phase 1
Swap device table: (start & size given in 512-byte blocks)
entry 0 - auto-configured on root device; ignored - no room
WARNING: No swap device configured, so dump cannot be defaulted to primary swap.
WARNING: No dump devices are configured. Dump is disabled.
Create STCP device files
Starting the STREAMS daemons-phase 2
$Revision: vmunix: B.11.31_LR FLAVOR=perf nfsauth: lookupname: 2

Memory Information:
physical page size = 4096 bytes, logical page size = 4096 bytes
Physical: 8357148 Kbytes, lockable: 6451428 Kbytes, available: 7277008 Kbytes

* Preparing to execute init...
======= 08/20/09 06:27:39 EDT HP-UX Installation Initialization. (Thu Aug 20
06:27:39 EDT 2009)
@(#)Ignite-UX Revision C.7.7.93
@(#)ignite/launch (opt) Revision:
/branches/IUX_RA0809/ignite/src@74753 Last Modified: 2008-07-11
12:27:58 -0600 (Fri, 11 Jul 2008)
* Configuring RAM filesystems...
* Scanning system for IO devices...
NOTICE: USB device detached. Identification String:
Devices/MassStorage-SCSI/USB/BulkOnly/hp/Multibay/0_a1
<2.310.3.150.1008.294.161>
NOTICE: USB device detached. Identification String:
Devices/ScsiControllerAdaptor/USB/BulkOnly/hp/Multibay
<2.1000.3.150.1008.294>
NOTICE: USB device detached. Identification String:
Devices/Device/USB/Standard/hp/Multibay/0_a1
<2.1.3.10.1008.294.161>
* Boot device is: 0/0/2/2.0x1.0x10
NOTE: Did not find (disk) devices files for: 0/0/2/2.0x1.0x10 (bmajor: 2
cmajor: 11 minor: 0x0)
ERROR: Cannot find block device file for boot device
15 REPLIES 15
Highlighted
Honored Contributor

Re: Cannot find block device file for boot device

Hi,
some questions, is it a new machine (preloaded) or new install? Did it work before?

Did you configure the P400/build a raidset?

Can you access the filesystem on the EFI shell?
Highlighted

Re: Cannot find block device file for boot device

The path in question is to 0/0/2 - this is the path to the USB subsystem, and not associated with your P400 RAID card - are you trying to install via vMedia? Maybe you are having network issues?

HTH

Duncan

I am an HPE Employee
Accept or Kudo
Highlighted
Frequent Advisor

Re: Cannot find block device file for boot device

Hi,

It is a new machine with no preloaded OS inside.
I have already created RAID 1+0 in the P400 Array Configuration. and inside there I can also see the disk.

I'm installing from a typical DVD disk in the rx6600 dvdrom.
Highlighted

Re: Cannot find block device file for boot device

Then you may have a flaky DVD, DVD drive, or USB interface - do you have another piece of install media you can try?

Alternatively you could try doing the install thro the vMedia interface on the iLO (with the DVD in your desktop PC) - it will be slower, but might get you going...

HTH

Duncan

I am an HPE Employee
Accept or Kudo
Highlighted
Frequent Advisor

Re: Cannot find block device file for boot device

I have tried swaping DVDROM, DVD Media, Harddisk, IO Backplane still no result.

I log a case with HP and they said something to do with USB1.1 and USB2.0. They came and install the HP-UX 11i v3 March 2009 and it works.

I question back HP that I have an identical server and it can able me to install HP-UX 11i v3 September 2008 release. They cannot give me an answer. lol
Highlighted

Re: Cannot find block device file for boot device

hmmm - are you sure both rx6600s had DVD-ROM drives? Are you sure the one that install failed on didn't have a DVD-RW drive?

The DVD-RW device is I think only a USB2.0 device which requires a USB2.0 stack which only appeard in the 0903 media, whereas the DVD-ROM is not as fussy

Just a guess...

Duncan

I am an HPE Employee
Accept or Kudo
Highlighted
Frequent Advisor

Re: Cannot find block device file for boot device

I confirm both DVDROM are identical. I ejected the dvd drive and compared the revision version, firmware, model, part number. all same.

Really lost here...
Highlighted
Solution

Re: Cannot find block device file for boot device

OK I just read a couple of internal case reviews which match your problem... basically the problem was a corner case in the USB1.1 driver which resulted in a timing issue. It meant that the problem was seen on only a very small number of USB based installs, and as we completely re-wrote the USB driver for 0903 anyway, the old driver had been obsoleted and the 0809 DVDs had already shipped, the code in the USB1.1 driver wasn't looked at...

There's some indication that some folks managed to get round the problem by re-scanning their hardware at the first Ignite install screen... but my advice would be to stick with 0903 now...

HTH

Duncan

I am an HPE Employee
Accept or Kudo
Highlighted
Frequent Advisor

Re: Cannot find block device file for boot device

So are you saying that my this problematic server hardware specs is newer then the working server with september 2008 OS?