cancel
Showing results for 
Search instead for 
Did you mean: 

Make install compiling problems

 
Highlighted
Advisor

Make install compiling problems

Hi,

I'm trying to install SAMBA 3.0.29 on my HP-UX 11.11 server, but I cannot do the make or make install. I get the following error:

# make
Make: No arguments or description file. Stop.


# make install
Make: Don't know how to make install. Stop.

I did run the ./configure and it ran for a minute or two doing checks. But now I am stuck here.

Can anyone assist me?

Regards,
Schalk
9 REPLIES 9
Highlighted
Acclaimed Contributor

Re: Make install compiling problems

Do you have a file makefile or Makefile in the current directory?
Highlighted
Advisor

Re: Make install compiling problems

Hi,

None what so ever. Here is search of *make*

gwsae02:root:/data2/depot/samba/samba-3.0.29 # find . -name *make*
./packaging/Debian/debian-sarge/patches/make-distclean.patch
./packaging/Debian/debian-unstable/patches/make-distclean.patch
./packaging/RHEL/makerpms.sh.tmpl
./packaging/Solaris/makepkg.sh
./source/script/makeunicodecasemap.awk

Highlighted
Acclaimed Contributor

Re: Make install compiling problems

>None what so ever.

The others don't have HPUX in them.
Was there any output from configure that indicated it failed/aborted?
Highlighted
Advisor

Re: Make install compiling problems

Please find attached the output of the ./configure

I could not really see anything that failed due to HPUX.

Regards,
SChalk
Highlighted
Acclaimed Contributor

Re: Make install compiling problems

>I could not really see anything that failed due to HPUX.
configure: error: libldap is needed for LDAP support

This looks like the failure.
Highlighted
Advisor

Re: Make install compiling problems

Ok, so what is the next steps I have to take?

Regards,
Schalk
Highlighted
Acclaimed Contributor

Re: Make install compiling problems

>so what is the next steps I have to take?

Was there a runtime dependency for libldap? If so, you'll have to build it first.

Any reason you're not just installing prebuild binaries?
Highlighted
Advisor

Re: Make install compiling problems

There was no prebuild binaries. Or where do I find these?
Highlighted
Acclaimed Contributor

Re: Make install compiling problems

>There was no prebuild binaries. Or where do I find these?

You can download HP CIFS from here:
http://software.hp.com/portal/swdepot/displayProductInfo.do?productNumber=B8725AA

But this is based on: Samba Server version 3.0.22 with selected fixes from 3.0.25 ...